6 Replies Latest reply on Jan 31, 2018 2:52 AM by Raphael_Gassmann

    Upgrade to vCSA 6.5 fails, "this appliance cannot be used or repaired", source and target vCenter left unreachable

    EdSp Novice

      Hi,

       

      I was trying to upgrade our vCenter from 6.0 (6.0.0U2) to 6.5U1. The 2 external platform service controllers (PSC's) were first successfully upgraded. Next and last was the upgrade of the vCenter Appliance itself. All seemed to go well: stage 1 (deploy) done; running stage 2 (upgrade).

       

      The upgrade failed with the message: "This appliance cannot be used or repaired because a failure was encountered. You need to deploy a new appliance. Failure details"

      The failure details show that the java process has failed:

       

      An error occurred while invoking external command : 'Command: ['/usr/java/jre-vmware/bin/java', u'-Djava.endorsed.dirs=/var/opt/apache-tomcat-8.5.8/endorsed', u'-Djava.security.properties=/etc/vmware/java/vmware-override-java.security', u'-Djava.ext.dirs=/usr/java/jre-vmware/lib/ext:/usr/java/packages/lib/ext:/opt/vmware/jre_ext/', u'-classpath', u'/usr/lib/vmware-eam/dbmigrate/dbmigrate.jar:/etc/vmware/../vmware-eam/dbmigrate/:/etc/vmware/../vmware-eam/:/usr/lib/vmware-eam/web/webapps/eam/WEB-INF/classes/:/usr/lib/vmware-eam/web/webapps/eam/WEB-INF/lib/*:/usr/lib/vmware/common-jars/spring-core-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/spring-context-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/spring-beans-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/spring-web-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/log4j-1.2.17.jar:/usr/lib/vmware/common-jars/commons-lang-2.6.jar:/usr/lib/vmware/common-jars/commons-codec-1.6.jar:/usr/lib/vmware/common-jars/commons-logging-1.1.3.jar:/usr/lib/vmware/common-jars/httpclient-4.3.3.jar:/usr/lib/vmware/common-jars/httpcore-4.3.2.jar:/usr/lib/vmware/common-jars/stax2-api-3.0.1.jar:/usr/lib/vmware/common-jars/woodstox-core-asl-4.0.5.jar:/usr/lib/vmware/common-jars/spring-webmvc-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/spring-expression-4.3.5.RELEASE.jar:/usr/lib/vmware/common-jars/commons-io-1.4.jar:/usr/lib/vmware/common-jars/slf4j-api-1.7.12.jar:/usr/lib/vmware/common-jars/slf4j-log4j12-1.7.12.jar', u'com.vmware.eam.dbmigrate.Main']

      Stderr: Picked up JAVA_TOOL_OPTIONS: -Xms32M -Xmx128M '

      Unable to migrate ESX Agent Manager persistent data

       

      At this point I cannot access either the source (6.0) or target (new 6.5) appliance with the vSphere Client (thick/web).

      I searched around and it looks like a possibility that the message printed on Stderr "Picked up ..." may be why the Java process is seen as "failed"???

       

      Any tips greatly appreciated.

      Thanks,

      Ed

       

      Message was edited by: EdSp Added exact source version (6.0.0U2).