4 Replies Latest reply on Jul 31, 2017 12:05 PM by chrisirwin

    USB device not listed for passthrough to VM

    chrisirwin Lurker

      I have two USB Aladdin tokens. However, while one is able to be used for USB passthrough just fine, the other is not.

       

      Output from lsusb shows they have different device IDs:

       

      Bus 001 Device 008: ID 0529:0620 Aladdin Knowledge Systems Token JC

      Bus 001 Device 006: ID 0529:0600 Aladdin Knowledge Systems eToken Pro 64k (4.2)

       

      When attempting to pass the token through, only one USB token (0529:0600) is listed. The 0529:0620 token is not even in the list.

       

      Selection_001.png

      Host is ESXi 6.5

      vCenter is 6.5. I'm using the HTML5 UI to launch the remote console

      vmrc is 10.0.1 build-5898794

      Client Fedora 25 & 26

       

      This token is listed, and passes through sucessfully with vmrc on Windows 10, but not Linux.

       

      To me, this looks to be some sort of issue with the usbarbitrator, but I have found little documentation on actually troubleshooting that.

        • 1. Re: USB device not listed for passthrough to VM
          bluefirestorm Master

          Try adding the following two lines to the VMX configuration of the VM. This works in the VMware Workstation (Windows/Linux) and Fusion (macOS) and presumably it works in similar ways to VMRC.

           

          usb.generic.allowCCID = "TRUE"

          usb.ccid.disable = "TRUE"

           

          What these two lines do is to disable the CCID sharing between VMs. When a CCID device is shareable between VMs, it does not appear in the "Removable Devices" list.

          • 2. Re: USB device not listed for passthrough to VM
            chrisirwin Lurker

            Hi, thanks for the suggestion bluefirestorm.

             

            I'm not sure I can modify the vmx file, as the VM is running on an ESXi server (not locally)

            • 3. Re: USB device not listed for passthrough to VM
              bluefirestorm Master

              There are few different ways to edit the vmx configuration of a VM in ESXi 6.5, You just have to pick the one you have access to and/or most comfortable with. In all cases, the VM should be powered off (not suspended) when you want to edit the vmx configuration. Advisable to back up the vmx file especially if you are editing it manually through a text editor.

               

              Here are some ways to do it:

              1. Login via console/SSH and go to the datastore where the VM is stored and edit using vi
              2. Download the vmx file from the datastore, edit locally in a PC and then upload again to the datastore
              3. Go the ESXi UI client, edit VM settings, VM Options tab, Advanced, there is a Configuration Parameters with "Edit Configuration" button and use the "Add Parameter" option to add those two lines.
              4. Ask your ESXi administrator to do it if you don't have any of the access rights to 1 through 3.

               

              • 4. Re: USB device not listed for passthrough to VM
                chrisirwin Lurker

                Well, you had the right settings, but the wrong place to put them.

                 

                I attempted to update the vmx file in vcenter, but I wasn't quite sure how to do it in the html5 UI (the thick client is apparently not available anymore). I ended up just using vi to modify the vmx file directly. This did not have any effect, as I suspected, as the vmrc client which shows the issue runs locally on my workstation, not on the ESX server.

                 

                While looking for for what configuration vmrc might be using, I found there is a .vmware directory in my homedir (No XDG_CONFIG?!?), that has a preferences file. I added the two suggested ccid settings there, on my client machine.

                 

                $ cat ${HOME}/.vmware/preferences | grep usb

                usb.generic.allowCCID = "TRUE"

                usb.ccid.disable = "TRUE"

                 

                The token is now listed as a removable device. I'm able to successfully pass it through, and it works in the guest VM.