6 Replies Latest reply on Oct 16, 2017 1:19 AM by noogle

    VMWare Tools in Debian Jessie

    robvun Lurker

      Debian Jessie is installed on VMWare using a Mac. I followed these guidelines to install Open VM Tools:
      VMware Documentation for Debian 8 

       

      Sharing files between OS X and Debian Jessie proves not possible, Debian Jessie tels me to install VMWare Tools.

       

      According to the same guidelines VMWare Tools can only be installed in text mode, not in graphical mode.

       

      Problem: how to get Debian Jessie in text mode?

        • 1. Re: VMWare Tools in Debian Jessie
          wila Guru
          User ModeratorsCommunity Warriors

          Hi,

           

          You can just install VMware Tools in a terminal window in Jessie, you can stay in graphical mode, no need to switch.

           

          It sounds like that the vmware host guest share drivers are broken in the open vmtools variant of Jessie, this is also an issue in a few versions of ubuntu.

          Guess they might share some code there.


          The easiest solution is to install the vmware tools version that comes with VMware Fusion.

          But before you do, completely remove the open vm tools variant from debian.

           

          sudo apt-get purge open-vm-tools

          sudo apt-get purge open-vm-tools-desktop

           

          then select install VMware Tools from the virtual machine menu in Fusion. Note that this just presents a CDrom to the guest, so you will have to install

           

          If you're not sure on how-to do that, then here's a script I've used in the past:

           

          #!/bin/bash
          
          sudo apt-get update
          sudo apt-get upgrade
          echo "Do go and mount your cdrom from the VMware menu"
          echo "press any key to continue"
          read -n 1 -s
          mount /dev/cdrom
          cd /media/cdrom0
          cp VMwareTools-*.tar.gz /tmp
          cd /tmp
          tar xvzf VMwareTools-*.tar.gz
          cd vmware-tools-distrib/
          sudo apt-get install --no-install-recommends libglib2.0-0
          sudo apt-get install --no-install-recommends build-essential
          sudo apt-get install --no-install-recommends gcc-4.3 linux-headers-`uname -r`
          sudo ./vmware-install.pl --default
          
          sudo /etc/init.d/networking stop
          sudo rmmod pcnet32
          sudo rmmod vmxnet
          sudo modprobe vmxnet
          sudo /etc/init.d/networking start
          

           

           

          hope this helps,

          --

          Wil

          | Author of Vimalin. The VMware Fusion Backup app |
          | More info at http://www.vimalin.com |
          | Twitter @wilva |
          | Wiki at http://www.vi-toolkit.com |
          | http://www.vimalin.com/why-is-time-machine-not-a-good-backup-for-virtual-machines/ |
          • 2. Re: VMWare Tools in Debian Jessie
            robvun Lurker

            Alas:

             

             

            /tmp/vmware-tools-distrib$

            sudo apt-get install --no-install-recommends gcc-4.3 linux-headers-`uname -r`

             

            Reading package lists... Done

            Building dependency tree      

            Reading state information... Done

             

            Package gcc-4.3 is not available, but is referred to by another package.

            This may mean that the package is missing, has been obsoleted, or

            is only available from another source

             

             

            E: Package 'gcc-4.3' has no installation candidate

            • 3. Re: VMWare Tools in Debian Jessie
              wila Guru
              Community WarriorsUser Moderators

              Hi,

               

              OK, as I said, I used in the past, aka it was an old script.

               

              Looks like Jessie has gcc-4.9

              Adjust it to that and hopefully it will install.

               

              --

              Wil

              | Author of Vimalin. The VMware Fusion Backup app |
              | More info at http://www.vimalin.com |
              | Twitter @wilva |
              | Wiki at http://www.vi-toolkit.com |
              | http://www.vimalin.com/why-is-time-machine-not-a-good-backup-for-virtual-machines/ |
              • 4. Re: VMWare Tools in Debian Jessie
                robvun Lurker

                Obviously GCC is already present in Debian Jessie, so I proceeded to:

                 

                sudo apt-get install linux-headers-$(uname -r)

                 

                After that

                sudo ./vmware-install.pl --default

                resulted in an automatic [no] without the option to say yes

                with a text telling me I should use Open VM Tools

                (thank you very much but that's not what I was aiming for)

                 

                so I changed this line into:

                sudo ./vmware-install.pl

                after which I could install VMWare tools.

                 

                Of course, before using sudo, which is not included in Debian, I had to follow these instructions:
                su

                [root password)

                apt-get install sudo

                 

                Add your username to the sudo group

                    - Type in the following command...

                        adduser yourusernamehere sudo

                    - then press [enter]

                   

                Now add your name to /etc/sudoers file

                    - Type in the following command...

                        nano /etc/sudoers

                    - then press [enter]

                    - Scroll down and look for the line "%sudo  ALL=(ALL:ALL) ALL"

                    - Below that line type in the following...

                        yourusernamehere  ALL=(ALL:ALL) ALL

                    - Press "Ctrl+x" then press "y" and then press [enter] to exit and save the file

                 

                Now the full screen option is working as it should and I can drag files from Mac to Debian and back.

                 

                Thanks, Wila, for your help. All in all the whole procedure is extremely user-unfriendly.

                • 5. Re: VMWare Tools in Debian Jessie
                  wila Guru
                  Community WarriorsUser Moderators

                  Hi,

                   

                  Yes the original idea with having open-vm-tools upstream with the linux distributions is basically the step meant to alleviate these kind of issues.

                   

                  The problem is that distributions upstream do not tend to patch much, so if something is broken in the open-vm-tools package then it becomes the opposite of convenient an even bigger PITA as before.

                  Unfortunately so far open-vm-tools does not have a great track record on improving the install/update experience, at least not on the debian side of things.

                   

                  --

                  Wil

                  | Author of Vimalin. The VMware Fusion Backup app |
                  | More info at http://www.vimalin.com |
                  | Twitter @wilva |
                  | Wiki at http://www.vi-toolkit.com |
                  | http://www.vimalin.com/why-is-time-machine-not-a-good-backup-for-virtual-machines/ |
                  • 6. Re: VMWare Tools in Debian Jessie
                    noogle Novice

                    The perl script worked a treat for me, only modification was to remove the --default option which otherwise stopped the installation from going ahead. With this done I have file sharing, window resizing, and drag-drop from VM to host. Only bit not working is drag and drop from host back to VM.

                     

                    I grabbed a screen recording of my VM installation and the VMWare Tools as well..

                     

                    * Raspberry Pi Desktop - Virtual Machine and VMWare Tools - YouTube

                     

                    Thanks - Jon