7 Replies Latest reply on May 18, 2017 5:30 PM by dariusd

    How to disable system beep on vm startup?

    Entegy Hot Shot

      Some of my vms are making very annoying system beeps upon their startup. How can I disable this? I found one solution that said to add the line mks.beep = "FALSE", but then I get an error message upon starting the vm saying "Invalid parameter for mks.beep, using default "TRUE"" or something like that.

        • 1. Re: How to disable system beep on vm startup?
          a.p. Guru
          User ModeratorsCommunity WarriorsvExpert

          The entry you mention shoud read mks.noBeep = "true". see http://www.sanbarrow.com/vmx/vmx-advanced.html

           

          André

          • 2. Re: How to disable system beep on vm startup?
            sflanders Master
            vExpertVMware Employees

            I have seen this issue with Workstation on actions such as power on, but also others. My solution was just to disable Windows beep. See: http://www.howtogeek.com/howto/windows/turn-off-the-annoying-windows-xp-system-beeps/

            • 3. Re: How to disable system beep on vm startup?
              Entegy Hot Shot

              That was the site I found the line on. Looking at the VMX again, somehow the "TRUE" had become ìTRUEì. Fixed the quotations.

              • 4. Re: How to disable system beep on vm startup?
                mccog Lurker

                I have set mks.noBeep = "true" in my .vmx file and exported the vm.

                A Developer had imported the vm into his machine, but then the vm in his machine still beeps.

                I told him to add the parameter in the .vmx file and it stopped beeping.

                I am wondering if there would be a permanent way to disable the beep.

                Because we update our VMs frequently and the Devs import the latest VM into their machines every 2 weeks.

                And we always the beep across the room.

                • 5. Re: How to disable system beep on vm startup?
                  dariusd Virtuoso
                  VMware EmployeesUser Moderators

                  Which version of Workstation are you using?  The beep should only occur if there is a problem during boot.  Certain VM configurations with Workstation 10.0.0 and 10.0.1 had a problem with boot device selection and would beep if there were no bootable IDE devices in the system; That problem was corrected in Workstation 10.0.2 and newer.

                   

                  If you're encountering beeps on boot with a newer version of Workstation, please post the VM's vmware.log as an attachment here (just look for the Attach button in the lower-right corner when composing a reply).

                   

                  Cheers,

                  --

                  Darius

                  • 6. Re: How to disable system beep on vm startup?
                    mccog Lurker

                    Thank you for your reply.

                     

                    It is not during boot.. it is when you type in vi.

                     

                    I have modified /etc/inputrc, removing the comment for set bell-style none

                     

                    Although editing the .vmx file resolves the issue, we have to re-do it each time we import a new VM and in every machine we import it.

                    There must be a permanent way we can set it, so when we export the VM, the settings are already in place, and when it is imported in another machine, there will be no beeping sound.

                    • 7. Re: How to disable system beep on vm startup?
                      dariusd Virtuoso
                      User ModeratorsVMware Employees

                      The speaker beep is considered an integral part of the VM's functionality, and the custom option to suppress it using mks.noBeep is not preserved through an OVF export/import.

                       

                      If you are moving the VM between computers running similar versions of Workstation, you don't need to use OVF.  Simply power off the VM, zip or tar up the VM's files, copy the zipfile/tarball to the destination, and unpack it there.  That will preserve the mks.noBeep option.

                       

                      Another way to configure a Linux-based guest OS itself so that it does not beep is to prevent the pcspkr kernel module from loading.  Depending on your Linux distribution, you can probably do this by creating a file at /etc/modprobe.d/pcspkr.conf inside the guest, with the following contents:

                       

                         blacklist pcspkr

                       

                      That will inhibit loading the pcspkr driver on the next boot.  I do the same thing on physical machines if I don't want them to beep.  If you put that pcspkr.conf  into your master VM image, it should take care of the problem without requiring that OVF handle the mks.noBeep option.  If you also want to unload it immediately (without requiring a reboot), run (as root) the following command:

                       

                         rmmod pcspkr

                       

                      Cheers,

                      --

                      Darius