5 Replies Latest reply on Mar 27, 2017 12:29 AM by p_hall

    Loading of datastores slow in web client

    tekhie999 Novice

      Hi all

       

      I am setting up replication jobs for SQL VM's with numerous VMDK's.  There are different target datastores for the type of disk, so i need to use the Advanced configuration and do each VMDK at a time.  The Target VCentre manages a lot of datastores, and when i am trying to select the datastore to replicate to it takes several minutes for the datastores to populate.  I then select the one i want, and move onto the next VMDK, where i have to wait again for the datastores to load. It can take up to 30 minutes to setup 1 replication job - 95% of that tme is waititng for the datastores to load.

       

      Does anyone know if there is a way around this ? Any help would be much appreciated !

       

      Thanks

        • 1. Re: Loading of datastores slow in web client
          mellis99 Novice
          vExpert

          I have the same issue. It takes forever to load. Are you still having this issue?

          • 2. Re: Loading of datastores slow in web client
            astardjiev Enthusiast
            VMware Employees

            Hi tekhie999,

             

            Thanks for posting.

             

            Two questions:
            1. Would you please give me an idea of the size of the environment in which the datatores' list is slow to load: how many hosts and how many datastores have you got?

            2. Which version of vSphere Replication have you got?

             

            Best,

            Hristo

            • 3. Re: Loading of datastores slow in web client
              jkakari Lurker

              Was there ever a followup to this?

               

              I have the same situation here.  The datastore selector is glacial.

               

              vSphere Replication version 6.1.0.10819, build 3051487.  I can't use a newer version since for this project I'm stuck with down-level vCenter servers.

               

              The sites are ~3000 mi apart so there is considerable WAN latency.  However, the data returned to the source server shouldn't be big enough to care.  (Or, maybe it does?)

               

              Target site has ten hosts, 53 datastores.

               

              The "For optimal performance, only 20 of 53 datastores are displayed..." message is of little comfort when I then have to filter to find the target I really want.

               

              This is _excruciating_ since I have a number of machines I can't configure in a batch with others, and a few with RDMs that I have to manually de-select.  (Which causes another problem, but the performance is the bigger issue.)

              • 4. Re: Loading of datastores slow in web client
                kegwell Enthusiast

                Any updates to this?  I too am experiencing a VERY long "Select Target Location" page load.  It takes approximately 2 minutes to load the list of 25 datastores over about 10 ESX hosts.  Many machines have multiple vDisks, so i have to sit at this 2 minute screen for every disk.  That turns into a 10-15 minute job for each virtual machine I setup replication on.  Any thoughts on speeding up this load time?

                • 5. Re: Loading of datastores slow in web client
                  Hot Shot

                  What version of Replication are you using? There was a code change that improved this behavior when there are a lot of datastores on the target site. In newer builds it should be a bit faster when viewing target datastores...