5 Replies Latest reply on Dec 22, 2016 8:49 AM by EfiVg

    VMWare Workstation on Linux DNS adding localdomain to response

    rpiercey Lurker

      My VMware workstation 12.1 adds ".localdomain" to any queries response on the NAT address DNS Server.

       

      > server 172.20.142.2

      Default Server:  [172.20.142.2]

      Address:  172.20.142.2

       

      > www.vmware.com

      Server:  [172.20.142.2]

      Address:  172.20.142.2

       

      Name:    e751.dscx.akamaiedge.net

      Addresses:  173.223.98.234

                173.223.98.234

      Aliases:  www.vmware.com.localdomain

       

      When I use a true dns server - I get the correct response.

      > www.vmware.com

      Server:  [8.8.8.8]

      Address:  8.8.8.8

       

      Non-authoritative answer:

      Name:    e751.dscx.akamaiedge.net

      Addresses:  2600:141b:5:283::2ef

                2600:141b:5:280::2ef

                96.7.203.51

      Aliases:  www.vmware.com

                www.vmware.com.ds.edgekey.net

       

      I can use the true DNS server in the settings for my VM - but I travel around and it is a pain changing this all the time.

       

      I have tried a complete new install of Opensuse 13.1 and 42 Linux with Workstation 12 and I get the same result. I have tried many different guest OS Windows\Linux - all with the same result.

       

      This use to work fine in 8,9,10, I think it stopped working after a patch in 10 or 11.

        • 1. Re: VMWare Workstation on Linux DNS adding localdomain to response
          Shawn Hu Hot Shot
          VMware Employees

          Hello,

           

          Welcome to Workstation Community!

           

          I cannot reproduce your problem with Ubuntu 15.10 guest and win8.1 host:

          2016-01-05_10-32-39.png

          (Note: I didn't try with www.vmware.com because I'm inside the domain...)

           

          I guess it may be some changes to the local DNS server of your network. So could you please try below command on your host OS?

           

          nslookup www.vmware.com
          

          or

          nslookup www.redhat.com
          

           

           

          Thanks,

          Shawn

          • 2. Re: VMWare Workstation on Linux DNS adding localdomain to response
            rpiercey Lurker

            My Host is Linux (OpenSuse 13.2) also tried OpenSuse Leap 42, not windows, DNS works fine on the host - it's just the VM's that get the incorrect response.

             

            If you look at the file :/etc/vmware/vmnet8/dhcpd/dhcpd.conf

             

            I am pretty sure that the supply of the domain name is causing the issue - however if you edit this file it no longer works at all..... does anyone know how to change the options for dhcp?

             

            # Configuration file for ISC 2.0 vmnet-dhcpd operating on vmnet8.

            #

            # This file was automatically generated by the VMware configuration program.

            # See Instructions below if you want to modify it.

            #

            # We set domain-name-servers to make some DHCP clients happy

            # (dhclient as configured in SuSE, TurboLinux, etc.).

            # We also supply a domain name to make pump (Red Hat 6.x) happy.

            #

             

             

            ###### VMNET DHCP Configuration. Start of "DO NOT MODIFY SECTION" #####

            # Modification Instructions: This section of the configuration file contains

            # information generated by the configuration program. Do not modify this

            # section.

            # You are free to modify everything else. Also, this section must start

            # on a new line

            # This file will get backed up with a different name in the same directory

            # if this section is edited and you try to configure DHCP again.

             

            # Written at: 12/15/2015 12:32:22

            allow unknown-clients;

            default-lease-time 1800;                # default is 30 minutes

            max-lease-time 7200;                    # default is 2 hours

             

            subnet 172.20.142.0 netmask 255.255.255.0 {

                    range 172.20.142.128 172.20.142.254;

                    option broadcast-address 172.20.142.255;

                    option domain-name-servers 172.20.142.2;

                    option domain-name localdomain;

                    default-lease-time 1800;                # default is 30 minutes

                    max-lease-time 7200;                    # default is 2 hours

                    option netbios-name-servers 172.20.142.2;

                    option routers 172.20.142.2;

            }

            host vmnet8 {

                    hardware ethernet 00:50:56:C0:00:08;

                    fixed-address 172.20.142.1;

                    option domain-name-servers 0.0.0.0;

                    option domain-name "";

                    option routers 0.0.0.0;

            }

            ####### VMNET DHCP Configuration. End of "DO NOT MODIFY SECTION" #######

            • 3. Re: VMWare Workstation on Linux DNS adding localdomain to response
              jhsnyder Lurker

              FWIW I see the same behavior on archlinux with kernel 4.4.5-1, VMware 12.1, and Win7Pro guest using NAT.

               

              A quick work-around is to manipulate the Windows guest network settings so that the default DNS server is external to the host. I set the guest DNS to my network router, rebooted, and now DNS works.

               

              (Kinda implied in the first post here.)

               

              This seems to be an uncommon problem. It might be that it occurs only on networks with a named domain (e.g. myveryowndomainname rather than no-name); I haven't experimented.

               

              It also seems to be an entirely artificial problem created by vmware workstation 12 configuration. I didn't have this problem with Workstation 11.

              • 4. Re: VMWare Workstation on Linux DNS adding localdomain to response
                raiford Enthusiast

                This is the same issue as reported earlier today in regards to the vmnat-natd having an issue with the new glibc library.  I have the problem with Ubuntu 16.04 LTS and Workstation 12 Pro.  Attached is a screenshot similar to the one above showing Ubuntu 15.10 working.

                 

                Note that this happens on Linux Hosts.  It is not a problem with Windows hosts.

                • 5. Re: VMWare Workstation on Linux DNS adding localdomain to response
                  EfiVg Novice

                  Had the exact same issue a few days ago. This is how I solved it.

                   

                  On Wmware I clicked on edit > Virtual network editor

                  Clicked on the third one (NAT) then NAT settings then DNS settings.

                  Unchecked "Auto detect available DNS servers" and set manually two DNS servers. First one should be 8.8.8.8 (Google DNS server)

                  Then I tried to ping google.com and everything worked great without that "localdomain" which makes everything slower. 

                  In the next morning I went back, removed those DNS and checked again "Auto detect available DNS servers".

                   

                  I guess that refreshed the DNS inside the Linux and fixed the issue because now everything works normally