2 Replies Latest reply on Sep 19, 2016 8:07 AM by komanek

    VDP 6.0.3.3 after vCenter server upgrade to 5.5 update 3e is not working

    komanek Enthusiast

      Hello,

       

      I am running VDP 6.0.3.3. Before I upgraded my vCenter Server from 5.5u3b to 5.5u3e, I consulted Vmware interoperability matrixes to see that there should be no problem. But the opposite has happened:

       

      All backups end up with the error:

      VDP: An attempt made to backup a client failed because no data was found that matches the type of data that the job was configured for.

      XXX com.vmware.vdp2.server.error.30915.formatOnVm not found XXX

      XXX com.vmware.vdp2.server.common.error.code.formatOnVm not found XXX

       

      I retired one of the VMs, it is no longer in the clients list. But I cannot add it back to the job. In fact, I am not able to add any VM to any job, even those which were never backed up by VDP. The error message is:

      VDP: Unable to add client "AAA" to the VDP appliance while creating/editing backup job "BBB". (Full client path: ?)

       

      Do you have an idea, what is going on and how to resolve it ? It's quite urgent.

       

      Thank you in advance.

       

      Regards,

      David

        • 1. Re: VDP 6.0.3.3 after vCenter server upgrade to 5.5 update 3e is not working
          komanek Enthusiast

          Hello,

           

          I was eager to resolve it, so I tried to upgrade to VDP 6.0.4 in the hope it is tested against current vCenter version. Unfortuntately, the release info talks about kernel patch which should be part of the installation ISO, but it isn't there. and yes, the upgrade did not succeed.

           

          Next step was to abandon current backups and remove VDP completely (deleted from inventory, removed from vCenter registry through MOB methods invocation and removed from vCenter Web Client folder, all according to KBs) and to install it from scratch, step by step according to installation guide. Not even this works: the OVF deployment and configuration wizard aparently succeed, but after next reboot, it is stuck at 70% of "VDP: configuring appliance" task for 8 hours. Web interface to VDP is still just the configuration wizard. Of course, there is no VDP icon in vCenter Web client and in the MOB registry is only one extension registered (com.vmware.vdp2.config is there as expected, but com.vmware.vdp2 is missing).

           

          So it seems VDP is not an option for me anymore. There were many problems with it in all previous versions, maybe now it's the right time to abandon it completely. I am writing my story here, just in case somebody knows how to push the VDP configuration to the end and make it usable. Or am I the last one who is still using this piece of .... ?

           

          D.

          • 2. Re: VDP 6.0.3.3 after vCenter server upgrade to 5.5 update 3e is not working
            komanek Enthusiast

            Hello,

             

            finally, I found a solution, which was hard for me to find: VDP 6.1.2 appliance can't connect to vCenter after initial configuration

             

            So the problem appears after upgrade to vCenter 5.5u3e and affects at least both 5.8.x and 6.0.x versions of VDP appliance. I have two instances of vCenter, on one I verified that it helped to reconnect an existing appliance to a vCenter server, the other was new installation, also successful with the help of the same community discussion thread. I have no idea if there is a working solution for VDP appliance in-place upgrade, for that question please follow the aforementioned thread.

             

            I was not easy for me to find the solution, what helpew me was to analzye vdr-configure.log and search for error messages found there.

             

            Well, I think it's worth of mentioning this problem in vCenter release notes or even releasing VDP 6.0.5 ....

             

            Regards,

             

            David