3 Replies Latest reply on Aug 16, 2016 1:16 PM by sowmya123

    vCenter Server Appliance update and VMware Tools

    racom Enthusiast

      I've just updated VCSA to 5.1.0.10000 Build 1065184. I had to uninstall VMware Tools first 'cause update failed with

       

      "VMware Tools cannot install because it appears that another installation of

      VMware Tools is already present. Please remove the previous installation and

      then attempt to install this copy of VMware Tools again."

       

      error in /opt/vmware/var/log/vami/updatecli.log (I had similar problem with previous update).

      After update I can see in this log:

       

      "22/05/2013 14:43:48 [INFO] Running /opt/vmware/share/vami/vami_reconfigure_tools

      VMware tools is not installed on this VM.

      22/05/2013 14:43:48 [INFO] Update status: Done VMware tools reconfiguration"

       

      Should I install VMware Tools via vSphere Web Client again? I supposed VMware Tools to be installed by VCSA update. I can see packages anyway:

       

      vm-vcenter:~ # rpm -qa|grep -i vmware-tools

      vmware-tools-vmmemctl-kmp-default-1.2.1.2_3.0.13_0.27-3

      vmware-tools-vmxnet-kmp-default-2.0.14.0_3.0.13_0.27-3

      vmware-tools-services-9.0.5-1.sles11

      vmware-tools-plugins-hgfsServer-9.0.5-1.sles11

      vmware-tools-plugins-vmbackup-9.0.5-1.sles11

      vmware-tools-vmci-common-9.0.5-1.sles11

      vmware-tools-vsock-kmp-default-9.3.3.0_3.0.13_0.27-3

      vmware-tools-libraries-nox-9.0.5-1.sles11

      vmware-tools-vmmemctl-common-9.0.1-3

      vmware-tools-core-9.0.5-1.sles11

      vmware-tools-plugins-autoUpgrade-9.0.5-1.sles11

      vmware-tools-plugins-guestInfo-9.0.5-1.sles11

      vmware-tools-plugins-powerOps-9.0.5-1.sles11

      vmware-tools-plugins-vix-9.0.5-1.sles11

      vmware-tools-esx-kmods-default-9.0.5-1.sles11

      vmware-tools-vmxnet-common-9.0.5-1.sles11

      vmware-tools-vmci-kmp-default-9.3.18.0_3.0.13_0.27-3

      vmware-tools-guestlib-9.0.5-1.sles11

      vmware-tools-plugins-deployPkg-9.0.5-1.sles11

      vmware-tools-plugins-timeSync-9.0.5-1.sles11

      vmware-tools-esx-nox-9.0.5-1.sles11

      vmware-tools-vsock-common-9.0.5-1.sles11

      vmware-tools-foundation-9.0.5-1.sles11

       

      But I can't start daemon:

       

      vm-vcenter:~ # /etc/init.d/vmware-tools-services start

         Starting VMware Tools guest operating system daemon:               failed

        • 1. Re: vCenter Server Appliance update and VMware Tools
          racom Enthusiast

          I've tried to install VMware Tools by mounting "CD" and running vmware-install.pl but it's not possible 'cause they were installed by update:

           

          VMware Tools cannot be installed, since they have already been installed using

          a package-based mechanism (rpm or deb) on this system. If you wish to continue,

          you must first remove the currently installed VMware Tools using the

          appropriate packaged-based mechanism, and then restart this installer

           

          Execution aborted.

           

           

          Any idea, please?

          • 2. Re: vCenter Server Appliance update and VMware Tools
            racom Enthusiast

            Following support I've removed /usr/lib/vmware-tools/ directory and was able to run vmware-install.pl and install VMware Tools 9.0.1.18551 (build-913578) then.

             

            I'm still confused why vmware-tools-services-9.0.5-1.sles11 and other packages installed during VCSA update didn't work.

            • 3. Re: vCenter Server Appliance update and VMware Tools
              sowmya123 Lurker

              Un-installing an re-installing of the VMWare tools on VCSA 5.5 worked. But i still see that the VMWare Tools for the Simulated hosts still show as "Not Installed". Looking for info/help for installing the vmware tools on simulated hosts as well.