0 Replies Latest reply on Aug 16, 2016 8:33 AM by Vision1988

    Can't running test in passive mode

    Vision1988 Novice

      While running test in ViewPlanner 3.6 got error in ViewPlanner.log

       

      2016-08-16 17:42:13,171 ERROR    Error from the remote: Error in mapping prefixes with error: 2004: Error in mapping VM Prefixes to Pools: string indices must be integers, not str

      Traceback:

      Traceback (most recent call last):

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\listener.py", line 194, in remote_mapPrefixToPool

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\viewadmin.py", line 142, in mapPrefixToPool

      TypeError: string indices must be integers, not str

       

       

      Unhandled error in Deferred:

      Unhandled Error

      Traceback from remote host -- Traceback unavailable

      2016-08-16 17:42:15,443 DEBUG    Returning the current status: 0 with message Error in mapping prefixes with error: 2004: Error in mapping VM Prefixes to Pools: string indices must be integers, not str

      Traceback:

      Traceback (most recent call last):

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\listener.py", line 194, in remote_mapPrefixToPool

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\viewadmin.py", line 142, in mapPrefixToPool

      TypeError: string indices must be integers, not str

      . Please see viewplanner.log for more details

      2016-08-16 17:42:17,937 DEBUG    Waiting for the prefixes map to be fetched from View server.

      and so on.

       

      I tried to restart ViewPlanner Agent at ViewServer and and vdiappd server, but it's not effective. Also tried to exit and enter into domain, same trouble/

       

      Harnessip is correct, here is my IP.txt from ViewServer

      HARNESSIP=192.168.80.242

      VIEWIP=

      LOGIN=

      PASSWORD=

      DOMAIN=

       

      Here is result from command line form ViewServer

       

      PS C:\> python serviceagent.pyc debug

      Debugging service ViewPlannerAgent - press Ctrl+C to stop.

      Staring the ViewPlanner Agent service.

      Starting the twisted server on the machine for harness to send commands....

      192.168.80.242 None None None None

      Connection status: True

      Getting the harness root object from the harness: 192.168.80.242

      Adding the callback for getting the root object from the appliance

      Error 0xC0000003 - The instance's SvcRun() method failed

       

       

      Traceback (most recent call last):

        File "C:\Python26\lib\site-packages\win32\lib\win32serviceutil.py", line 806, in SvcRun

          self.SvcDoRun()

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\serviceagent.py", line 73, in SvcDoRun

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\twisted_interface.py", line 39, in listen

        File "C:\Python26\lib\site-packages\twisted\internet\posixbase.py", line 419, in listenTCP

          p.startListening()

        File "C:\Python26\lib\site-packages\twisted\internet\tcp.py", line 857, in startListening

          raise CannotListenError, (self.interface, self.port, le)

      CannotListenError: Couldn't listen on any:9200: [Errno 10048] Only one usage of each socket address (protocol/network ad

      dress/port) is normally permitted.

       

      Please, help.