2 Replies Latest reply on Apr 25, 2016 4:17 AM by lvaibhavt

    Able to take quiesce snapshot for a VM with no VM tools !

    lvaibhavt Hot Shot

      Hi All,

       

       

      In my home lab I am running esxi 5.5 and recently noticed that I create a Windows 7 x32 VM. I did not install VMware tools and I was still able to take quiesce snapshot from VI client and from the web client.

       

       

      AFAIK for quiesce snapshot you need VMware tools in the guest OS -- right? How is this possible.

       

       

       

       

      Thanks

        • 1. Re: Able to take quiesce snapshot for a VM with no VM tools !
          Gortee Hot Shot

          Morning,

           

          Sorry about the delay.  You cannot take a quiesce snapshot without tools installed and running.  The process is as follows:

           

          You initiate a quiesce snapshot

          ->vCenter / ESXi host contacts the hardware virtual chip on the OS that communicates with VMware tools

          ->VMware tools picks up this command and tells the OS to flush buffers in prep for a stun

          ->Quiesce happens

          ->Stun happens and snap is made

          ->Life goes on

           

          If quiesce fails it still does a crash inconsistent snapshot.    If you are using Windows the method for quiescing is VSS so check your event logs of VSS events... if you have no tools you should not see anything. 

           

          I could be wrong but that is my understanding.   What evidence do you have that it was a quiesced snapshot vs a crash inconsistent snap?   I would like to play with this more ...:)

           

          Thanks,

          Joseph

          • 2. Re: Able to take quiesce snapshot for a VM with no VM tools !
            lvaibhavt Hot Shot

            Hi Gortee, Joseph

             

            Thanks for replying. I was looking for a online screen recorder so I could share the video with you.

             

            I created a new VM and installed Windows 7 on it. I did not install VM tools and then tried a quiesce snapshot. I clicked on take snapshot -- unchecked memory --- checked quiesce and the snapshot completed fine.

             

            If possible can you please try it in your lab.

             

             

             

            Thanks