8 Replies Latest reply on Mar 21, 2016 10:07 PM by kopper27

    Error upgrading vCenter appliance from 5.1 to 6

    psychokinetic Lurker

      Hi

       

      I'm trying to upgrade from vCenter appliance 5.1u3 to 6u1

       

      I have 3 ESXi hosts on 5.1.

       

      I'm using the the upgrade manager. After completing the information at step 4 I receive an error:

       

      "Internal error occurs during VMware vCenter Server Database pre-upgrade checks"

       

      After scanning the log files I see an error(log file below).

       

      I have search the forums and tried the following with no success. A support call to vmware has produced no solution.

       

      VMware KB:    Upgrading to VMware vCenter Server 6.0 fails with the error: Internal error occurred during VMware vCente…

       

      VMware KB: Upgrading from vCenter Server Appliance 5.x to 6.0 reports error: vCenterServer FQDN does not match DNS

       

      Questions:

      1.Can anyone help?

      2.Can I manually install a fresh appliance and then connect to my hosts. What configuration would I lose?

       

      Thanks

       

       

      Log file snippet from CollectRequirements_com.vmware.vcdb_"Date".log

       

      2016-01-21T22:48:44.357Z INFO vcdb Retrieving DB type...

      2016-01-21T22:48:44.357Z INFO vcdb DB type retrieved: PostgreSQL

      2016-01-21T22:48:44.367Z INFO vcdb Retrieving DB user...

      2016-01-21T22:48:44.398Z INFO vcdb DB user retrieved: vc

      2016-01-21T22:48:44.408Z INFO vcdb Retrieving DB password...

      2016-01-21T22:48:44.453Z INFO vcdb DB password retrieved: ****

      2016-01-21T22:48:44.466Z INFO vcdb Validating source embedded schema...

      2016-01-21T22:49:00.493Z INFO vcdb Souce embedded schema validation completed.

      2016-01-21T22:49:00.500Z WARNING transport.local BAD REQUEST: Cannot execute ['/opt/vmware/vpostgres/1.0/bin/psql', '-U', 'postgres', '-d', 'VCDB', '-t', '-c', "\n               SELECT ceil(sum(pg_relation_size(C.oid)) / (1024*1024)) as disk_size\n                 FROM pg_class C\n                 LEFT JOIN pg_namespace N\n                   ON N.oid = C.relnamespace\n                WHERE nspname IN ('vc', 'vpx') and relkind in ('r', 't')\n               \n                           AND relname NOT LIKE 'vpx_hist_stat%'\n                           AND relname NOT LIKE 'vpx_sample_time%'\n                           AND relname NOT LIKE 'vpx_event%'\n                           AND relname NOT LIKE 'vpx_task%'\n                           AND relname NOT LIKE 'vpx_property_bulletin%'\n                           "]. Error: [Errno 2] No such file or directory

      2016-01-21T22:49:00.500Z ERROR __main__ Upgrade Phase 'vcdb:CollectRequirements' failed. Exception:

      Traceback (most recent call last):

        File "/var/tmp/vmware-upgrade-requirements/cis-upgrade-runner/payload/componentPhaseLauncher.py", line 379, in main

          executionResult = systemExtension(exeContext)