1 2 Previous Next 26 Replies Latest reply on Apr 2, 2017 11:38 PM by Vindia Go to original post
      • 15. Re: VMware Remote MKS has stopped working
        SkyRE Lurker

        Thanks!

        Your workaround worked for me.

         

        What is VMware doing?

        VMware Remote Console Plug-in 5.1 - vmware-remotemks.exe file version 8.0.0.33578 from VMware Workstation.

        VMware Remote Console Plug-in 5.5 - vmware-remotemks.exe file version 9.0.0.34615 from VMware Workstation

        VMware-VMRC-7.0.1-2508353.msi - vmware-remotemks.exe file version 7.0.1.35209

        • 16. Re: VMware Remote MKS has stopped working
          jde126 Lurker

          All,

           

          I came across this same issue, and it is not a firewall issue. The port 902 errors are different. This error is the annoying error that occurs when the vSphere "thick client"  Remote Console attempts to resize the window from within the OS. This happens when booting Linux, Windows, etc., going from the BIOS boot screen at one resolution, to the bootloader screen at another resolution, to the final bootup screen at another resolution.  The error specifically states that the "VMware Remote MKS has stopped working" , and you have to close this and then close the console and then re-open it.

           

          This for me was caused when I installed the VMWare PowerCLI, and it forced me to install the Remote Console Plug-In 5.1 as part of the installation. After that, I had this issue. The resolution was to uninstall the Remote Console Plug-In 5.1 (hasn't seemed to affect the PowerCLI operation), and then uninstall and reinstall the vSphere 6.0 Client software.  Apparently this is like the old "DLL Hell" days   .... And there is a version issue with the Remote Console Plug-In when installing other VMware products.

          • 17. Re: VMware Remote MKS has stopped working
            Lan1800 Lurker

            Thanks jde126!

             

            Your resolution fit my timeline exactly.  I just downloaded and updated the latest PowerCLI and I wasn't able to correlate the two problems.  Uninstalling that Console Plug-in 5.1 did the trick for me as well.

             

            Thanks for sharing

            • 18. Re: VMware Remote MKS has stopped working
              enriquepessoa Lurker

              Thank you, Juspi. You've got the right clue!

               

              When connecting to a VSphere 5.1 Server the client installs the 5.1 version over the 5.5 (used by 6.0), bringing us that problem.

               

              Here we have a registry fix for that situation.

              • 19. Re: VMware Remote MKS has stopped working
                JesseRA2000_ENS Lurker

                I had the same issue. I did what Juspi did, and it fixed the issue.

                Workaround:

                In "C:\Program Files (x86)\Common Files\VMware\", Rename the folder "VMware Remote Console Plug-in 5.1" to "VMware Remote Console Plug-in 5.1"_Old, and then rename the folder "VMware Remote Console Plug-in 5.5" to "VMware Remote Console Plug-in 5.1".

                • 20. Re: VMware Remote MKS has stopped working
                  vmwaresucksatrestarting Lurker

                  This issue happened to me recently and i traced it down to having installed the remote console plugin the day before it started happening. I uninstalled that program as well as all other vmware software and then reinstalled vsphere client 6 and now all is back to normal.

                  • 21. Re: VMware Remote MKS has stopped working
                    drexciya Hot Shot

                    This explains a lot and seems to be the fix I was looking for, thank you very much. I would really like to see VMware engineers to put in a proper check for the VMRC, since I already had version 7 or 8 installed before I installed (or upgraded) to PowerCLI 6.x, which installed the flaky 5.1 VMRC software. That would prevent this from happening in the first place.

                    • 22. Re: VMware Remote MKS has stopped working
                      jimbledsoe Lurker

                      Not sure what the issue is on our side.   But migrating the system to the same host or a new host has clearned up the MKS problem four times in a row.

                      • 23. Re: VMware Remote MKS has stopped working
                        esriley Lurker

                        You did the same thing i would have done. But you have to only uninstall the remote console plug in. must be some conflict with that remote plugin for the web interface and the GUI client.

                        • 24. Re: VMware Remote MKS has stopped working
                          RestartAdmin Lurker

                          Hi, we had the same issue after installing PowerCLI 6.3. We testet the registry hack of enriquepessoa and the rename/copy hack of jde126 successfully. Deinstalling the Remote Plugin 5.1 and reinstalling VIClient 6.0 did not work for us.

                          • 25. Re: VMware Remote MKS has stopped working
                            NTShad0w Enthusiast

                            enriquepessoa,,


                            that's a working fix (reg file) for this issue (multiple vSphere c# client versions on single windows and console MKS crash).


                            thanks!!

                            best regards

                            NTShad0w

                            • 26. Re: VMware Remote MKS has stopped working
                              Vindia Lurker

                              Thank you Very much,

                               

                                   I was suffering from last 3 month with this issue, But your solution working 100% for me. 

                               

                               

                              In My live lab, this error is coming frequently when I just connect Esxi 6.0 U1 with vSpher Client "VMware Remote MKS has stopped working".

                               

                              1. Some host console displaying "Unable to connect to the MKS.Internal Error"  this error resolved after proper configer or mantioned  default getway of Esxi server. after that I restart the "Instant" (virtual internal systems ) and resolved its error successfully.

                              2.  Also I installed your giving .reg  & its 100 % work.

                               

                               

                              Thanks,

                               

                               

                               

                               

                              1 2 Previous Next