9 Replies Latest reply on Jul 31, 2017 9:35 PM by swhiteheadCA

    No Mac OSX 10.11 support on ESXi 6.0 B3247720

    kevindd992002 Novice

      I have a standalone ESXi server (no vCenter) and I manage it either through vSphere wweb client or VMWare Workstation 12 (remote connection to server). I usually create my VM's through VMWare Workstation as that is the closest I can get to a vSpher web client with updated features. I'm trying to create a MAC OS X 10.11 El Capitan image but when the latest OS X version I can pick off of the list is 10.10.

       

      Based on the documentation of VMWare ESXi, OS X 10.11 is supported since the base version of 6.0. Any ideas why? Or is this because I really need a vSphere web client?

        • 1. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
          kevindd992002 Novice

          Also, if the MAC OS X is natively supported by ESXi then what is the use of this hack: [removed] ? It does say that it is for ESXi 6.0.

           

          edit by wila Removed link as it is not allowed to post links to content that help you get around copy protection / pirating software.

          • 3. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
            HawkieMan Enthusiast

            You are using a unlocked hack to allow for macosx, its not native to workstation. The licensing from Apple says you can create those on apple HW, and that would mean you must run it on apple, with Fusion. The list you have is defined in the hack,and this is NOT a vmware forum issue. If you where running Fusion and could not select then it was another issue all together.

             

            There is no real issue for vmware to run apple, but this is a licensing constraint, so please do not even think about doing this on a commercial system or for work purposes.

            • 4. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
              wila Guru
              vExpertUser ModeratorsCommunity Warriors

              Hi HawkieMan,

               

              That's almost correct.

              He talks about ESXi which actually is allowed to run OS X, but only if the underlying hardware is apple hardware.

              As OP did not mention he's using non apple hardware, for the moment I give him the benefit of the doubt.

               

              As for the OP, yes you might need the web client for that. VMware Workstation itself normally does not give you OS X client settings at all (as it is under no circumstance allowed to run OS X natively under Workstation)

              Although I would expect it to work if you set the guest OS to 10.10 instead of 10.11

               

              Edit: As an additional note to the OP, if you want to try and run OS X on non apple hardware then we are not allowed to help you in this forum.

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 5. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
                HawkieMan Enthusiast

                He refers directly to vmware workstation in his quesion, so I assume with almost 99,9% certainty that he is not running on apple HW.

                • 6. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
                  wila Guru
                  vExpertCommunity WarriorsUser Moderators

                  Hi,

                   

                  He refers to using workstation as a feature to remote install, not for local. He is using it as an alternative vSphere Client.

                  That by itself is fine.

                   

                  You are correct that you cannot use Workstation to install OS X locally.

                  That's not even allowed when running running from an OS X bootcamp partition.

                   

                  The hack the OP refers to is also not allowed, which is why I removed the link.

                  -

                  Wil

                  | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                  | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                  | More info at https://www.vimalin.com
                  | Twitter @wilva
                  | VMware Wiki at http://www.vi-toolkit.com
                  • 7. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
                    kevindd992002 Novice

                    Wila is correct. I was talking about the ESXi hardware. I didn't realize that the hack isn't allowed here so I apologize. I get your point and you can go ahead and close this case. I'm running non-Apple hardware, yes. I don't plan on doing this for production purposes. This is all for lab purposes and I'm just trying to install one Mac test machine.

                     

                    Thanks.

                    • 8. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
                      FrankBE Lurker

                      I am using ESXI 6.0 upd 2 on a Mac Mini late 2012 en that is supported & allowed.

                       

                      I use vSphere & Workstation 12 to remotely administer (starting from a PC)

                       

                      For me too I canot create OS-X 10.11 or 10.12

                       

                      So now what is the solution ?

                      • 9. Re: No Mac OSX 10.11 support on ESXi 6.0 B3247720
                        swhiteheadCA Lurker

                        I have this same issue... No luck so far