6 Replies Latest reply on Aug 13, 2015 1:54 PM by RyanJMN

    Backup job failing - Error 3 (One of the parameters was invalid)

    GustavoOliveira90 Lurker

      Hello,

      as stated above my backup job is failing and I don't know why.

       

       

      From the vSphere Web Client I get the following message on the task console:

       

      VDP server execution error code: 10055

       

       

      And from the logs I deducted that the important part is the one below:

       

      /usr/local/avamarclient/var/Backup_test....log

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <9666>: Available transport modes are file:san:hotadd:nbdssl:nbd

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <9667>: Calling ConnectEx with servername=10.64.208.104 vmxspec=moref=vm-13 on port 443 snapshot(snapshot-26)

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <9668>: virtual machine will be connected readonly

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <16041>: VDDK:VixDiskLib: VixDiskLib_ConnectEx: Establish connection using (null).

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <16041>: VDDK:VixDiskLib: VixDiskLib_Connect: Establish connection.

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <16041>: VDDK:VixDiskLib: A thumbprint is required for SSL certificate validation. vixDiskLib.c line 2446

      2015-04-17T18:55:18.478-05:-30 avvcbimage Info <16041>: VDDK:VixDiskLib: VixDiskLib_Connect: Failed to allocate connection. Error 3 (One of the parameters was invalid) at 3914.

       

      All my software if version 6.0.

      If there is anymore information I can provide please tell me.

        • 1. Re: Backup job failing - Error 3 (One of the parameters was invalid)
          GustavoOliveira90 Lurker

          I can now add some more information.

           

          During the weekend the Scheduled Backup Jobs worked alright, only the manual are failing on that condition.

          • 3. Re: Backup job failing - Error 3 (One of the parameters was invalid)
            GustavoOliveira90 Lurker

            I'm backing up a RHEL machine, not Windows...

            I also checked connectivity.

            • 4. Re: Backup job failing - Error 3 (One of the parameters was invalid)
              Umesh Expert

              Hi,

              While taking the manual snapshot , Are there any old snapshot file residing on the datastore ? Try to consolidate them and then try again manually.

              • 5. Re: Backup job failing - Error 3 (One of the parameters was invalid)
                wildo69 Lurker

                did you ever find a resolution to this issue? it appears i am now having the same issue. everything was working a day or two ago, after migrating in some new servers now VDP wont back them up.

                 

                Getting a similar error

                 

                Info <16041>: VDDK:VixDiskLib: VixDiskLib_Connect: Failed to allocate connection. Error 3 (One of the parameters was invalid) at 3914
                Info <16041>: VDDK:VixDiskLib: VixDiskLib_PrepareForAccess: Failed to establish connection. Error 3 (One of the parameters was invalid) at 3978.
                Warning <0000>: [IMG0008] VixDiskLib_PrepareForAccess returned fault(3), (3) One of the parameters was invalid
                

                 

                then

                Info <16041>: VDDK:VixDiskLib: VixDiskLib_Connect: Failed to allocate connection. Error 3 (One of the parameters was invalid) at 3914.
                Info <16041>: VDDK:VixDiskLib: VixDiskLib_Cleanup: Error occured during establishing connection. Error 3 (One of the parameters was invalid) at 3819.
                Warning <0000>: [IMG0008] VixDiskLib_Cleanup() returned code(3),'(3) One of the parameters was invalid', 0 VMx require cleanup
                

                 

                Then towards the end of the log this

                 

                Info <16041>: VDDK:VixDiskLib: VixDiskLib_Connect: Failed to allocate connection. Error 3 (One of the parameters was invalid) at 3914.
                Error <0000>: [IMG0008] VixDiskLib_ConnectEx returned 3 (3) One of the parameters was invalid
                Info <9772>: Starting graceful (staged) termination, VixDiskLib_Open attempt to connect to virtual disk failed (wrap-up stage)
                Error <0000>: [IMG0008] VixDiskLib_Connect(host:[VC FQDN] account:[admin account name] dc:/[VC Datacenter name]&dsName: vmxpath:[datastore name] virtualserver1/virtualserver1.vmx port:443vmmoref:vm-217741) detected a problem, returned (3) One of the parameters was invalid
                Info <0000>: getActiveTaskCount prior to snapshot removal: CreateSnapshot=3 RemoveSnapshot=0 ImageTask=0 otherTask=4
                Info <14642>: Deleting the snapshot 'VDP-14394866627387bf477b03254454639b27b9076b8cffe2401b', moref 'snapshot-218502'
                Info <14631>: Snapshot (snapshot-218502) removal for VM '[datastore name] virtualserver1/virtualserver1.vmx' task still in progress, sleep for 2 sec
                Info <14630>: Snapshot (snapshot-218502) removal for VM '[datastore name] virtualserver1/virtualserver1.vmx' task was canceled.
                Info <18649>: Removal of snapshot 'VDP-14394866627387bf477b03254454639b27b9076b8cffe2401b' is not complete, moref 'snapshot-218502'.
                Info <0000>: vcbimage_progress::terminate
                Warning <40361>: VixDiskLib vMotion reservation release requested for prior reservation
                Info <16041>: VDDK:VixDiskLib: VixDiskLib_EndAccess: Disk access completed.
                

                 

                the details may be a bit different but seems to have the same common errors.

                • 6. Re: Backup job failing - Error 3 (One of the parameters was invalid)
                  RyanJMN Enthusiast

                  I believe you likely have an issue with the proxy connection to the esxi host.  How did you migrate in new servers?