2 Replies Latest reply on May 23, 2015 12:06 PM by IReallTryhard

    Ubuntu and Shared folders, I need help

    IReallTryhard Enthusiast

      Installed Ubuntu 14.04 Guest and updated and all good.

      Followed instructions on this page and almost all good

      http://theholmesoffice.com/how-to-share-folders-between-windows-and-ubuntu-using-vmware-player/

       

      Ran this command and it shows the drives and folders that I defined as Shared-Folders

      vmware-hgfsclient

       

      Ran this and it put shortcuts on the desktop

      ln -s /mnt/hgfs/shared-directory ~/Desktop/Name-of-the-folder  {edit} Yes, I used the real Shared Folder names

       

      If I double click on the shortcut OR try to copy a file to it from Ubuntu, I get

      This link cannot be used because its target “/mnt/hgfs/shared-directory” doesn't exist.

       

      Where am I going wrong?

      And, how do I make it work?

       

      Also /mnt/hgfs is empty even with Ctrl-H

       

      Also edited the fstab file as per...

      VMware Workstation 10 Documentation Center

      .host:/ /mnt/hgfs vmhgfs defaults 0 0

       

      Rebooted Ubuntu and got an error "Error mounting hgfs - S=skip, M=manual fix."

       

      I skipped.

        • 1. Re: Ubuntu and Shared folders, I need help
          CraigPD Lurker

          Ran this command and it shows the drives and folders that I defined as Shared-Folders

          vmware-hgfsclient

           

          Ran this and it put shortcuts on the desktop

          ln -s /mnt/hgfs/shared-directory ~/Desktop/Name-of-the-folder  {edit} Yes, I used the real Shared Folder names

           

          If I double click on the shortcut OR try to copy a file to it from Ubuntu, I get

          This link cannot be used because its target “/mnt/hgfs/shared-directory” doesn't exist.

           

          Where am I going wrong?

          And, how do I make it work?

           

          Also /mnt/hgfs is empty even with Ctrl-H

           

          If /mnt/hgfs is empty the share isn't being set up correctly.  If the shared folders output in the vmware hgfsclient command appears all I can think is possibly the second command creating desktop shortcuts is in error.  I'm confused about what is actually "shared-directory" and "Name-of-the-folder".  They should be the same.  That particular step shouldn't even be be necessary if the share was actually established.  Normally all you need to do is create a desktop link to the shared folders once they are visible in the /mnt/hgfs directory.  You could try everything again. leaving that part out and going directly to /mnt/hgfs to see if it might be the source of the problem.

           

          Another option is to take a look at the links posted in this message two days ago - Re: complete, total and utter failure to get shared folders working in VM Player - host W7, guest Lubuntu (various versions)  The patch script is backward compatible with numerous Linux kernels so it should work on Ubuntu 14.04 which uses 3.13.  If for some reason it doesn't, you can rerun the unpatched VMware Tools distribution and be back where you are now, none the worse for wear.

           

          Good luck,

          • 2. Re: Ubuntu and Shared folders, I need help
            IReallTryhard Enthusiast

            Thanks Craig,

             

            Sorry for the confusion, I just pasted that command from the website. When I used the command in Term in Ubuntu I used the folder names i had assigned in Player/Manage/SharedFolders. I have a backup of the Guest, so will copy it over and try again as you suggest.

             

            I had read the other post you mentioned, with a Subject header as amusing as that, who could not?