6 Replies Latest reply on May 22, 2015 6:22 AM by TronAr

    Not able to ping the storage with an MTU of 9000

    Sudharshans Lurker

      Hi,

       

      I have a lab setup. I have a ESXi 5.5 built on a VMWare workstation. I have bridged the adapted connecting to the storage to ESXi, from the host am able to ping the storage with an MTU of 9000 but from the ESXi am not able to do the same. While i set the MTU to 1500 on the ESXi am able to ping the storage but when i set it to 9000 the connectivity to the storage is completely lost. Need help !!

        • 1. Re: Not able to ping the storage with an MTU of 9000
          schepp Virtuoso
          vExpertUser Moderators

          Hey welcome to the communities,

           

          what workstation version are you using? A   Workstation 7 performance guide states that workstation doesn't support jumbo frames. I can't find anything for newer releases, but I'd assume, that the Workstation still only supports the standard 1500 MTU.

           

          Regards

          Tim

          Edit: I've moved your thread, as this doesn't seem to be a storage problem.

          1 person found this helpful
          • 2. Re: Not able to ping the storage with an MTU of 9000
            Sudharshans Lurker

            Hi Tim,

             

            Thanks for the reply, I use workstation 10 !

            • 3. Re: Not able to ping the storage with an MTU of 9000
              TronAr Expert

              Please try changing the type of adapter to vmxnet3.

              (i.e. edit .vmx and set ethernet0.virtualDev = "e1000")

              Internet Public Knowledge Advisor (a.k.a. google) reports that jumbo frames are not supported,

              but if you change the default (e1000) net type to vmxnet3, it does work.

               

              I run into this while trying to setup an NSX lab on workstation and finding out that MTU 1600 (needed by NSX for vxlans) was not working...

               

              HTH,

              -Carlos

              • 4. Re: Not able to ping the storage with an MTU of 9000
                TronAr Expert

                FTR, it seems there's a reason for not being supported.

                After changing the device type to vmxnet3, VMs can indeed use jumbo frames and they work, but bridging to the physical network is another story.

                Interestingly, bridging TO the network (including the host) seems to work, but FROM the network does not.

                And this kind of breaks console streaming

                 

                -Carlos

                • 5. Re: Not able to ping the storage with an MTU of 9000
                  Lurker

                  Hi Carlos,

                   

                  I'm facing the same issue when setting up a lab for NSX.

                  Tried with Workstation 10 and did not work despite I was using a vmxnet3 adapter.

                   

                  Did you use a Host-only network for the VXLAN transport ?

                  Did you connect a host virtual adapter to the VMNET (ex: VMNet1) network used for the VXLAN transport ?

                   

                   

                  Using Workstation 10 and 11, I successfully test VTEP connectivity between ESXi nested host with MTU = 1500

                   

                  but when I test VTEP connectivity between ESXi nested host with MTU > 1500

                   

                  the ESXi crashes with the following exception.

                  • 6. Re: Not able to ping the storage with an MTU of 9000
                    TronAr Expert

                    I did get the NSX lab to work, sort of.

                    Internal only works AFAIK, and from the outside world works up to MTU 1570 if memory serves. That breaks the standard test of MTU 1600 but works for some setups. In the end, it was so complicated that I ended up shifting my NSX test bed to a real ESXi and using nested. That's another can of worms, but works

                    The only think that comes to mind is that you might need MTU set in the physical adapter too.