5 Replies Latest reply on Mar 9, 2015 11:52 AM by MikaelPareChabot

    Unable to see vCO in vSphere Web Client

    MikaelPareChabot Novice

      I'm currently using vRealize Orchestrator 6.0.0. I've been trying to add the extention to my vSphere Web Client but it still does not work.

       

      I configured the SSO Authentication, the network, imported the SSO Certificate. I ran both workflows "Add a vCenter Server instance" and "Register vCetner Orchestrator as a vCenter Server extension" in "Library / vCenter / Configuration".

       

      When I try to restart my vSphere Web Client service, I can see the vCO in it, but it disappear after a minute. And I can the see the error message "

      Could not connect to one or more vCenter Server systems:

      https://{vCenterIP}:443/sdk"

       

      unnamed.png

        • 1. Re: Unable to see vCO in vSphere Web Client
          MikaelPareChabot Novice

          I'm still unable to see the "vCO Servers" section in my vSphere Web client. Here is what I have in my "mob". Is it normal to have a type "HTTPS" ? Because of what I've seen in the forum, people are talking about "REST" in this section.

           

          Data Object Type: Extension
          Parent Managed Object ID: ExtensionManager
          Property Path: extensionList["com.vmware.vco"]

          Properties

          NAMETYPEVALUE
          clientExtensionClientInfo[]client
          companystringUnset
          descriptionDescriptiondescription
          dynamicPropertyDynamicProperty[]Unset
          dynamicTypestringUnset
          eventListExtensionEventTypeInfo[]Unset
          extendedProductInfoExtExtendedProductInfoextendedProductInfo
          faultListExtensionFaultTypeInfo[]Unset
          healthInfoExtensionHealthInfoUnset
          keystring"com.vmware.vco"
          lastHeartbeatTimedateTime"2015-03-09T10:27:52.807-04:00"
          managedEntityInfoExtManagedEntityInfo[]Unset
          ovfConsumerInfoExtensionOvfConsumerInfoUnset
          privilegeListExtensionPrivilegeInfo[]Unset
          resourceListExtensionResourceInfo[]Unset
          serverExtensionServerInfo[]server
          shownInSolutionManagerbooleanfalse
          solutionManagerInfoExtSolutionManagerInfosolutionManagerInfo
          subjectNamestringUnset
          taskListExtensionTaskTypeInfo[]Unset
          typestringUnset
          versionstring"6.0.0"

           

          Data Object Type: ExtensionServerInfo[]
          Parent Managed Object ID: ExtensionManager
          Property Path: extensionList["com.vmware.vco"].server

          Properties

          NAMETYPEVALUE
          [0]ExtensionServerInfo
          NAMETYPEVALUE
          adminEmailstring[]
          "vco-c0edd5bc-11e0-453f-9e95-f2f40c8beb42@vmware.com"
          companystring"VMware Inc."
          descriptionDescription
          NAMETYPEVALUE
          dynamicPropertyDynamicProperty[]Unset
          dynamicTypestringUnset
          labelstring"vRealize Orchestrator"
          summarystring"vRealize Orchestrator server"
          dynamicPropertyDynamicProperty[]Unset
          dynamicTypestringUnset
          serverThumbprintstring"05:9A:8E:33:05:2C:57:49:7F:06:D3:77:38:D2:4A:89:A1:DC:5D:2C"
          typestring"HTTPS"
          urlstring"https://{vCenterIP}:8281"
          • 2. Re: Unable to see vCO in vSphere Web Client
            gkostova Enthusiast
            VMware Employees

            Hi,

             

            What are the exact versions are you using? For vRO and vSphere web client.. We do not have a vRO 6.0.0 official release, so what are your version?

             

            Regards,

            Galina

            • 3. Re: Unable to see vCO in vSphere Web Client
              MikaelPareChabot Novice

              vSphere web client: Version 5.5.0 Build 1750785

              vRealize Orchestrator: Version 6.0.0 2357352

              • 4. Re: Unable to see vCO in vSphere Web Client
                gkostova Enthusiast
                VMware Employees

                It seems that this is not a supported combination - vRO 6.0.0 (for vRA 6.2 customers only) + VC 5.5.0. Also in general it is not needed to run the Register extension workflow. The extension should be registered automatically with Add vCenter server workflow. You could wait for vRO 6.0.1and for vSphere 6.0.0 and try with them.

                 

                Regards,

                Galina

                • 5. Re: Unable to see vCO in vSphere Web Client
                  MikaelPareChabot Novice

                  I tried with a vCO 5.5.2.1 and it worked. So it was a problem with the 6.0.0...