4 Replies Latest reply on Jan 18, 2015 10:31 PM by rachelsunsm

    Workstation 11 does not use host monitor configuration with multiple monitors

    delador Lurker

      Just upgraded to a new Dell XPS 15 running Windows 8.1 The laptop monitor is set to 3200x1800 and I have an second monitor connected by HDMI set to  1900x1200 which is the native display mode.  I also upgraded to VMWare Workstation 11.0 in the default configuration.  All system components are updated correctly including the guests VMWare tools.

       

      When I open a Windows Guest OS and expand it to full screen on the second monitor, the guest should display should in 1900x1200 mode which is the native mode for the display and is how the host has it set.  However Workstation 11 attempts to run the monitor at 3840x2400.  The result is a very blurry display and a mouse that does not locate screen items correctly.

        • 1. Re: Workstation 11 does not use host monitor configuration with multiple monitors
          rachelsunsm Enthusiast

          Hello, thanks for using WMware workstation.

          I tried to reproduce it on my own env by following steps, but didn't hit the issue.

          1. I connect two monitors,  the resolution of the first one is 3840 x 2160. the second one is 1440x900

          2. I launch the WS11  and power on GOS from the first monitor and then drag it to the second one.

          3. set the WS to full screen. the resolution of GOS is 1440 x 900.

           

          Can you describe the detail steps about how to reproduce this, or you can upload a screenshot for reference.\

           

          Thanks,

          Rachel

          • 2. Re: Workstation 11 does not use host monitor configuration with multiple monitors
            delador Lurker

            That is the correct procedure if the display is in "extend" desktop mode.

             

            Today, I debugged the problem to the interaction between Windows 8.1 Update auto scaling of the displays and VMWare.  During this debug I noticed you do not even need to open the GOS, just moving the WS11 window between the "magnified" desktop on the laptop screen and the external monitor there will be display issues.

             

            Removing the automatic magnification in "Control Panel - Appearance and Personalization - Display - Change the size of all items" corrects the problem that WS11 experiences but makes the native laptop display unreadable.  This appears to be a WS11 only bug because other programs like Chrome or Outlook do not exhibit the odd behavior.

             

            It looks like WS11 is trying to use the "magnified" values on both screen displays which explains why everything was so small on the external display and why the resolution on the external display was 3840x2160 (3840 is double the 1920 of the external monitor).

            • 3. Re: Workstation 11 does not use host monitor configuration with multiple monitors
              delador Lurker

              Re: Mouse problem on second display using WS 10 (regression?)

               

              This thread has a response with workaround from AvalonWar that corrects the problem.

               

              "the problem is caused by a settings on Host (if it's Win 8.1). It is caused by DPI Scaling.

              One of the possibile workaround can be:

              On the Host, find the vmware.exe executable, right click, properties, compatibility, under Settings check "Disable display scaling on High DPI settings".

              Close and re-open vmware workstaion."

               

              While this workaround does correct the issue, it seems like this is a VMware WS11 bug because other programs work as expected.

              • 4. Re: Workstation 11 does not use host monitor configuration with multiple monitors
                rachelsunsm Enthusiast

                Thanks for your reply. there was a bug for WS 11 about Win8.1u2: on the 4k HDPI monitor, when I try to full screen the gos, the gos display as black screen.

                I tried with the sugestion you mentioned, when I check "Disable display scaling on High DPI settings", it will works well. I think it's all about the scaling on HDPI monitor, I will post the result once the bug is fixed.

                 

                Thanks,

                Rachel