1 2 3 Previous Next 44 Replies Latest reply on Jul 27, 2017 5:43 AM by Exch2016

    VMware ESXi 5.5 U2 - TcpAckFrequency

    kungpow Enthusiast

      Looks like there is a bug in VMware ESXi.

       

      Exchange 2013 SP1 on win2k12 r2 on a physical server: no slow upload issue with Outlook.

       

      Exchange 2013 SP1 on win2k12 r2 on VMware ESXi 5.5 U2: has slow upload issue with Outlook.

      -tried E100E & VMXNET3 network adapters, doesn't fix the issue.

      -only way to fix the slow upload issue is to modify the registry key TcpAckFrequency on the PC

       

      How do I fix this in ESXi without modifying TcpAckFrequency in the registry on the PC?

       

      Thanks

        • 1. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
          bbernsee Lurker

          There are a lot of questions I'd ask to get to the bottom of this one.

           

          Start with the basic things:

          - make sure you don't have a duplex mismatch or port errors

          - does a continuous ping show issues?

          - see if any NIC settings such as TCP offload, or Interrupt moderation are different

          - then check your routing and ARP table at any routers in between the client and server

          - is TCPNoDelay set on your stack?

          - make sure you aren't running into NIC teaming issues

          - do you have any load balancers or firewalls in between the client and server?

          - get a network trace and look at the pattern of the segments being sent and ack'd (I'd use Opnet App Expert - but I'm lucky enough to have that tool, wireshark works great too)

          - check your segment size and make sure you're not running across and smaller MTU segments - specifically if one is a VPN.  If so - you might need to turn down the MTU or put in a tcp adjust MSS at a network device

           

          Good luck in addressing this... 

          • 2. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
            fkoller Lurker

            Have the same Problem as reported. Have different VMWare Environments - 5.0.0, 5.1 U1, 5.1 U2 and 5.5 U2 and also different AD Sites! 5.0.0 and 5.1 U1 will work fine with Exchange 2013 Sp1. But not so 5.1 U2 and 5.5 U2!

             

            Already checked the mentioned points but do not help to solve the Problem. We also tired a virtual machine without Firewall in between - has the same problem.

             

            We have an active call with Microsoft. They told us to set the TcpAckFrequency Parameter on the Client Interfaces. This will help, Outlook will work fast again. But on the older VMWare Environment we do not have to set the TcpAskFrequency and it will work fine. To conclude, it seems to be a problem with newer VMWare Versions.

            • 3. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
              kungpow Enthusiast

              fkoller, did VMware say when they will have a fix for it or why it is happening in ESXi?

               

              Thanks

              • 4. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                fkoller Lurker

                I just want to clearfy my Statement. We have a call with Microsoft and not yet with VMWare. According to our Exchange 2013 infrastructure, which runs on severeal VMWare Hosts with different VMWare Editions We got the assumption, that the reason has to do with newer VMWare Editions. We are doing some further tests to underpin this Statement.

                 

                Will come back to you.

                • 5. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                  fkoller Lurker

                  As we installed the Exchange Server 2012 on a VMWare host 5.1.0 Build 1065491, Exchange and Outlook will work fast again! So the problem on Exchange 2013 with Windows 2012 R2 has definitly to do with VMWare edition, you install from.

                   

                  We will do another test to see what happens, when moving the virtual server to newer hosts.

                   

                  Will let you know.

                  • 6. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                    fkoller Lurker

                    Moved the virtual Machine to VMWare Host 5.5 U2, still working fine. As soon as the VMWare tools would be upgraded to the 5.5 U2 version, the performance issue will come back again!

                     

                    Have to open a call with VMWare to find a solution for 5.5 U2. Has anybody done this already to get a work around or a patch?

                    • 7. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                      kungpow Enthusiast

                      fkoller wrote:

                       

                      Have the same Problem as reported. Have different VMWare Environments - 5.0.0, 5.1 U1, 5.1 U2 and 5.5 U2 and also different AD Sites! 5.0.0 and 5.1 U1 will work fine with Exchange 2013 Sp1. But not so 5.1 U2 and 5.5 U2!

                      I just confirmed this as well. I am running ESXi 5.5 U2 and I downgraded VMware Tools from 5.5 U2 to 5.1 U1 on the Exchange 2013 guest OS and the TcpAckFrequency issue went away. Now I don't have to edit the registry for the TcpAckFrequency key on each PC.

                       

                      To download an older version of VMware Tools:

                      http://packages.vmware.com/tools/esx/index.html

                      • 8. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                        tedsteenvoorden Lurker

                        Experiencing the same problem. Exchange 2013 on VMware and Outlook responses very slow. Setting the TcpAckFrequency did not solve the problems, but our clients are running on ESXi 5.1 U2 (VDI).

                         

                        Did you open a VMware case and had any response?

                        • 9. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                          fkoller Lurker

                          We opened a case with HP Support Center on Tuesday, 14 of October (We have a VMWare Bundle bought by HP).

                           

                          The technician already confirmed some problems with VMWare Tools Version 11. But he was not shure, if our symptoms would have the same source. He wanted to scan the knowledge base and come backup with more information. No further reaction up today.

                          • 10. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                            tedsteenvoorden Lurker

                            I'll open also a VMware case and post any results in this thread.

                             

                            Are your Windows 7 clients physical machines or are they virtual?

                            • 11. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                              kungpow Enthusiast

                              tedsteenvoorden wrote:

                              Are your Windows 7 clients physical machines or are they virtual?

                              I tested the TcpAckFrequency registry key on both physical and virtual windows 7/8.1 machines and the TcpAckFrequency key fixes the issue.

                               

                              A better way to fix the issue instead of adding the TcpAckFrequency registry key on each pc is to downgrade the VMware Tools on the Exchange 2013 server. I tested the issue after the downgrade on virtual machines XP, 7, and 8.1 and it fixes the problem as well.

                              • 12. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                                BradleyJohn Lurker

                                Hi folks,

                                We look to be experiencing a similar issue with 5.1 U2. Do you know if anyone has contacted VMWare support about this or have received or seen an official VMWare KB article about this issue?

                                I didn't find one when I searched.

                                Thank you,

                                Brad

                                • 13. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                                  Rudy_van_Os Lurker

                                  Did you check the installation of the vShield Drivers:

                                   

                                  If this option is installed, please try to remove, reboot and test again. Do not forget to delete TcpAckFrequency on client-side and reboot.

                                   

                                  For us this was the solution for the same issue.

                                  • 14. Re: VMware ESXi 5.5 U2 - TcpAckFrequency
                                    mikejroberts Enthusiast

                                    Any word on whether or not this is resolved in the latest tools version?

                                    1 2 3 Previous Next