1 2 Previous Next 15 Replies Latest reply on Oct 1, 2014 11:44 AM by dariusd Go to original post
      • 15. Re: Version mismatch with vmmon module: expecting 279.0, got 271.0.
        dariusd Virtuoso
        VMware EmployeesUser Moderators

        Repeating myself, to try to squash this cargo-cult "solution"...


        DO NOT MANUALLY COPY THE KERNEL EXTENSIONS ANYWHERE.  Doing this will only make it much more likely that you will encounter problems every single time you upgrade Fusion.  Fusion 4 and newer (maybe even earlier than that?) have all been self-contained and will not require any installation as long as you haven't already tampered with your system to the point where some cleanup is needed.

         

        You should never EVER manually copy around the kernel extensions nor manually load them, other than as a troubleshooting step performed under competent instruction.

         

        I suggest you unload the vmmon.kext you have loaded, then remove it completely from /System/Library/Extensions/vmmon.kext, reboot your system, and then launch Fusion.  Fusion will load the kernel extensions that it needs.

         

        Cheers,

        --

        Darius

        1 2 Previous Next