4 Replies Latest reply on Sep 8, 2014 11:20 AM by Scott58

    GUI crash on connecting to vSphere server

    wila Guru
    vExpertUser ModeratorsCommunity Warriors

      Hi,

       

      VMware Fusion Tech Preview July version.

       

      Connecting to a local vSphere 5.1 server after disconnecting the same server caused the GUI to completely crash.

      I had used the vSphere server connection for a few hours and it worked well. As I had connected via IP address directly, I disconnected and removed the IP details in the GUI. Then connected via domain name. On clicking "Connect" the GUI completely crashed.

       

      See attached file.

       

      I also grabbed a vmware-vmfusion.log file which I don't mind sharing, just not in the public forum as it contains a number of details of my vSphere environment.

       

      Oh and for the record, restarting the GUI brought back my VMs, but not connected to the vSphere server (will try that again next)

      --

      Wil

      | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
      | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
      | More info at https://www.vimalin.com
      | Twitter @wilva
      | VMware Wiki at http://www.vi-toolkit.com
        • 1. Re: GUI crash on connecting to vSphere server
          Enthusiast

          Hi wila,

           

          Thx a lot.

          What's host of you environment? And can you consistently reproduce the problem?

          I can't reproduce your problem in my machine(Mac OS X is 10.9.5), connect to a vSphere 5.5 server(as I don't have 5.1 server available).

          Pls email me your vmware-vmfusion.log. I send you my email by private message. Appreciate your help in advance.

          • 2. Re: GUI crash on connecting to vSphere server
            wila Guru
            User ModeratorsCommunity WarriorsvExpert

            Hi,

             

            OS X host is 10.8.5

            Will have to come back with the exact vSphere 5.1 host build number later on when I have the time to try and reproduce the issue.

            A crash like that might be difficult to reproduce. I've not seen it happening again, only the first time and I immediately posted it down here.

             

            --

            Wil

            | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
            | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
            | More info at https://www.vimalin.com
            | Twitter @wilva
            | VMware Wiki at http://www.vi-toolkit.com
            • 3. Re: GUI crash on connecting to vSphere server
              Enthusiast

              Hi wila,

              I can reproduce the problem on my env using Fusion 7 July Preview version (Mac OS X 10.8.5, connecting to vSphere 5.5), after below steps,

              Steps:

              1. Connect to a remote server by ip

              2. disconnect and remove

              3. connect to the same remote server by domain name

              Then, GUI crashed, and the assert is the same as your log.

               

              And I also try to reproduce the problem using Fusion 7 latest internal build, can't reproduce the problem, I think the problem probably have already fixed in Fusion 7. FYI.

              • 4. Re: GUI crash on connecting to vSphere server
                Scott58 Lurker

                I'm running into the same issue. Currently have a ticket opened with the VMware Fusion team. The issue happens when connecting to any ESXi server I have on premise. It does work fine in a new user, I'm at a point where isolating it to a conflicting piece of software. I am just unsure of which one is causing it.