1 2 Previous Next 25 Replies Latest reply on Feb 17, 2014 12:22 PM by Q3Q

    Please Help Backup Problem

    chungl83 Lurker

      Hi all!  Please forgive my English.

       

      Dryrun log

      dryrun - Pastebin.com

       

      debug log

      http://pastebin.com/vkVT2jGD

       

      Esxi:     5.5

      Backup datastore type:     local

       

      I don't know why can't backup. How to fix this problem?

       

       

      Thanks

        • 1. Re: Please Help Backup Problem
          Tondorf Lurker

          Hi,

           

          same problems here.

          Dryrun seems to be OK.

           

          Cronjob -> Error:

          2013-11-22 18:50:02 -- info:

          2013-11-22 18:50:39 -- info: ###### Final status: ERROR: No VMs backed up! ######

           

          2013-11-22 18:50:39 -- info: ============================== ghettoVCB LOG END ================================

           

          No more information.

           

          ESXi 5.5

          Local datastore

           

          Has someone any ideas how to solve the problem?

           

          Greetings

          • 2. Re: Please Help Backup Problem
            Q3Q Novice

            Hi

            I am seeing the same problem.

            Also ESXi 5.5 with local datastore.

             

            In my case I can guess what the problem might be:

             

            Due to some shoving around, the name of the vm does not correspond to the name of the container folder of the vm.

            Where my vm has a name of 'thevmname' the folder it is stored in has a name of  'thevmname_1'.

            The name of of vmx file however corresponds to the name of the vm.

             

            So my guess is that ghettoVCB is looking for the wrong folder...

             

            At least I thought so.

            After renaming the folder, the vm is back up, but still no backup possible.

            It would help, If the script would output a reason for this...

             

            Now it just says '###### Final status: ERROR: No VMs backed up! ######'

            • 3. Re: Please Help Backup Problem
              Q3Q Novice

              2013-11-26 12:51:33 -- info: ============================== ghettoVCB LOG START ==============================

               

               

              2013-11-26 12:51:33 -- debug: Succesfully acquired lock directory - /tmp/ghettoVCB.work

               

               

              2013-11-26 12:51:33 -- debug: HOST VERSION: VMware ESXi 5.5.0 build-1331820

              2013-11-26 12:51:33 -- debug: HOST LEVEL: VMware ESXi 5.5.0 GA

              2013-11-26 12:51:33 -- debug: HOSTNAME: myserver.mydomain.edu

               

               

              2013-11-26 12:51:33 -- info: CONFIG - USING GLOBAL GHETTOVCB CONFIGURATION FILE = ghettoVCB.conf

              2013-11-26 12:51:33 -- info: CONFIG - VERSION = 2013_01_11_0

              2013-11-26 12:51:33 -- info: CONFIG - GHETTOVCB_PID = 4363452

              2013-11-26 12:51:33 -- info: CONFIG - VM_BACKUP_VOLUME = /vmfs/volumes/myserver.backup

              2013-11-26 12:51:33 -- info: CONFIG - VM_BACKUP_ROTATION_COUNT = 3

              2013-11-26 12:51:33 -- info: CONFIG - VM_BACKUP_DIR_NAMING_CONVENTION = 2013-11-26_12-51-32

              2013-11-26 12:51:33 -- info: CONFIG - DISK_BACKUP_FORMAT = thin

              2013-11-26 12:51:33 -- info: CONFIG - POWER_VM_DOWN_BEFORE_BACKUP = 0

              2013-11-26 12:51:33 -- info: CONFIG - ENABLE_HARD_POWER_OFF = 0

              2013-11-26 12:51:33 -- info: CONFIG - ITER_TO_WAIT_SHUTDOWN = 3

              2013-11-26 12:51:33 -- info: CONFIG - POWER_DOWN_TIMEOUT = 5

              2013-11-26 12:51:33 -- info: CONFIG - SNAPSHOT_TIMEOUT = 15

              2013-11-26 12:51:33 -- info: CONFIG - LOG_LEVEL = debug

              2013-11-26 12:51:33 -- info: CONFIG - BACKUP_LOG_OUTPUT = /tmp/ghettoVCB-2013-11-26_12-51-32-4363452.log

              2013-11-26 12:51:33 -- info: CONFIG - ENABLE_COMPRESSION = 0

              2013-11-26 12:51:33 -- info: CONFIG - VM_SNAPSHOT_MEMORY = 0

              2013-11-26 12:51:33 -- info: CONFIG - VM_SNAPSHOT_QUIESCE = 0

              2013-11-26 12:51:33 -- info: CONFIG - ALLOW_VMS_WITH_SNAPSHOTS_TO_BE_BACKEDUP = 1

              2013-11-26 12:51:33 -- info: CONFIG - VMDK_FILES_TO_BACKUP = all

              2013-11-26 12:51:33 -- info: CONFIG - VM_SHUTDOWN_ORDER =

              2013-11-26 12:51:33 -- info: CONFIG - VM_STARTUP_ORDER =

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_LOG = 1

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_SERVER = mail.mydomain.edu

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_SERVER_PORT = 25

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_DELAY_INTERVAL = 1

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_FROM = myserver@mydomain.ch

              2013-11-26 12:51:33 -- info: CONFIG - EMAIL_TO = ictadmin@mydomain.ch

              2013-11-26 12:51:33 -- info: CONFIG - WORKDIR_DEBUG = 0

              2013-11-26 12:51:33 -- info:

              2013-11-26 12:51:37 -- debug: Storage Information before backup:

              2013-11-26 12:51:37 -- debug: SRC_DATASTORE: myserver.hd

              2013-11-26 12:51:37 -- debug: SRC_DATASTORE_CAPACITY: 63488.0

              1862.5 GB

              2013-11-26 12:51:37 -- debug: SRC_DATASTORE_FREE: 1750.0 GB

              2013-11-26 12:51:37 -- debug: SRC_DATASTORE_BLOCKSIZE: 1

              2013-11-26 12:51:37 -- debug: SRC_DATASTORE_MAX_FILE_SIZE: 256 GB

              2013-11-26 12:51:37 -- debug:

              2013-11-26 12:51:37 -- debug: DST_DATASTORE: myserver.backup

              2013-11-26 12:51:37 -- debug: DST_DATASTORE_CAPACITY: 63488.0

              1862.8 GB

              2013-11-26 12:51:37 -- debug: DST_DATASTORE_FREE: 1783.3 GB

              2013-11-26 12:51:37 -- debug: DST_DATASTORE_BLOCKSIZE: 1

              2013-11-26 12:51:37 -- debug: DST_DATASTORE_MAX_FILE_SIZE: 256 GB

              2013-11-26 12:51:37 -- debug:

              2013-11-26 12:51:37 -- info: ###### Final status: ERROR: No VMs backed up! ######

               

               

              2013-11-26 12:51:37 -- debug: Succesfully removed lock directory - /tmp/ghettoVCB.work

               

               

              2013-11-26 12:51:37 -- info: ============================== ghettoVCB LOG END ================================

              • 4. Re: Please Help Backup Problem
                davidneudorfer Novice

                My debug output looks like this too. I haven't been able to figure out the problem. Any suggestions?

                • 5. Re: Please Help Backup Problem
                  lamw Guru
                  Community WarriorsVMware Employees

                  Can you also provide the output of the dryrun output? For miss-matched directory names and VM Display Name, this gets a bit difficult to process as what do you base the "searched" name from. It's best you get those resolved before proceeding with backups

                  • 6. Re: Please Help Backup Problem
                    davidneudorfer Novice

                    Thanks! It finds the vmx file in the dry run but fails when I try and do the actual backup.

                     

                    2013-11-26 21:35:12 -- info: ============================== ghettoVCB LOG START ==============================

                     

                    2013-11-26 21:35:12 -- info: CONFIG - VERSION = 2013_01_11_0

                    2013-11-26 21:35:12 -- info: CONFIG - GHETTOVCB_PID = 10593266

                    2013-11-26 21:35:12 -- info: CONFIG - VM_BACKUP_VOLUME = /vmfs/volumes/norco/vm_backups/

                    2013-11-26 21:35:12 -- info: CONFIG - VM_BACKUP_ROTATION_COUNT = 3

                    2013-11-26 21:35:12 -- info: CONFIG - VM_BACKUP_DIR_NAMING_CONVENTION = 2013-11-26_21-35-11

                    2013-11-26 21:35:12 -- info: CONFIG - DISK_BACKUP_FORMAT = thin

                    2013-11-26 21:35:12 -- info: CONFIG - POWER_VM_DOWN_BEFORE_BACKUP = 0

                    2013-11-26 21:35:12 -- info: CONFIG - ENABLE_HARD_POWER_OFF = 0

                    2013-11-26 21:35:12 -- info: CONFIG - ITER_TO_WAIT_SHUTDOWN = 3

                    2013-11-26 21:35:12 -- info: CONFIG - POWER_DOWN_TIMEOUT = 5

                    2013-11-26 21:35:12 -- info: CONFIG - SNAPSHOT_TIMEOUT = 15

                    2013-11-26 21:35:12 -- info: CONFIG - LOG_LEVEL = dryrun

                    2013-11-26 21:35:12 -- info: CONFIG - BACKUP_LOG_OUTPUT = /tmp/ghettoVCB-2013-11-26_21-35-11-10593266.log

                    2013-11-26 21:35:12 -- info: CONFIG - ENABLE_COMPRESSION = 0

                    2013-11-26 21:35:12 -- info: CONFIG - VM_SNAPSHOT_MEMORY = 0

                    2013-11-26 21:35:12 -- info: CONFIG - VM_SNAPSHOT_QUIESCE = 1

                    2013-11-26 21:35:12 -- info: CONFIG - ALLOW_VMS_WITH_SNAPSHOTS_TO_BE_BACKEDUP = 1

                    2013-11-26 21:35:12 -- info: CONFIG - VMDK_FILES_TO_BACKUP = all

                    2013-11-26 21:35:12 -- info: CONFIG - VM_SHUTDOWN_ORDER =

                    2013-11-26 21:35:12 -- info: CONFIG - VM_STARTUP_ORDER =

                    2013-11-26 21:35:12 -- info: CONFIG - EMAIL_LOG = 0

                    2013-11-26 21:35:12 -- info:

                    2013-11-26 21:35:12 -- dryrun: ###############################################

                    2013-11-26 21:35:12 -- dryrun: Virtual Machine: AD-VM0

                    2013-11-26 21:35:12 -- dryrun: VM_ID: 36

                    2013-11-26 21:35:12 -- dryrun: VMX_PATH: /vmfs/volumes/xServe RAID 3/ad.office.lbox.com/ad.office.lbox.com.vmx

                    2013-11-26 21:35:12 -- dryrun: VMX_DIR: /vmfs/volumes/xServe RAID 3/ad.office.lbox.com

                    2013-11-26 21:35:12 -- dryrun: VMX_CONF: ad.office.lbox.com/ad.office.lbox.com.vmx

                    2013-11-26 21:35:12 -- dryrun: VMFS_VOLUME: xServe RAID 3

                    2013-11-26 21:35:12 -- dryrun: VMDK(s):

                    2013-11-26 21:35:12 -- dryrun: ad.office.lbox.com-000001.vmdk 300 GB

                    2013-11-26 21:35:12 -- dryrun: INDEPENDENT VMDK(s):

                    2013-11-26 21:35:12 -- dryrun: TOTAL_VM_SIZE_TO_BACKUP: 300 GB

                    2013-11-26 21:35:12 -- dryrun: Snapshots found for this VM, ALL EXISTING SNAPSHOTS WILL BE CONSOLIDATED PRIOR TO BACKUP!

                    2013-11-26 21:35:12 -- dryrun: ###############################################

                     

                    2013-11-26 21:35:12 -- info: ###### Final status: OK, only a dryrun. ######

                     

                    2013-11-26 21:35:12 -- info: ============================== ghettoVCB LOG END ================================

                    • 7. Re: Please Help Backup Problem
                      lamw Guru
                      Community WarriorsVMware Employees

                      Are you using the latest version from github site? I know there was an issue reported that for VMs w/snapshots it didn't consolidate, only printed the message as you see above. I suspect that's what is happening which I thought was fixed in the latest release.

                      • 8. Re: Please Help Backup Problem
                        davidneudorfer Novice

                        ~ # /sbin/ghettoVCB/ghettoVCB.sh                   

                        ###############################################################################

                        #

                        # ghettoVCB for ESX/ESXi 3.5, 4.x+ and 5.x

                        # Author: William Lam

                        # http://www.virtuallyghetto.com/

                        # Documentation: http://communities.vmware.com/docs/DOC-8760

                        # Created: 11/17/2008

                        # Last modified: 2013_01_11 Version 0

                        #

                        ###############################################################################

                         

                        Looks like I'm using the one modified Jan 11, 2013. I'll update to the latest version and let everyone know.

                        • 9. Re: Please Help Backup Problem
                          lamw Guru
                          VMware EmployeesCommunity Warriors

                          Okay, I know what's going on now. Just tested the fix in my lab and pushed the changes to github. You can see the changes here https://github.com/lamw/ghettoVCB/commit/32487120adcf8a01b7e1ab73baa711fcc9a93bc0 or just download the latest version. Let me know if you still have any issues

                          • 10. Re: Please Help Backup Problem
                            davidneudorfer Novice

                            This is ESXi 5.0 and running the updated ghettoVCB.sh:

                             

                            /sbin/ghettoVCB/ghettoVCB.sh: line 1197: syntax error: "done" unexpected (expecting "fi")

                            • 11. Re: Please Help Backup Problem
                              lamw Guru
                              VMware EmployeesCommunity Warriors

                              Missed elif in the if/else statement. Sorry about that

                              • 12. Re: Please Help Backup Problem
                                davidneudorfer Novice

                                /sbin/ghettoVCB # /sbin/ghettoVCB/ghettoVCB.sh -m AD-VM0 -d debug

                                Logging output to "/tmp/ghettoVCB-2013-11-26_23-19-38-10607031.log" ...

                                2013-11-26 23:19:38 -- info: ============================== ghettoVCB LOG START ==============================

                                 

                                2013-11-26 23:19:38 -- debug: Succesfully acquired lock directory - /tmp/ghettoVCB.work

                                 

                                2013-11-26 23:19:38 -- debug: HOST VERSION: VMware ESXi 5.0.0 build-768111

                                2013-11-26 23:19:38 -- debug: HOST LEVEL: VMware ESXi 5.0.0 Update 1

                                2013-11-26 23:19:38 -- debug: HOSTNAME: batman.lbox.com

                                 

                                2013-11-26 23:19:38 -- info: CONFIG - VERSION = 2013_26_11_1

                                2013-11-26 23:19:38 -- info: CONFIG - GHETTOVCB_PID = 10607031

                                2013-11-26 23:19:38 -- info: CONFIG - VM_BACKUP_VOLUME = /vmfs/volumes/norco/vm_backups/

                                2013-11-26 23:19:38 -- info: CONFIG - VM_BACKUP_ROTATION_COUNT = 3

                                2013-11-26 23:19:38 -- info: CONFIG - VM_BACKUP_DIR_NAMING_CONVENTION = 2013-11-26_23-19-38

                                2013-11-26 23:19:38 -- info: CONFIG - DISK_BACKUP_FORMAT = thin

                                2013-11-26 23:19:38 -- info: CONFIG - POWER_VM_DOWN_BEFORE_BACKUP = 0

                                2013-11-26 23:19:38 -- info: CONFIG - ENABLE_HARD_POWER_OFF = 0

                                2013-11-26 23:19:38 -- info: CONFIG - ITER_TO_WAIT_SHUTDOWN = 3

                                2013-11-26 23:19:38 -- info: CONFIG - POWER_DOWN_TIMEOUT = 5

                                2013-11-26 23:19:38 -- info: CONFIG - SNAPSHOT_TIMEOUT = 15

                                2013-11-26 23:19:38 -- info: CONFIG - LOG_LEVEL = debug

                                2013-11-26 23:19:38 -- info: CONFIG - BACKUP_LOG_OUTPUT = /tmp/ghettoVCB-2013-11-26_23-19-38-10607031.log

                                2013-11-26 23:19:38 -- info: CONFIG - ENABLE_COMPRESSION = 0

                                2013-11-26 23:19:38 -- info: CONFIG - VM_SNAPSHOT_MEMORY = 0

                                2013-11-26 23:19:38 -- info: CONFIG - VM_SNAPSHOT_QUIESCE = 0

                                2013-11-26 23:19:39 -- info: CONFIG - ALLOW_VMS_WITH_SNAPSHOTS_TO_BE_BACKEDUP = 0

                                2013-11-26 23:19:39 -- info: CONFIG - VMDK_FILES_TO_BACKUP = all

                                2013-11-26 23:19:39 -- info: CONFIG - VM_SHUTDOWN_ORDER =

                                2013-11-26 23:19:39 -- info: CONFIG - VM_STARTUP_ORDER =

                                2013-11-26 23:19:39 -- info: CONFIG - EMAIL_LOG = 0

                                2013-11-26 23:19:39 -- info:

                                2013-11-26 23:19:41 -- debug: Storage Information before backup:

                                2013-11-26 23:19:41 -- debug: SRC_DATASTORE: xServe RAID 3

                                2013-11-26 23:19:41 -- debug: SRC_DATASTORE_CAPACITY: 2794.5 GB

                                2013-11-26 23:19:41 -- debug: SRC_DATASTORE_FREE: 1097.1 GB

                                2013-11-26 23:19:41 -- debug: SRC_DATASTORE_BLOCKSIZE: 1

                                2013-11-26 23:19:41 -- debug: SRC_DATASTORE_MAX_FILE_SIZE: 256 GB

                                2013-11-26 23:19:41 -- debug:

                                2013-11-26 23:19:41 -- debug: DST_DATASTORE: norco

                                2013-11-26 23:19:41 -- debug: DST_DATASTORE_CAPACITY: 29695.8 GB

                                2013-11-26 23:19:41 -- debug: DST_DATASTORE_FREE: 27267.4 GB

                                2013-11-26 23:19:41 -- debug: DST_DATASTORE_BLOCKSIZE: 1

                                2013-11-26 23:19:41 -- debug: DST_DATASTORE_MAX_FILE_SIZE: 256 GB

                                2013-11-26 23:19:41 -- debug:

                                2013-11-26 23:19:41 -- info: Snapshot found for AD-VM0, backup will not take place

                                 

                                2013-11-26 23:19:43 -- debug: getVMDKs() - ad.office.lbox.com-000001.vmdk###300:

                                2013-11-26 23:19:43 -- info: Initiate backup for AD-VM0

                                2013-11-26 23:19:43 -- info: Creating Snapshot "ghettoVCB-snapshot-2013-11-26" for AD-VM0

                                2013-11-26 23:19:45 -- debug: Waiting for snapshot "ghettoVCB-snapshot-2013-11-26" to be created

                                2013-11-26 23:19:45 -- debug: Snapshot timeout set to: 900 seconds

                                2013-11-26 23:19:46 -- debug: findVMDK() - Searching for VMDK: "ad.office.lbox.com-000001.vmdk" to backup

                                2013-11-26 23:19:46 -- debug: /sbin/vmkfstools -i "/vmfs/volumes/xServe RAID 3/ad.office.lbox.com/ad.office.lbox.com-000001.vmdk" -a "" -d "thin" "/vmfs/volumes/norco/vm_backups//AD-VM0/AD-VM0-2013-11-26_23-19-38/ad.office.lbox.com-000001.vmdk"

                                 

                                2013-11-26 23:19:46 -- info: ERROR: error in backing up of "/vmfs/volumes/xServe RAID 3/ad.office.lbox.com/ad.office.lbox.com-000001.vmdk" for AD-VM0

                                 

                                After running this, "Remove Snapshot" has been stuck at 0% for about 5 minutes now. http://cl.ly/Sfo6

                                Also it warns of having snapshots but other then the snapshot created by ghettoVCB *after* the snapshot warning. There are no snapshots. Screen Shot 2013-11-26 at 3.22.55 PM.png

                                 

                                Thanks for all your hard work Will, we all definitely appreciate it!

                                • 13. Re: Please Help Backup Problem
                                  davidneudorfer Novice

                                  Remove snapshot just made it to 1% so its not completely stuck, just slow like snail.

                                  • 14. Re: Please Help Backup Problem
                                    davidneudorfer Novice

                                    Running it a second time seems to have fixed it! Thanks Will.

                                    1 2 Previous Next