12 Replies Latest reply on Nov 20, 2014 12:30 PM by Ben Liebowitz

    Automating Converter Standalone using Converter-cli.exe

    sratcliff Novice

      Hi,

       

      I have worked out that this must be possible because of the inclusion of converter-cli.exe with Converter 5.0.1 Build 875114, plus I've got very close but not quite close enough!  I have vCenter 5.0 and ESXi 5.0.0 hosts.

       

      I am using the following XML and it's submitting the job to Converter with what looks like to be the correct details but fails straight away with the error:

      FAILED: The source configuration file is invalid, corrupted or not recognized.

       

      I've checked logs in the following locations but nothing gives me any clues as to what isn't quite right:

      C:\ProgramData\VMware\VMware vCenter Converter Standalone\logs

      C:\Users\All Users\VMware\VMware vCenter Converter Standalone\logs

      C:\Users\XXAdmin\AppData\Local\VMware\VMware vCenter Converter Standalone Client\Logs

      Anywhere else I can look?

       

      My XML file (p2v.xml):

       

      <p2v version="2.2" xmlns="http://www.vmware.com/v2/sysimage/p2v" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

      xsi:schemaLocation="http://www.vmware.com/v2/sysimage/p2v p2vJob.xsd" xsi:type="P2VJob">
        <source>
          <hostedSpec networkPassword="domainpassword" networkUsername="domain\username" path="PHYSICALSERVER"/>
        </source>
        <dest>
          <managedSpec datastore="Datastore XXXX" folder="Temp" host="HOST1" resourcePool="" vmName="NEWVM">
            <creds host="VCENTER" port="0" type="sessionId" username="domain\username" password="domainpassword" />
          </managedSpec>
        </dest>
        <importParams diskType="VMFS" preserveHWInfo="true" removeSystemRestore="false" targetProductVersion="PRODUCT_MANAGED">
          <nicMappings/>
          <diskLocations/>
        </importParams>
        <postProcessingParams/>
      </p2v>

       

      I'm running the command: C:\Program Files (x86)\VMware\VMware vCenter Converter Standalone>converter-cli -s C:\Temp\p2v.xml

       

      I feel sure that this is just a minor issue with the xml input configuration file and if I knew the correct syntax or had an example file I could get it working. I can't find one anywhere. Should the datastore be the name vSphere/ESXi knows it as rather than the name I see in the vSphere Client?

       

      Please help!

       

      Thanks