7 Replies Latest reply on Oct 13, 2013 6:07 AM by CalvinBlueFish

    vmware.service fail on Fedora 19

    skruju Lurker

      Hi all.

       

      I'm unsuccessfully trying to run vmware.service via systemd on Fedora 19.

      Kernel Info: 3.10.3-300.fc19.x86_64

      VMware player: VMware-Player-5.0.2-1031769.x86_64.bin

      altus# rpm -qa |grep vmware

           xorg-x11-drv-vmware-13.0.1-1.fc19.x86_64

       

      When I try to run vmware player from the GUI (), first I get messagebox saying "Before you can run VMware, several modules must be compiled and loaded into the running kernel" and when I click on Install button, nothing happens. Here are some logs generated on button click:

      /var/log/messages

      Aug  1 11:23:24 altus kernel: [157759.696449] vmware-gksu[24580]: segfault at 7fe5d58194ab ip 00007fe5da08c196 sp 00007fff14246b78 error 4 in libc-2.17.so[7fe5d9f5b000+1b5000]

      Aug  1 11:23:24 altus abrt[24585]: Saved core dump of pid 24580 (/usr/lib/vmware/bin/appLoader) to /var/tmp/abrt/ccpp-2013-08-01-11:23:24-24580 (2121728 bytes)

      Aug  1 11:23:24 altus abrtd: Directory 'ccpp-2013-08-01-11:23:24-24580' creation detected

      Aug  1 11:23:26 altus abrtd: Executable '/usr/lib/vmware/bin/appLoader' doesn't belong to any package and ProcessUnpackaged is set to 'no'

      Aug  1 11:23:26 altus abrtd: 'post-create' on '/var/tmp/abrt/ccpp-2013-08-01-11:23:24-24580' exited with 1

      Aug  1 11:23:26 altus abrtd: Deleting problem directory '/var/tmp/abrt/ccpp-2013-08-01-11:23:24-24580'

       

      After that I tried to run systemctl start vmware.service but if FAILS.

      altus# systemctl start vmware.service

      Job for vmware.service failed.

       

      journalctl -xn output:

      -- Logs begin at Tue 2013-07-02 16:51:21 CEST, end at Thu 2013-08-01 11:05:15 CEST. --

      Aug 01 11:05:09 altus.local vmware[24218]: Starting VMware services:

      Aug 01 11:05:10 altus.local vmware[24218]: Virtual machine monitor[FAILED]

      Aug 01 11:05:10 altus.local vmware[24218]: Virtual machine communication interface[FAILED]

      Aug 01 11:05:15 altus.local vmware[24218]: VM communication interface socket family[  OK  ]

      Aug 01 11:05:15 altus.local vmware[24218]: Blocking file system[  OK  ]

      Aug 01 11:05:15 altus.local vmware[24218]: Virtual ethernet[FAILED]

      Aug 01 11:05:15 altus.local vmware[24218]: VMware Authentication Daemon[  OK  ]

      Aug 01 11:05:15 altus.local systemd[1]: vmware.service: control process exited, code=exited status=1

      Aug 01 11:05:15 altus.local systemd[1]: Failed to start SYSV: This service starts and stops VMware servic

      -- Subject: Unit vmware.service has failed

      -- Defined-By: systemd

      -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

      -- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f0

      --

      -- Unit vmware.service has failed.

      --

      -- The result is failed.

      Aug 01 11:05:15 altus.local systemd[1]: Unit vmware.service entered failed state.

       

      Has anyone achieved to start vmware service on systemd? Am I missing some modules or what? Also, If you need output of some other logs I currently can't remember, I will be glad to post it here.

       

      Help please!