12 Replies Latest reply on May 14, 2013 4:07 AM by MKguy

    vSphere Management Assistant (vMA) 5 Problem update

    ii00907 Enthusiast

      Hi to all,

      i have a problem when run, via WEB GUI , the update.

       

      I check the new updates

       

      5.0.0.1 Build 643553

       

      But when run Install updates , i have this error;

       

      Failed to install updates (Error while running package installation)

       

       

      In attach the screen

       

      Thanks for the support

        • 1. Re: vSphere Management Assistant (vMA) 5 Problem update
          DorseyFoga Lurker

          I'm running into the same problem as well.  One other thing I noticed is that the VM is not treated as a Virtual Application.  You can run the update through Update Manager on this VM.  Every time I scan this VM with just Virtual Appliance upgrades checked, it fails saying taht the operation is not supported on this object.  Not sure if it's related, but just thought I would point it out...

          • 2. Re: vSphere Management Assistant (vMA) 5 Problem update
            lamw Guru
            VMware EmployeesCommunity Warriors

            @ii00907,

             

            You should be able to get more details by looking at the vami logs /opt/vmware/var/log/vami/vami.log

            • 3. Re: vSphere Management Assistant (vMA) 5 Problem update
              lamw Guru
              Community WarriorsVMware Employees

              @DorseyFoga,

               

              vMA patching can not be managed by VUM, you need to update it through the web management interface by going to https://vma-ip:5480

              • 4. Re: vSphere Management Assistant (vMA) 5 Problem update
                ii00907 Enthusiast

                Hi William,

                thanks for the support .

                 

                I see output vami.log, but i don't see error;

                 

                22/03/2012 09:54:03 5370 installUpdate:UpdateResource.cpp:285 (update) [INFO] Installing updates. instanceid=VMware:VMware_5.0.0.1, jobid=30
                22/03/2012 09:54:03 5370 installFromSoftwareIdentity:UpdateAgentInterface.cpp:566 (update) [INFO] Installing update. instanceId=VMware:VMware_5.0.0.1, jobId=30, url=http://vapp-updates.vmware.com/vai-catalog/valm/vmw/449bf27f-70b9-476e-af17-fc4369637c25/5.0.0.1.latest, username=, password=
                22/03/2012 09:54:03 5370 DoDownloadInstallUpdate:UA_Executive.cpp:672 (update) [INFO] Downloading and installing update packages
                22/03/2012 09:54:03 5370 OpenURL:UA_Network.cpp:176 (update) [INFO] Using download cache
                22/03/2012 09:54:03 5370 Download:UA_Network.cpp:356 (update) [INFO] Downloading file. URL: http://vapp-updates.vmware.com/vai-catalog/valm/vmw/449bf27f-70b9-476e-af17-fc4369637c25/5.0.0.1.latest/manifest/manifest-latest.xml
                22/03/2012 09:54:03 5370 OpenURL:UA_Network.cpp:264 (update) [INFO] Using cache file content
                22/03/2012 09:54:03 5370 OpenURL:UA_Network.cpp:176 (update) [INFO] Using download cache
                22/03/2012 09:54:03 5370 Download:UA_Network.cpp:356 (update) [INFO] Downloading file. URL: http://vapp-updates.vmware.com/vai-catalog/valm/vmw/449bf27f-70b9-476e-af17-fc4369637c25/5.0.0.1.latest/manifest/manifest-latest.xml.sig
                22/03/2012 09:54:03 5370 OpenURL:UA_Network.cpp:264 (update) [INFO] Using cache file content
                22/03/2012 09:54:03 5370 addFileToLog:UA_Util.cpp:231 (update) [INFO] Signature script output: Verified OK
                22/03/2012 09:54:03 5370 addFileToLog:UA_Util.cpp:231 (update) [INFO] Signature script output:
                22/03/2012 09:54:03 5370 ValidateSignature:UA_Manifest.cpp:87 (update) [INFO] Manifest signature verification passed
                22/03/2012 09:54:03 5370 PrintPackages:UA_PackageSet.cpp:286 (update) [INFO] Downloading the following packages for update version 5.0.0.1
                22/03/2012 09:54:03 5370 PrintPackages:UA_PackageSet.cpp:299 (update) [INFO] package NEW PACKAGE   : vmware-open-vm-tools-common  x86_64  (none)  8.3.2  292861.sles11sp1  /package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm  rpm  5283072  dd78252d99f6eba04ba372dab50fe8cdb5dc18fa
                22/03/2012 09:54:03 5370 PrintPackages:UA_PackageSet.cpp:299 (update) [INFO] package NEW PACKAGE   : vmware-open-vm-tools-kmod  x86_64  (none)  8.3.2  292861.sles11sp1  /package-pool/vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64.rpm  rpm  130690  bfb675a04843a19717d987a296d61ac8f0b78982
                22/03/2012 09:54:03 5370 Download:UA_Network.cpp:356 (update) [INFO] Downloading file. URL: http://vapp-updates.vmware.com/vai-catalog/valm/vmw/449bf27f-70b9-476e-af17-fc4369637c25/5.0.0.1.latest/package%2Dpool/vmware%2Dopen%2Dvm%2Dtools%2Dcommon%2D8%2E3%2E2%2D292861%2Esles11sp1%2Ex86%5F64%2Erpm
                22/03/2012 09:54:04 5370 DownloadPackageSet:UA_DownloadManager.cpp:70 (update) [INFO] Downloaded file. url=/package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm
                22/03/2012 09:54:04 5370 Download:UA_Network.cpp:356 (update) [INFO] Downloading file. URL: http://vapp-updates.vmware.com/vai-catalog/valm/vmw/449bf27f-70b9-476e-af17-fc4369637c25/5.0.0.1.latest/package%2Dpool/vmware%2Dopen%2Dvm%2Dtools%2Dkmod%2D8%2E3%2E2%2D292861%2Esles11sp1%2Ex86%5F64%2Erpm
                22/03/2012 09:54:04 5370 DownloadPackageSet:UA_DownloadManager.cpp:70 (update) [INFO] Downloaded file. url=/package-pool/vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64.rpm
                22/03/2012 09:54:04 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:166 (update) [INFO] Creating install script files for updatecli
                22/03/2012 09:54:04 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:178 (update) [INFO] Using update pre-install script
                22/03/2012 09:54:04 5370 PrintPackages:UA_PackageSet.cpp:286 (update) [INFO] Update version 5.0.0.1. Installing the following packages:
                22/03/2012 09:54:04 5370 PrintPackages:UA_PackageSet.cpp:299 (update) [INFO] package NEW PACKAGE   : vmware-open-vm-tools-common  x86_64  (none)  8.3.2  292861.sles11sp1  /package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm  rpm  5283072  dd78252d99f6eba04ba372dab50fe8cdb5dc18fa
                22/03/2012 09:54:04 5370 PrintPackages:UA_PackageSet.cpp:299 (update) [INFO] package NEW PACKAGE   : vmware-open-vm-tools-kmod  x86_64  (none)  8.3.2  292861.sles11sp1  /package-pool/vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64.rpm  rpm  130690  bfb675a04843a19717d987a296d61ac8f0b78982
                22/03/2012 09:54:04 5370 InstallPackageSet:UA_RPMInterface.cpp:65 (update) [INFO] Install packages set:  '/opt/vmware/var/lib/vami/update/data/package-pool/package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm' '/opt/vmware/var/lib/vami/update/data/package-pool/package-pool/vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64.rpm'
                22/03/2012 09:54:04 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:220 (update) [INFO] Update 5.0.0.1 manifest is set to be installed
                22/03/2012 09:54:04 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:227 (update) [INFO] Using update post-install script
                22/03/2012 09:54:04 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:302 (update) [INFO] Running updatecli to install update. command={ /opt/vmware/share/vami/update/updatecli '/opt/vmware/var/lib/vami/update/data/job/30' '5.0.0.0' '5.0.0.1' ; /opt/vmware/bin/vamicli version --appliance ;  } >> /opt/vmware/var/log/vami/updatecli.log 2>&1 &
                22/03/2012 09:54:05 5370 DoInstallDownloadedUpdates:UA_Executive.cpp:322 (update) [INFO] Installation running in the background

                 

                but i see error on updatecli.log

                 

                Preparing packages for installation...
                VMware Tools cannot install because it appears that another installation of
                VMware Tools is already present. Please remove the previous installation and
                then attempt to install this copy of VMware Tools again.
                error: %pre(vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64) scriptlet failed, exit status 1
                error:   install: %pre scriptlet failed (2), skipping vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1
                VMware Tools cannot install because it appears that another installation of
                VMware Tools is already present. Please remove the previous installation and
                then attempt to install this copy of VMware Tools again.

                 

                I installed vmware-tools via your procedure ( http://www.virtuallyghetto.com/2011/07/tips-and-tricks-for-vma-5.html )

                 

                Should I remove the vmware-tools and try again with VMA update via gui?

                 

                Thanks

                • 5. Re: vSphere Management Assistant (vMA) 5 Problem update
                  lamw Guru
                  Community WarriorsVMware Employees

                  Looking at the error, it looks you like you might have installed another version of VMware Tools on your vMA host? If you look at my article, it shows you how to "remove" the default version of VMware Tools which is (open-vm-tools) and not the version that is distributed with vSphere. I'm assuming that it expects the original version since it can't upgrade it the non-open-vm-tools. Go ahead and uninstall VMware Tools if that is the case and then try the update again

                  • 6. Re: vSphere Management Assistant (vMA) 5 Problem update
                    ii00907 Enthusiast

                    Hi William,

                    i have the same problem;

                     

                    Description - Upgrade to version 5.0.0.0
                    22/03/2012 14:58:52 30432 main:UA_CLI.cpp:187 (updatecli) [INFO] Starting Install
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Starting Install
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Running pre-install scripts
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:86 (updatecli) [INFO] Running /opt/vmware/var/lib/vami/update/data/job/40/pre_install '5.0.0.0' '5.0.0.1'
                    Installing update from version 5.0.0.0 to version 5.0.0.1
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Done pre-install scripts
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Running installation tests
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:86 (updatecli) [INFO] Running /opt/vmware/var/lib/vami/update/data/job/40/test_command
                    warning: /opt/vmware/var/lib/vami/update/data/package-pool/package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                    Preparing packages for installation...
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Done installation tests
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Running package installation
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:86 (updatecli) [INFO] Running /opt/vmware/var/lib/vami/update/data/job/40/run_command
                    warning: /opt/vmware/var/lib/vami/update/data/package-pool/package-pool/vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                    Preparing packages for installation...
                    VMware Tools cannot install because it appears that another installation of
                    VMware Tools is already present. Please remove the previous installation and
                    then attempt to install this copy of VMware Tools again.
                    error: %pre(vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1.x86_64) scriptlet failed, exit status 1
                    error:   install: %pre scriptlet failed (2), skipping vmware-open-vm-tools-kmod-8.3.2-292861.sles11sp1
                    VMware Tools cannot install because it appears that another installation of
                    VMware Tools is already present. Please remove the previous installation and
                    then attempt to install this copy of VMware Tools again.
                    error: %pre(vmware-open-vm-tools-common-8.3.2-292861.sles11sp1.x86_64) scriptlet failed, exit status 1
                    error:   install: %pre scriptlet failed (2), skipping vmware-open-vm-tools-common-8.3.2-292861.sles11sp1
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:92 (updatecli) [ERROR] Failed with exit code 512
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Running post-install scripts
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:86 (updatecli) [INFO] Running /opt/vmware/var/lib/vami/update/data/job/40/post_install '5.0.0.0' '5.0.0.1' 4
                    Failed with status of 4 while installing version 5.0.0.1
                    VM version is still 5.0.0.0
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Done post-install scripts
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Running VMware tools reconfiguration
                    22/03/2012 14:58:52 30432 executeFile:UA_CLI.cpp:86 (updatecli) [INFO] Running /opt/vmware/share/vami/vami_reconfigure_tools
                    Configuring VAMI VMware tools service wrapper.
                    /opt/vmware/share/vami/vami_reconfigure_tools: line 29: type: vmware-toolbox-cmd: not found
                    Configuring /etc/vmware-tools/tools.conf to add power-on and resume scripts.
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Done VMware tools reconfiguration
                    22/03/2012 14:58:52 30432 updateStatus:UA_CLI.cpp:45 (updatecli) [INFO] Update status: Error while running package installation
                    22/03/2012 14:58:52 30432 main:UA_CLI.cpp:223 (updatecli) [ERROR] Failure: updatecli exiting abnormally
                    22/03/2012 14:58:52 30432 main:UA_CLI.cpp:225 (updatecli) [INFO] Install Finished
                    Version - 5.0.0.0 Build 472630
                    Description - Upgrade to version 5.0.0.0

                     

                    I have remove the vmware-tools i installed!!!

                     

                    What do you think are the vmware tools that he is already installed?

                     

                    Thanks for the support

                    • 7. Re: vSphere Management Assistant (vMA) 5 Problem update
                      lamw Guru
                      VMware EmployeesCommunity Warriors

                      Interesting error message.

                       

                      Can you do me a quick favor, just curious. Can you deploy a new vMA 5.0 version on the same network/environment then just update it to vMA 5.0 patch01 and see if that's succesful? Wondering if it's something with your environment or just that vMA instance that might have been tweaked and it's not liking that ...

                      • 8. Re: vSphere Management Assistant (vMA) 5 Problem update
                        ii00907 Enthusiast

                        Hi William,

                        I was already performing the test!!!!!

                         

                         

                        I will make you know.

                         

                        Thanks for your support and patience.

                        • 9. Re: vSphere Management Assistant (vMA) 5 Problem update
                          ii00907 Enthusiast

                          Hi William,

                          i have deploy vMA 5 on my datacenter and upgrade to 5 update 1 with success.

                           

                           

                          But is possible my install vmware tools to create some problem?

                           

                          Thanks for the support

                          • 10. Re: vSphere Management Assistant (vMA) 5 Problem update
                            lamw Guru
                            Community WarriorsVMware Employees

                            I suspect that as part of the upgrade, it assumes you have the default version of VMware Tools installed which is the open-vm-tools. The installer must not like the fact that it has been changed. You can try to find the version that came with the default here - http://www.vmware.com/download/packages.html and see if that helps.

                            • 11. Re: vSphere Management Assistant (vMA) 5 Problem update
                              ii00907 Enthusiast

                              Hi William,

                              i see, but when run rpm i have many  dependencies;

                               

                              vi-admin@itrmvma:~> ls
                              bin  vmware-tools-core-8.6.5-2.x86_64.rpm
                              vi-admin@itrmvma:~> sudo rpm -ivh vmware-tools-core-8.6.5-2.x86_64.rpm
                              vi-admin's password:
                              warning: vmware-tools-core-8.6.5-2.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                              error: Failed dependencies:
                                      vmware-tools-libraries-nox = 0:8.6.5 is needed by vmware-tools-core-8.6.5-2.x86_64
                                      vmware-tools-guestlib = 0:8.6.5 is needed by vmware-tools-core-8.6.5-2.x86_64
                                      vmware-tools-foundation >= 0:8.6.5 is needed by vmware-tools-core-8.6.5-2.x86_64
                              vi-admin@itrmvma:~> sudo rpm -ivh vmware-tools-libraries-nox-8.6.5-2.x86_64.rpm
                              warning: vmware-tools-libraries-nox-8.6.5-2.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                              error: Failed dependencies:
                                      vmware-tools-foundation >= 0:8.6.5 is needed by vmware-tools-libraries-nox-8.6.5-2.x86_64
                              vi-admin@itrmvma:~> sudo rpm -ivh vmware-tools-foundation-8.6.5-4.x86_64.rpm
                              warning: vmware-tools-foundation-8.6.5-4.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                              Preparing...                ########################################### [100%]

                              VMware Tools cannot install because it appears that another installation of
                              VMware Tools is already present. Please remove the previous installation and
                              then attempt to install this copy of VMware Tools again.

                              error: %pre(vmware-tools-foundation-8.6.5-4.x86_64) scriptlet failed, exit status 1
                              error:   install: %pre scriptlet failed (2), skipping vmware-tools-foundation-8.6.5-4
                              vi-admin@itrmvma:~> sudo rpm -ivh vmware-tools-esx-8.6.5-2.x86_64.rpm
                              warning: vmware-tools-esx-8.6.5-2.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949
                              error: Failed dependencies:
                                      vmware-tools-esx-nox >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-libraries-x >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-plugins-desktopEvents >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-plugins-resolutionSet >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-plugins-unity >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-user >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-tools-foundation >= 0:8.6.5 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware_drv.so()(64bit) is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmmouse_drv.so()(64bit) is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-xorg-ipt-vmmouse = 12.6.10.0 is needed by vmware-tools-esx-8.6.5-2.x86_64
                                      vmware-xorg-drv-video = 11.0.2.10 is needed by vmware-tools-esx-8.6.5-2.x86_64
                              vi-admin@itrmvma:~>

                              • 12. Re: vSphere Management Assistant (vMA) 5 Problem update
                                MKguy Virtuoso

                                I had the same issue as you when updating to vMA 5.1.0 1062361 just now.

                                I also used the real Tools package as opposed to the OSP the vMA is being shipped with and the installation crapped itself there.

                                I uninstalled the Tools and installed some earlier version of the OSPs (8.3.12) manually, but it still didn't work. Only manually installing the vmware-open-vm-tools-common-8.3.17-870839.sles11sp2 and vmware-open-vm-tools-kmod-8.3.17-870839.sles11sp2 RPMs, which the update was trying to install, solved this for me.

                                 

                                But something still went wrong and made the update fail:

                                /opt/vmware/var/log/vami/updatecli.log

                                14/05/2013 10:49:02 [INFO] Running /opt/vmware/var/lib/vami/update/data/job/12/test_command

                                Preparing packages for installation...

                                        file /sbin/conf.d/SuSEconfig.glib2 from install of glib2-2.22.5-0.6.1.x86_64 conflicts with file from package glib2-tools-2.28.0-3.6.1.x86_64

                                 

                                Uninstalling the package glib2-tools-2.28.0-3.6.1.x86_64 and an dependency finally made the whole update work out.