10 Replies Latest reply: May 7, 2013 12:34 AM by sxlt2398801 RSS

    USB 3.0 ... Again ...

    JonnyTDI Lurker

      Hi,

       

      First time poster, be gentle.

       

      M/C Alienware M14X 1 x USB 2.0, 2 x USB 3.0

      Host O/S WIndows 7 Ultimate 64 Bi.

      VM Player 5.00

      Guest O/S OpenSuse 12.2

       

      Connecting external drives through the USB 3.0 ports results in the following in the VMWARE log file:

       

      2012-10-29T16:23:37.547Z| vmx| I120: USB: Found device [name:Iomega\ ASMedia vid:059b pid:0570 path:1/9/1 speed:super family:storage virtPath:ehci:0 instanceId:USB\\VID_059B&PID_0570\\0123456789ABCDEF serialnum:0123456789ABCDEF disconnected:1 arbRuntimeKey:5 version:2], connected to [EHCI Port 1]

      ...

      2012-10-29T16:23:46.207Z| vmx| W110: USBGA: Failed to connect device 20000005059b0570, error (4)
      2012-10-29T16:23:46.207Z| vmx| I120: Msg_Post: Warning
      2012-10-29T16:23:46.207Z| vmx| I120: [msg.usb.connectFailedErr] The connection for the USB device "Iomega ASMedia" was unsuccessful. Driver error.

       

      When connecting through the USB 2.0 ... all is fine ...

       

      2012-10-29T17:54:02.699Z| vmx| I120: USB: Found device [name:Iomega\ ASMedia vid:059b pid:0570 path:1/0/0/1 speed:high family:vendor,storage virtPath:ehci:0 instanceId:USB\\VID_0E0F&PID_0001\\0123456789ABCDEF serialnum:0123456789ABCDEF arbRuntimeKey:8 version:2], connected to [EHCI Port 1]

       

      This is a "default" install, and the VM was created using the "USB 3.0" switch.

      I have two completely different USB 3.0 drives, both report exactly the same, so not "drive specific".

       

      Any comments / suggestions / help?

       

      Further information available on request (i.e. a complete clean log file from start up, clean USB 2.0 usage, failed USB 3.0 usage).

       

      JJ

        • 1. Re: USB 3.0 ... Again ...
          a.p. Guru User Moderators vExpert

          Welcome to the Community,

           

          USB 3.0 is only supported with Windows 8 where MS provides native drivers.

           

          André

          • 2. Re: USB 3.0 ... Again ...
            JonnyTDI Lurker

            Hi,

             

            Many thanks for the response ... although I am not sure that this is clear from the release notes ...

             

            From vmplayer 5.0 release notes is the following:

             

            Virtual Hardware Improvements

            This version of VMware Player includes the same virtual hardware improvements included with Workstation. See VMware Workstation 9.0 Release Notes To try new hardware features, you must upgrade the hardware  version of your virtual machine or create a new virtual machine that uses the latest virtual hardware version

             

            and from VMware Workstation 9.0 Release Notes ...

             

            USB 3.0

            Workstation 9 supports attaching USB 3.0 devices to Windows 8 virtual  machines. The latest portable devices use USB 3 (SuperSpeed) to achieve  faster transfer rates for data. USB 3.0 devices such as portable  storage devices and video equipment can be connected directly to Windows  8 and Linux virtual machines that contain in-box drivers USB 3.0  controllers.

             

             

            Does this refer to just Windows 8 or Windws 8 and Linux virtual machines?

            Does this mean that USB 3.0 speed is only achievable in Windows 8 or Windows 8 and Linux virtual machines?

             

            From the switch in the VM Edit Virtual Machine Preferences / USB, if USB 3.0 is selected under the drop down for "USB compatibility: ", there is an "i" note that states "Using USB devices with USB 3.0 controller requires Linux kernel 3.2 or newer" which OpenSuse 12.2 is (3.4 I belive). But to me this definitely looks like a VMware Player issue and not the actual guest O/S issue.

             

            Even if I can get USB 2.0 speed working on the USB 3.0 sockets in the VM would be halfway there. (no difference changing the USB compatibility switch)

             

            Thanks again for the initial response!

             

            JJ

            • 3. Re: USB 3.0 ... Again ...
              ArnoBosch Novice

              Hi JJ,

               

              VMWare seems to support USB 3.0 on a Windows host system only with NEC xHCI-drivers.

              Look at http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1025956

              Now if you have hardware with an Intel chipset onboard it will normally use the Intel xHCI-driver which is not supported.

              That results in the situation that you can just use your USB 2.0 port.

               

              Regards,

              Arno

              (by the way: I have the same problem but no USB 2.0 port on my mainboard....)

              • 4. Re: USB 3.0 ... Again ...
                WDitters Lurker

                The problems on systems with an Intel Extensible USB 3.0 chipset onboard actually extend way past this. Even turning off USB 3.0 in the BIOS does not prevent driver loading error issues in VMs, or device in use issues. Quite an annoyance on systems where for instance internal smartcard readers and fingerprint readers are connected to the USB 2.0 bus. They end up completely unusable in VMs. For me a severe issue that prevents me from migrating from Parallels Workstation to VMware workstation. VMware seriously needs to work on this issue.

                • 5. Re: USB 3.0 ... Again ...
                  jethawk Novice

                  I just went thru a hell that resembles this but might not be covered in the previous posts ...

                   

                  Running on a Win7 x64 system with private (Dell, in this case) USB 3.0 drivers,  VMware Workstation 9.0.1, and guests of Win6.1 (7) and Win5.1 (XP) x86 and x64 configurations.  Tried to Connect (disconnect from host) a USB 2 thumb drive on a USB3 port (where it works fine on the host) connecting to any of the aforementioned guests.  The drive failed to transfer, and sometimes would immediately remount on the host.  This could also be repeated with a USB3 drive (WD MyBook Essential 3TB).  When this experiment is performed on a USB 2 port, all works as you'd want.  May have to move to Win8 on the host ...  The VMware.log snippet from one such attempt is appended.  The essential element appears to be the USB3 port and / and/or its driver on the HOST.

                   

                  GSM  20121119

                   

                  2012-11-19T15:10:08.583-05:00| vmx| I120: USB: Connecting pattern [path:1/9/2 version:2] controller []
                  2012-11-19T15:10:08.583-05:00| vmx| I120: USB: Connecting device 0x2000000b00117788
                  2012-11-19T15:10:08.583-05:00| vmx| I120: USBGW: Write arbitrator op:8 len:8
                  2012-11-19T15:10:08.583-05:00| vmx| I120: MsgHint: msg.usb.generic.stopDevice
                  2012-11-19T15:10:08.583-05:00| vmx| I120+ A USB device is about to be unplugged from the host and connected to this virtual machine. It will first be stopped to enable safe removal. With some devices, the host may display the message "The device can now safely be removed."
                  2012-11-19T15:10:08.583-05:00| vmx| I120+ ---------------------------------------
                  2012-11-19T15:10:08.583-05:00| vmx| I120: USBGW: Write arbitrator op:6 len:17
                  2012-11-19T15:10:09.347-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:19.627-05:00| vmx| W110: USBGA: Failed to connect device 2000000b00117788, error (4)
                  2012-11-19T15:10:19.627-05:00| vmx| I120: Msg_Post: Warning
                  2012-11-19T15:10:19.627-05:00| vmx| I120: [msg.usb.connectFailedErr] The connection for the USB device "Mass Storage" was unsuccessful. Driver error.
                  2012-11-19T15:10:19.627-05:00| vmx| I120: ----------------------------------------
                  2012-11-19T15:10:19.627-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:19.643-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:19.643-05:00| vmx| I120: USB: Disconnecting device 0x2000000b00117788
                  2012-11-19T15:10:19.643-05:00| vmx| I120: USBGW: Disconnecting device: 508BD278 id: 2000000b00117788
                  2012-11-19T15:10:19.643-05:00| vmx| I120: USBGW: Write arbitrator op:7 len:8
                  2012-11-19T15:10:21.811-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:25.945-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:26.148-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:39.580-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13
                  2012-11-19T15:10:39.892-05:00| vmx| I120: USBGW: Write arbitrator op:13 len:13

                  • 6. Re: USB 3.0 ... Again ...
                    ArnoBosch Novice

                    I am running Windows 7 - 64Bit with VMWare 9.01 an Win 7 - 32Bit Host systems.

                    For me the combination of the following three actions worked

                    - updated Intel(R) USB 3.0 eXtensible Host Controller Driver Version 1.0.6.245 released 10/16/2012

                      from http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3467&DwnldID=21129&keyword=host+controller&lang=eng

                      as requested by w3by

                    - updated VMWare Workstation Version 9.0.1 Build 894247 released 11/06/2012

                      from https://my.vmware.com/group/vmware/details?downloadGroup=WKST-901-WIN&productId=293&rPId=3081

                    - I replaced a USB 2.0-Hub which was attached to my computer with a USB 3.0 Hub because I needed the older one someplace else. After this replacement I have a "clean" USB 3.0 configuration. There is no port and no hub with a smaller USB version number attached to my computer.

                    • 7. Re: USB 3.0 ... Again ...
                      geppo12 Lurker

                      I have same problem and I don't find serious form VMWare company support only Windows 8 that is too Young. Many customers still ask Win7 Sp1 as safest microsoft OS. So i think that VMWare should support UBS3 also in windows 7 host

                       

                      Giuseppe

                      • 8. Re: USB 3.0 ... Again ...
                        sxlt2398801 Lurker

                        I use VMware Player 5.02 under windows 8 64 bit system to create a virtual system windows 8 32 bit. I can connect USB 2.0 devices in the host and guest systems and I can use USB 3.0 in the host system. But when I connected the USB 3.0 devices to the guest system, the following message appeared and after I press OK button, the windows 8 32 bit shut down at once.

                        The message is in attachment named as Message .txt.  The log file is zipped in virtual Win 8.zip.

                        Could you tell me how to solve this problem?

                        • 9. Re: USB 3.0 ... Again ...
                          WoodyZ Guru

                          A log file is available in "D:\Virtual Win 8\vmware.log".

                           

                          You can request support.

                           

                          To collect data to submit to VMware technical support, run "vm-support".


                          can you tell me how to solve this problem?

                           

                          It might be more helpful if you at least archive (compress) and attach as a file the mentioned vmware.log file or even do the collect data and attach that file.

                           

                          NOTE: DO NOT copy and paste the contents of the .log file into the body of a reply!  Use the "Use advanced editor" link in the upper right corner of the normal reply window to bring up the Advanced Editor where you'll be able to attach files via the Choose File button or Browse button (depending on Browser) above the Post Message button!

                          • 10. Re: USB 3.0 ... Again ...
                            sxlt2398801 Lurker

                            I have modified my reply as above. Please help me to solve the problem.