1 2 3 4 Previous Next 112 Replies Latest reply on Aug 5, 2015 6:03 AM by dmgeurts Go to original post
      • 15. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
        AlanaA Enthusiast

        This might not be an Nvidia issue but with the Intel open source graphics drivers. To test out  Workstation 9 I just installed Ubuntu 12.04 on my Thinkpad T420s that only has an Intel HD3000 GPU. I installed the S2TC package that acts as an open source replacement for S3TC. For previous Ubuntu releases, the workaround was to just enable reporting of S3TC support. I get the same message in the log file for a Windows 7 guest:

        Disabling 3D on this host due to presence of Mesa DRI driver.  Set mks.gl.allowBlacklistedDrivers = TRUE to override.

         

        The  Mesa DRI driver is used for Intel graphics so I guess Workstation detects this for some reason (ie. a known issue with 3D and Intel graphics on Linux hosts) and disables 3D support.

        I added mks.gl.allowBlacklistedDrivers = TRUE in my .vmx file which stopped the messages about not having 3D support. I power on the VM and get a popup message saying:

        The GPU driver on this host might cause issues with VMware products. If you experience problems, disable 3D  support in the affected virtual machines.

        This isn't a good sign but I click OK. When I try to run the Windows Experience Index test,  workstation crashes during the "Running the Direct3D 9 Aero Assessment" part with a popup message saying:

        VMware Workstation unrecoverable error: (vcpu-0) Unexpected signal: 11

        The guest is then forcibly powered off when I click OK.

        Since Workstation wasn't working for me on my notebook, I removed it and installed it on my desktop running an Ubuntu 12.04 host. It doesn't  have any Intel graphics but an old Nvidia GeForce GTX 260 using the Nvidia proprietary drivers. I was able to run the WEI test for the Windows 7 guest and enable Aero just fine.

         

        Maybe Optimus users might be able to replicate this by going into their BIOS and setting it to use Intel graphics only or Nvidia graphics only. To me, it seems like Workstation 9 has something that 8 didn't have that causes issues with Intel graphics on Linux hosts.

        • 16. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
          CitizenVM Lurker

          Not all Optimus laptops have the option to choose one video card over another in the BIOS.

           

          Hence, we still need to find a solution to this since I'm sure there are "many" Dell laptop owners out there.

           

          Bump for more info....

           

           

          • 17. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
            AlanaA Enthusiast

            From what I've seen so far there seems to be something broken with Workstation 9 and Intel graphics on Linux hosts. So if VMware can fix what broke between Workstation 8 and 9 then the Optimus issues might be fixed as well. I'm sure there are even more users out there using Intel graphics (combined Optimus and Intel GPU users).

             

            I don't know much about Bumblebee but are there options to completely disable the Intel graphics for specific applications? Maybe a away to make Workstation not see the Intel GPU at all?

             

            I want to enable 3D support to get the better UI experience of Aero and Unity 3D in guests and have the UI rendered by the host GPU rather than CPU. Hopefully, this gets fixed soon.

            • 18. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
              LinuxReCon Lurker

              Well, I'm confused that some people writeing, that they was able to use their nvidia card with the help of optimus under VMWare Workstation 8. Under WS8, I have the issue that it reports me (at a start of the VM) that my GPU driver isn't compatible with VMWare, but the VM itself is starting.

              After the startup I can see that the VM was started without Optimus, what means that it is useing the Intel HD card. How did the people managed to get it working with WS8? (I already tried the parameter in the vmx configuration (force blacklisted drivers)).

               

              Under WS9 nothing works at all for me. The reason is, that I have a 3.5 kernel which is totally incompatible to WS9. I just get a stack trace and the system freezes. I already tried the patch for WS9 but that didn't helped. Well, the patch for WS8 and kernel 3.4 and kernel 3.5 works very nice therefor.

               

              Greetings

              • 19. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                TJet18 Novice

                Ah!...ok......

                 

                Here is what I did to get Workstation 8.0.x to run 3D in Ubuntu 12.04.

                First off....if you have installed the nVidia proprietary driver from the nVidia site....bad bad bad!!!...un-install it.

                 

                Now...proceed below:

                 

                1.) You don't have to blacklist anything in /etc/modprobe.d/blacklist.conf...so remove anything you blacklisted to try and get 3D to work.

                 

                2.) Install the nVidia-current drivers from the dedicated PPA

                 

                sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
                sudo apt-get update
                sudo apt-get install nvidia-current

                 

                Reboot to ensure all is working.

                 

                3.) Install bumblebee

                 

                sudo add-apt-repository ppa:bumblebee/stable

                sudo apt-get update
                sudo apt-get install bumblebee bumblebee-nvidia

                 

                Reboot to ensure all is working.

                 

                4,) Install driconf

                 

                sudo apt-get install driconf

                Run the driconf gui in your applications list

                When the gui open's up, go to the "Image Quality" tab

                Ensure the first option "Enable S3TC texture compression even if software support is not available" is set to Yes

                 

                That's it!!

                The next time you run your WIndow 7 VM, you can enable Aero or enable 3D in your Ubuntu VM running Unity or Gnome shell.

                Just ensure that you enable 3D support in your VM configuration.

                 

                This enables 3D support in BOTH the Intel HD card and nVidia card.

                When you run Workstation 8 from the icon....you will be running 3D on the Intel card.

                If you want to run "any" application on the nVidia card...you MUST type optirun <application_name> in a terminal...where <application_name> is the exectable you want to run (i.e. optirun vmplayer, optirun vmware, optirun glxsphere, etc.....)

                 

                Unfortunately...this doesn't work with Workstation 9 for some reason....

                 

                Hope this helps.....Good Luck

                • 20. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                  LinuxReCon Lurker

                  Thanks a lot, this worked ... but only with the Intel HD.

                   

                  Aero is running fine while I'm useing vmware with the Intel HD, but even if I try to start WS8 with "optirun vmware" it is starting the VM itself without the NVidia card just the VMWare Workstation interface runs on the NVidia card. Also, if I try to start a application which needs a little bit more GPU power I can see that the performance is to bad in comparison with my older rig (this rig was running with a weaker NVidia card, but it was running well with VMWare Workstation and some 3D applications).

                  Also, I get the message "The GPU driver currently installed on this host may cause issues with VMware products. If you notice any issues please disable the 3D support in the affected virtual machines." even if I start with "optirun" (or without).

                   

                  How can I go on here?

                  • 21. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                    rashm2k Novice

                    TJet18 that method has been plastered all over the internet. It does not work with ws9 which is why this thread was started> We need a solution for ws9.

                     

                    LinuxReCon when doing my own testing I discovered intel hd and nvidia don't work well in linux together on my openSUSE 12.2 distro (kernel 3.4). If you add nomodeset to the command line parameters of GRUB then the NVIDIA graphics SHOULD work but the Intel HD does not work. So you have two options SLOW host UI or SLOW guest UI with enabling/disabling nomodeset.

                     

                    VMware does not seem to recognise optirun.

                    • 22. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                      EtherealRemnant Lurker

                      I'm having a similar issue with VMWare Player 5 and Workstation 9, however, I don't have Optimus just an HD3000 in my Inspiron N7110. It is extremely frustrating that VMWare won't address this, especially considering that 3D acceleration works with the slower and more hassle-prone VirtualBox :/

                      • 24. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                        dskinner Novice

                        Same here.

                         

                        Running Debian Wheezy with 3.5 kernel on a thinkpad x230, intel HD4000 graphics only on the system. I can get the windows 7 vm to boot with 3D acceleration, dxdiag shows `enabled` for directx, directdraw, etc but within a few minutes, the VM crashes with Unexpected signal: 11 and makes a reference to the vmware tools graphics driver.

                         

                        I do not have aero enabled nor have I tried to enable it.

                         

                        Even though I paid for workstation 9, it's disheartening that the only way to make an official request for support is to also purchase a support contract.

                        • 25. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                          AlanaA Enthusiast

                          You get 30 days of email support for Workstation 9. You just need to fill out the required information in your My VMware profile and register your license key.

                           

                          I did that and I'm currently working with tech support to resolve this or file a bug report. So far they told me to clean install Ubuntu 12.04 which didn't help. Then they told me install the latest Intel graphics package (http://intellinuxgraphics.org/install.html) which also installed the 3.5 kernel. That broke Workstation since 3.5 isn't supported and now I get display corruption. As an FYI, I have an Intel HD 3000 only. I'm waiting on what the support person suggests next. Hopefully, it's finally filing some sort of bug report.

                           

                          Everyone should file a support request if you're within the 30 day period. That's probably a better way for VMware to track this issue.

                          • 26. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                            dskinner Novice

                            there's an (i guess) unofficial patch for the vmware kernel modules that makes them work with the 3.5 kernel (search around on the forums here if you really want to keep the 3.5 kernel for some reason, i have it out of necessitaty for hd4000 graphics). The patch itself is so minor, I'm surprised it wasn't just an update. I have multiple vm's across different OS's without issue on 3.5 kernel right now, aside from 3D graphics not working.

                            • 27. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                              ChandraSystem Novice

                              I just fill out a Suport Request for this issue. I will recommend you all do the same. As AlanaA says: "Everyone should file a support request if you're within the 30 day  period. That's probably a better way for VMware to track this issue.".

                               

                              This thread have about 2700 views. 2700 Suport Request could make them work on the problem (and them solve the problem, of course ).

                               

                              Let's all communicate this problem to technical support! Mourn in this thread is useless.

                              • 28. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                                ChandraSystem Novice

                                I had read somewhere that Workstation 9 3D acceleration work well by installing the latest Intel graphics package from the repository of Stefan Glasenhardt (https://launchpad.net/~glasen/+archive/intel-driver). But that does not work for me.

                                 

                                I spent the morning doing a fresh install:

                                And... the same error!: "Hardware graphics acceleration is not available" and "No 3D support is available from the host".

                                 

                                If that is the Support Request response... does not work (at least for me).

                                 

                                I'm losing too much time with this VMware Workstation 9 update ...

                                • 29. Re: Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card
                                  ninjacoding Novice

                                  Updated my system, but still no luck.

                                   

                                  kernel 3.5.3 (with the patch posted here on the forums)

                                  nvidia drivers 304.48

                                  bumblebee 3.0.1

                                   

                                  optirun runs perfectly now

                                   

                                  But this cursed vmware still insists on not working with: optirun vmware

                                  F*CK!

                                  If glxinfo and other applications (even cuda applications) see the nvidia card, why can't vmware do the same?!

                                   

                                   

                                  Optimus technology is ever increasingly more present in laptops.

                                  Is vmware ignoring this fact?

                                  When will they fix this issue?

                                   

                                   

                                  A shame I only have 6 more days of trial and I won't be able to try anything else.

                                  And I'm not going to pay for a broken product, even more when they don't even provide support for Debian.

                                   

                                  On the other hand, I would only be able to test it if vmware released a new version.

                                   

                                  PLEASE fix this issue!

                                  I want to be a customer.

                                  1 2 3 4 Previous Next