5 Replies Latest reply on Sep 5, 2012 2:20 PM by MarAndreas

    Tiny resolution when running games.

    MrRobville Lurker

      Hello,

       

      I installed VMware player in order to run some ancient games. After setting up Windows XP and 98 they both run great. Also the resolution is native to my computer's (1600X900)

      But when I try to run a game in these VM's it's resolution is tiny, leaving a large black border around it.

      Both of these games don't have any configuration settings so I can't try that. (Gearhead Garage on Win98, and Legoland on Win XP)

      I did find this topic here:

      http://communities.vmware.com/message/860197

       

      but I'm not very technical either and I hate it when people casually say "I fixed it" without specifically pointing out what they actually have done.

       

      So when I read the link to the beginners manual I haven't found any clue either.

      I need to find a configuration file with a .vmx extension.

      Well, these don't exist, only one file with a .vmxf extension.

       

      And when i added the line <vmmouse.present="FALSE"> inside the .vmxf file (assuming it's the file I need) I only get an error message that Win XP can't load.

       

      of course I altered the .vmxf file when I shut down the virtual windows XP.

       

      I really want to get this solved, because I installed VMplayer just to play these nostalgic games. It defeats the purpose if they don't work properly.

       

      Any help is kindly appreciated. (keep in mind I'm very unfammiliar with software like this and altering codes and such)

        • 1. Re: Tiny resolution when running games.
          amzhang0922 Novice

          fast way to open '.vmx' file, right-click the VM name in VM Library, hold the Option(Alt) Key, then you will see 'Open config file in Editor' appear in the menu. Click it. the vmx file will open.

          • 2. Re: Tiny resolution when running games.
            MarAndreas Hot Shot

            This is the VMware Fusion forum, but you say you installed VMware Player - which one is it?

             

            I'm not sure about Fusion, but Player does not do image scaling - if you are running a program that has a fixed resolution, and you want it to fill the screen, you have to change the resolution of the host.

            • 3. Re: Tiny resolution when running games.
              jayden1026 Novice

              You can try to use this method, open the VM's setting panel by 'Virtual machine -> Virtual machine Setting...' when the VM is power off . Select the "Hardware" tab and choose the "Display" item. You can set the resolution in the right panel. After you have set the resolution, start this VM and maximize the window, if the resolution is still tiny, you should try to resize the VM's window size to redraw the window.

              • 4. Re: Tiny resolution when running games.
                MrRobville Lurker

                Thanks a lot for the reactions!

                 

                I have tried setting the resolution at the settings before starting up but sadly it doesn't take effect.

                 

                About the version I have, the desktop Icon aswell as the title of the program is called "VMware Player"

                 

                I also cannot find the 'Open config file in Editor' button when I right click on the VM.

                I only got 4 options:

                . Play virtual Machine

                . Virtual Machine settings...

                . Remove VM from the Library

                . Delete VM from disk

                • 5. Re: Tiny resolution when running games.
                  MarAndreas Hot Shot

                  Alt + Right Click is how it works in Fusion - not in Player.

                   

                  I assume your host OS is some flavor of Windows?

                  In that case, I see two options:

                  1.) Lower the resolution of the host before starting the VM.

                  This can be done automatically using Display Changer - a guide for that is available in the VMware Player Community:

                  http://communities.vmware.com/docs/DOC-16772

                  2.) Upgrade to VMware Workstation.

                  It's a bit pricy, and the "Stretch Guest" option seemed to produce a lot of CPU load last time I tried it (on an older version of Workstation), so you may want to try the 30-day trial first.