11 Replies Latest reply on Jun 28, 2012 5:54 PM by continuum

    WSX on 2003 Sp2 does not work

    continuum Guru
    vExpertCommunity Warriors

      Reading the release notes for the latest build sounds like WSX should work on Windows hosts now.
      Does it work for anybody ?

        • 1. Re: WSX on 2003 Sp2 does not work
          Felix-The-Cat Enthusiast

          Hi Ulli,

          2003 Sp2 -- just 'SP2' or 'R2 SP2'? x64 or x32?

          ------------------------

          Cheers,

          FTC

          • 2. Re: WSX on 2003 Sp2 does not work
            continuum Guru
            vExpertCommunity Warriors

            build 5.2.3790 - 2003 SP2 32bit Enterprise Edition

            • 3. Re: WSX on 2003 Sp2 does not work
              Felix-The-Cat Enthusiast

              Ulli,

               

              Could you please share more details...

               

              What do you mean << WSX on 2003 Sp2 does not work>>

              WSX does not installs?

              WSX does not start?

              WSX does not connect to?

               

              ------------------------

               

              Cheers,

               

              FTC

              • 4. Re: WSX on 2003 Sp2 does not work
                continuum Guru
                Community WarriorsvExpert

                if I connect to the specified port with telnet for example there is nothing listening
                hostd is running , I have one shared VM that is also running,

                 

                 

                > WSX does not installs?

                am I missing something ? - is the feature called "WSX" that worked on last build on Linux hosts a separate download ?

                • 5. Re: WSX on 2003 Sp2 does not work
                  Felix-The-Cat Enthusiast

                  Ulli Hankeln wrote:

                  am I missing something ? - is the feature called "WSX" that worked on last build on Linux hosts a separate download ?

                   

                  WSX-Server.jpg

                  • 6. Re: WSX on 2003 Sp2 does not work
                    Enthusiast

                    Hello,

                     

                    I'm the WSX developer. Let's see if we can figure out what's going on.

                     

                    So first off, just to make sure it's clear, WSX is its own download and is not bundled with the Workstation installer.

                     

                    If you've installed that manually, the next thing to check is if the service is running. This should be in the Administrative Tools -> Services under "VMware WSX."

                     

                    If it's not, and starting it fails, try running it manually (in a DOS box) and see if any errors pop up. It should mention the path to a log file that may have additional info. There may also be something in Administrative Tools -> Event Viewer for the Win32 service initialization.

                     

                    - Christian

                    • 7. Re: WSX on 2003 Sp2 does not work
                      continuum Guru
                      Community WarriorsvExpert

                      ok - wsx service is running though it displays this message in eventlog:

                       

                      The description for Event ID ( 11 ) in Source ( WSX ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:   File "win32serviceutil.pyo", line 791, in ServiceCtrlHandlerEx
                        File "wsx\win32service.pyo", line 22, in SvcStop, <type 'exceptions.AttributeError'>, 'module' object has no attribute 'SERVICE_STOP_PENDING'.

                       

                      using Firefox 13.1 with javascript enabled I see

                       

                      wsx.PNG

                       

                       

                       

                      the home button has no effect
                      the configuration button just allows to add more hosts
                      the rest of the screen is blank

                      • 8. Re: WSX on 2003 Sp2 does not work
                        Enthusiast

                        Sorry for the delay on this.

                         

                        So it looks like WSX itself is up and running, but you don't have any hosts configured, at least not in the screenshot. If you add a Workstation 8/9 or ESXi host, and then click it in the sidebar and log in, what do you see?

                        • 9. Re: WSX on 2003 Sp2 does not work
                          continuum Guru
                          Community WarriorsvExpert

                          If I add the localhost using "localhost" or the IP-address I get a login prompt which hangs for ever

                           

                          wsx2.PNG

                          • 10. Re: WSX on 2003 Sp2 does not work
                            Enthusiast

                            Is your local hostd on the default port of 443, or is it on a custom port? I've seen a bug where, if something else has claimed the port or hostd has been set to another port, it will hang forever (and I'm working on a fix for that).

                             

                            If it is indeed on 443, can you check your browser's JavaScript console logs (open it and then reproduce this) to see if there's any errors popping up?

                            1 person found this helpful
                            • 11. Re: WSX on 2003 Sp2 does not work
                              continuum Guru
                              Community WarriorsvExpert

                              Looks like I hit that bug.
                              The installer did not accept port 443 for hostd - so I switched to 8443.

                               

                              Now that you mentioned it I checked port 443 and saw that Skype uses it per default.
                              Had to disable the skype setting (enabled per default) "use port 80 and 443 for incoming connections"

                               

                              After that changes I can now start a VM and watch it boot  - but the keyboard does not work