11 Replies Latest reply on May 11, 2012 9:03 AM by PPerovic

    enabling 3D acceleration causes problems

    zorgieboy Lurker

      I have host running ubuntu 10.04 x64.

      graphic card integrated Radeon HD 4250.

      using the fglrx driver.

       

      guest running windows 7 x64.

       

      if i enable 3D acceleration, when i start the VM i get this warning:

      "The GPU driver currently installed on this host may cause issues with VMware products. If you notice any issues please disable the 3D support in the affected virtual machines."

       

      and indeed there are problems: task bar is gone, progrems get stuck, panics...

       

      I have a game in the guest requires Direct3D support.

      Is there a way to solve this issue?

        • 1. Re: enabling 3D acceleration causes problems
          dieterm57 Lurker

          @bump

          same issue here. thanks you in advance.

           

          specs:

          host ubuntu 11.10 x64

          guest win xp

          cpu i3 330m

          gpu hd5650m

          @catalyst 12.1

          @driver 8.93-111205a-132081C-ATI

          • 2. Re: enabling 3D acceleration causes problems
            hbato Hot Shot

            What version are you using? I heard there are issues using the current version 4. You might want to try lower versions and see if issues still goes on.

             

             

            Regards, Harold http://imagicon.info/cat/5-59/vmware-wink.gif
            • 3. Re: enabling 3D acceleration causes problems
              dieterm57 Lurker

              Actually I am using vmware workstation 8.0.1 build-528992 and just pushed this thread because I thought this is a related problem.

              @edit: 8.0.2 build-591240 same problem

              • 4. Re: enabling 3D acceleration causes problems
                tetrapackage Enthusiast

                I haven't tried using other GPU than Nvidia, but still, I am not sure if that really is the case to this problem. I just can't see it that way.

                • 5. Re: enabling 3D acceleration causes problems
                  dieterm57 Lurker

                  Btw the problems do not occure if i enable fullscreen mode before launching a 3d application.

                  And I bet the poor performance is due to the fact that the driver does not seem to be supported and everything gets software rendered.

                  • 6. Re: enabling 3D acceleration causes problems
                    hbato Hot Shot

                    You might want to go test it on workstation 7 and see if there's any difference.

                     

                     

                     

                    Regards, Harold http://imagicon.info/cat/5-59/vmware-wink.gif
                    • 7. Re: enabling 3D acceleration causes problems
                      meows Lurker

                      Totally new to Virtual ware programs. Tried it with VMware player. Not real happy atm but figure it is because I do not know how to install it or have the wrong software. I am running Win7 Home Premium 64 bit, Intel 2500 4 core. Nvida GTX 560 Ti. 16 gig ram.

                      I need Direct x 9.c and Direct x 10. as I make 3d games in XP. So i installed the Free program to test it out. win xp 32 bit installed easy, however I could not install directx9.c or directx 10. the video said it was standard VGA. the buttons to change that were greyed out. I could not even upgrade IE6 that was installed in the free player to ie8.

                       

                      so I can understand flustration at not having 3D acceleration

                      What is needed to run directx? meows at techie.com

                      • 8. Re: enabling 3D acceleration causes problems
                        RDPetruska Guru
                        vExpertUser Moderators

                        You need to install the VMware Tools in the guest to get the proper video driver.

                        Note that currently it appears the VMware Tools ISO downloads are not available for Player 4.0.2.  Either install Player 4.0.1 and download/install the the Tools for that version, or download the Workstation 8.0.2 trial and extract the Tools from there.

                        • 9. Re: enabling 3D acceleration causes problems
                          meows Lurker

                          Wow. You sure these guys know what they are doing?

                          Looks like they are moving too fast. Or going through developers like Microsoft did in the early 80's

                          Ok I am totally lost and the web site does not help. they really need to dumb it down.

                           

                          I will see if i can find a download link for the 4.1 version. ( Where is sourceforge when you need it)

                           

                          Many Many thanks for trying to help. This all started with a new MB CPU etc. and using DriverManager web site that toasted my XP install so bad it

                          would not even get past the Bios screen. So i put win7 on but was not thinking at all about compatability with the programming software.

                          ( Its a rule actually., do not get old you forget the important stuff.)

                          So finding VMware was great.. but not letting me install IE8 was the first red flag then not letting me install DirectX was the last.

                          I will try this again.

                          Many thanks Robert. God bless. and Happy Valentine day!

                          • 10. Re: enabling 3D acceleration causes problems
                            effduca Lurker

                            Same issue here... WMware Player 4.0.3 running in Linux OpenSuSE 12.1 (hardware Intel Q6600, ATI HD4650 8Gb RAM etc).. in VM Windows XP Profissional.

                            This message apears only one time (on the first time a run), and disapear in other times (I guess after install VWtools etc)

                            I try run some games thats need DirectX9, but a lot of garbage pops in the screen.. and when I move mouse, some image of games apears (like puzzles in moviment)

                            This was correcterd after I open windosxp.vmx in a text editor and change/add some variables like:

                            mks.enable3d = "TRUE"
                            vmmouse.present = "FALSE

                            I try change video memory to 256Mb but with no sucess.

                            After all fo these changes, the game works perfectly.

                            best hegards

                            • 11. Re: enabling 3D acceleration causes problems
                              PPerovic Lurker

                              Hi according to

                              http://www.felipe-alfaro.org/blog/2006/09/06/ubuntu-edgy-ati-fglrx-dri-3d-acceleration-and-xorg-composite-extension/

                               

                              in xorg.conf add this at the end of file

                               

                              Section "Extensions"
                                      Option "Composite" "false"
                              EndSection
                              
                              

                              if you use ubuntu after this unity will run in 2d mode but u can enable 3d acceleration on  guest windows 7 and will run smoothly

                              At the moment this is only available solution ....

                              Hope that developers will find better solution

                               

                              Regards