1 Reply Latest reply on Nov 28, 2011 8:07 AM by mittim12

    Upgrading vmview 3.1 to 4.6

    StuartB201110141 Novice

      Hi Everyone

       

      I am just asking for a bit of advice on upgrade scenarios.

       

      I have a pair of 3.1 view servers I need to upgrade to 4.6 It isn't just as simple as that. I need to migrate them to 2 new W2K8 64 bit machines also.

       

      The config for the 3.1 is a load balanced pair. However each of the load balanced pair is 32bit and has 1 VCPU and 3 GB RAM.

       

      There are a couple of ways to do it I susupect. The way I am thinking of doing it is this (ensuring a good backup!):

       

      0) Remove one server from load balancer

      1) Upgrade one of the 32 bit servers VCPUs to 2

      2) In place upgrade of a singular host from the pair to 4.6

      3) Add in a replica server (on both new 64 bit machines)

      4) Add hosts into load balancer

      5) Remove 32 bit hosts

      6) Test

       

      Cheers

       

      Stu

        • 1. Re: Upgrading vmview 3.1 to 4.6
          mittim12 Guru
          User Moderators

          Stuart Burns wrote:

           

           

          0) Remove one server from load balancer

          1) Upgrade one of the 32 bit servers VCPUs to 2

          2) In place upgrade of a singular host from the pair to 4.6

          3) Add in a replica server (on both new 64 bit machines)

          4) Add hosts into load balancer

          5) Remove 32 bit hosts

          6) Test

           

          Cheers

           

          Stu

          0)     Why remove one host?

          1)     Why upgrade one to 2 vCPU?   Your only going to get rid of it after the upgrade.  

          2)     That is fine but i would verify you can go straight from 3 to 4.6

          3)     Seems fine

          4)     Seems fine

          5)     Seems fine

          5)     Seems fine

           

          I didn't see anything about Composer or a Security server.   If there are part of the plan make sure to include them.    Also keep in mind when you upgrade the View environmen it's best to have the View services stopped on all of the View connection brokers.  This keeps the environment from replicating different versions of the ADAM database.    Also don't forget about the Events database in 4.6 you will want to set that up.