14 Replies Latest reply on Dec 11, 2011 4:55 AM by uy

    Workstation 8.01 and kernel issues

    ltodd2 Novice

      I just changed my kernel to 2.6.41.1-1.fc15.x86_64 and vmware 8.0.0 will not compile the drivers for the kernel.  I switched back to 2.6.40.6-0.fc15.x86_64 and it worked.  I got the prompt about 8.0.1 update so installed this and now a windows 7 64bit guest will not get an IP.  NAT works but bridged or custom will not.  Im thinking about upgrading tio fedora16 and am guessing that it will be using the 2.6.41.1 kernel so will probably fail.

      The error log contains the following if anyone has any ideas:

       

      2011-11-21T14:23:59.152Z| vthread-3| I120: Log for VMware Workstation pid=23020 version=8.0.0 build=build-471780 option=Release
      2011-11-21T14:23:59.152Z| vthread-3| I120: The process is 64-bit.
      2011-11-21T14:23:59.152Z| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
      2011-11-21T14:23:59.152Z| vthread-3| I120: Host is Linux 2.6.41.1-1.fc15.x86_64 Fedora release 15 (Lovelock)
      2011-11-21T14:23:59.151Z| vthread-3| I120: Msg_Reset:
      2011-11-21T14:23:59.151Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
      2011-11-21T14:23:59.151Z| vthread-3| I120: ----------------------------------------
      2011-11-21T14:23:59.151Z| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
      2011-11-21T14:23:59.151Z| vthread-3| I120: Msg_Reset:
      2011-11-21T14:23:59.151Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
      2011-11-21T14:23:59.151Z| vthread-3| I120: ----------------------------------------
      2011-11-21T14:23:59.151Z| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
      2011-11-21T14:23:59.151Z| vthread-3| I120: Msg_Reset:
      2011-11-21T14:23:59.151Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
      2011-11-21T14:23:59.151Z| vthread-3| I120: ----------------------------------------
      2011-11-21T14:23:59.151Z| vthread-3| I120: PREF Failed to load user preferences.
      2011-11-21T14:23:59.152Z| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-23020.log
      2011-11-21T14:23:59.235Z| vthread-3| I120: modconf query interface initialized
      2011-11-21T14:23:59.235Z| vthread-3| I120: modconf library initialized
      2011-11-21T14:23:59.264Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.267Z| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.267Z| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
      2011-11-21T14:23:59.267Z| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
      2011-11-21T14:23:59.267Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.269Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.275Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.286Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:23:59.286Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.288Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.293Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.306Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:23:59.325Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.327Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.328Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.330Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.332Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.351Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.352Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.354Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.355Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.357Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.359Z| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.359Z| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
      2011-11-21T14:23:59.359Z| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
      2011-11-21T14:23:59.359Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.360Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.366Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.378Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:23:59.400Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.401Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.403Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.404Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.406Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.407Z| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.407Z| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
      2011-11-21T14:23:59.407Z| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
      2011-11-21T14:23:59.407Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.409Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.415Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.427Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:23:59.464Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.466Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.467Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.469Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.471Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.557Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:23:59.557Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:23:59.559Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.567Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:23:59.579Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:23:59.579Z| vthread-3| I120: Building module vmmon.
      2011-11-21T14:23:59.579Z| vthread-3| I120: Extracting the sources of the vmmon module.
      2011-11-21T14:23:59.586Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:01.367Z| vthread-3| I120: Installing module vmmon from /tmp/vmware-root/modules/vmmon.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
      2011-11-21T14:24:01.369Z| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmmon.ko
      2011-11-21T14:24:02.097Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:24:02.097Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:24:02.100Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:02.108Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:02.124Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:24:02.124Z| vthread-3| I120: Building module vmnet.
      2011-11-21T14:24:02.124Z| vthread-3| I120: Extracting the sources of the vmnet module.
      2011-11-21T14:24:02.133Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmnet-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:26.808Z| vthread-3| I120: Failed to compile module vmnet!
      2011-11-21T14:24:26.812Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:24:26.812Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:24:26.814Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:26.821Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:26.835Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:24:26.835Z| vthread-3| I120: Building module vmblock.
      2011-11-21T14:24:26.835Z| vthread-3| I120: Extracting the sources of the vmblock module.
      2011-11-21T14:24:26.844Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:32.204Z| vthread-3| I120: Installing module vmblock from /tmp/vmware-root/modules/vmblock.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
      2011-11-21T14:24:32.205Z| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmblock.ko
      2011-11-21T14:24:32.951Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:24:32.951Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:24:32.952Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:32.959Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:32.973Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:24:32.973Z| vthread-3| I120: Building module vmci.
      2011-11-21T14:24:32.973Z| vthread-3| I120: Extracting the sources of the vmci module.
      2011-11-21T14:24:32.983Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:34.808Z| vthread-3| I120: Installing module vmci from /tmp/vmware-root/modules/vmci.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
      2011-11-21T14:24:34.811Z| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmci.ko
      2011-11-21T14:24:35.580Z| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
      2011-11-21T14:24:35.580Z| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
      2011-11-21T14:24:35.582Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:35.588Z| vthread-3| I120: Your GCC version: 4.6
      2011-11-21T14:24:35.602Z| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
      2011-11-21T14:24:35.602Z| vthread-3| I120: Building module vmci.
      2011-11-21T14:24:35.602Z| vthread-3| I120: Extracting the sources of the vmci module.
      2011-11-21T14:24:35.610Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:36.094Z| vthread-3| I120: Building module vsock.
      2011-11-21T14:24:36.094Z| vthread-3| I120: Extracting the sources of the vsock module.
      2011-11-21T14:24:36.102Z| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vsock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
      2011-11-21T14:24:37.883Z| vthread-3| I120: Installing module vsock from /tmp/vmware-root/modules/vsock.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
      2011-11-21T14:24:37.885Z| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vsock.ko

        • 1. Re: Workstation 8.01 and kernel issues
          xcfman Novice

          I did have the same problem after update FC15 kernel and cannot find any solutions for that. Anybody can help ???

          HERE IS MY LOG WHEN RUNNING VMWARE

          2011-11-22T18:23:57.878+07:00| vthread-3| I120: Log for VMware Workstation pid=3992 version=8.0.0 build=build-471780 option=Release
          2011-11-22T18:23:57.878+07:00| vthread-3| I120: The process is 64-bit.
          2011-11-22T18:23:57.878+07:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
          2011-11-22T18:23:57.878+07:00| vthread-3| I120: Host is Linux 2.6.41.1-1.fc15.x86_64 Fedora release 15 (Lovelock)
          2011-11-22T18:23:57.875+07:00| vthread-3| I120: Msg_Reset:
          2011-11-22T18:23:57.875+07:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
          2011-11-22T18:23:57.875+07:00| vthread-3| I120: ----------------------------------------
          2011-11-22T18:23:57.875+07:00| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: Msg_Reset:
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: ----------------------------------------
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: Msg_Reset:
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: ----------------------------------------
          2011-11-22T18:23:57.877+07:00| vthread-3| I120: PREF Failed to load user preferences.
          2011-11-22T18:23:57.878+07:00| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-3992.log
          2011-11-22T18:23:58.117+07:00| vthread-3| I120: modconf query interface initialized
          2011-11-22T18:23:58.118+07:00| vthread-3| I120: modconf library initialized
          2011-11-22T18:23:58.196+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.204+07:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.204+07:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
          2011-11-22T18:23:58.204+07:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
          2011-11-22T18:23:58.204+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.209+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.229+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.271+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:23:58.272+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.276+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.297+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.337+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:23:58.394+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.400+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.407+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.413+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.419+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.541+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.547+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.553+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.559+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.565+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.583+07:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.583+07:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
          2011-11-22T18:23:58.583+07:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
          2011-11-22T18:23:58.583+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.589+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.610+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.650+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:23:58.727+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.734+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.740+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.746+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.753+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.760+07:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.760+07:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
          2011-11-22T18:23:58.760+07:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
          2011-11-22T18:23:58.761+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:58.765+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.786+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:58.829+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:23:58.932+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.938+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.944+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.950+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:58.956+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:59.148+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:23:59.149+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:23:59.154+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:59.175+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:23:59.216+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:23:59.216+07:00| vthread-3| I120: Building module vmmon.
          2011-11-22T18:23:59.216+07:00| vthread-3| I120: Extracting the sources of the vmmon module.
          2011-11-22T18:23:59.251+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:05.261+07:00| vthread-3| I120: Installing module vmmon from /tmp/vmware-root/modules/vmmon.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
          2011-11-22T18:24:05.272+07:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmmon.ko
          2011-11-22T18:24:07.510+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:24:07.511+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:24:07.516+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:07.537+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:07.580+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:24:07.580+07:00| vthread-3| I120: Building module vmnet.
          2011-11-22T18:24:07.580+07:00| vthread-3| I120: Extracting the sources of the vmnet module.
          2011-11-22T18:24:07.605+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmnet-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:13.850+07:00| vthread-3| I120: Failed to compile module vmnet!
          2011-11-22T18:24:13.861+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:24:13.861+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:24:13.866+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:13.887+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:13.932+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:24:13.932+07:00| vthread-3| I120: Building module vmblock.
          2011-11-22T18:24:13.932+07:00| vthread-3| I120: Extracting the sources of the vmblock module.
          2011-11-22T18:24:13.978+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:20.070+07:00| vthread-3| I120: Installing module vmblock from /tmp/vmware-root/modules/vmblock.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
          2011-11-22T18:24:20.073+07:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmblock.ko
          2011-11-22T18:24:22.292+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:24:22.293+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:24:22.298+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:22.319+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:22.360+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:24:22.360+07:00| vthread-3| I120: Building module vmci.
          2011-11-22T18:24:22.360+07:00| vthread-3| I120: Extracting the sources of the vmci module.
          2011-11-22T18:24:22.393+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:28.778+07:00| vthread-3| I120: Installing module vmci from /tmp/vmware-root/modules/vmci.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
          2011-11-22T18:24:28.785+07:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vmci.ko
          2011-11-22T18:24:30.976+07:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 2.6.41.1-1.fc15.x86_64.
          2011-11-22T18:24:30.976+07:00| vthread-3| I120: Validating path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64
          2011-11-22T18:24:30.981+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:31.002+07:00| vthread-3| I120: Your GCC version: 4.6
          2011-11-22T18:24:31.043+07:00| vthread-3| I120: Header path /lib/modules/2.6.41.1-1.fc15.x86_64/build/include for kernel release 2.6.41.1-1.fc15.x86_64 is valid.
          2011-11-22T18:24:31.043+07:00| vthread-3| I120: Building module vmci.
          2011-11-22T18:24:31.044+07:00| vthread-3| I120: Extracting the sources of the vmci module.
          2011-11-22T18:24:31.080+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:32.803+07:00| vthread-3| I120: Building module vsock.
          2011-11-22T18:24:32.803+07:00| vthread-3| I120: Extracting the sources of the vsock module.
          2011-11-22T18:24:32.835+07:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vsock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.41.1-1.fc15.x86_64/build/include CC=/usr/lib64/ccache/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6.1
          2011-11-22T18:24:39.319+07:00| vthread-3| I120: Installing module vsock from /tmp/vmware-root/modules/vsock.o to /lib/modules/2.6.41.1-1.fc15.x86_64/misc.
          2011-11-22T18:24:39.324+07:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/2.6.41.1-1.fc15.x86_64/misc/vsock.ko

          • 2. Re: Workstation 8.01 and kernel issues
            ltodd2 Novice

            Not sure if I should add this here or not but since all the above I went back to using kernel 2.6.40.6-0.fc15.x86_64 which does allow vmware to work but networking is screwed on it.  If I choose bridge using LAN and WLAN the guest will failt to get an IP.  Choose  NAT and it works but the VM keeps freezing every few mins for a few seconds at a time which is very very annoying.  I have no idea what to look at or what you guys may want from the system to look at so just let me know.

             

            Thanks

            Lee

            • 3. Re: Workstation 8.01 and kernel issues
              uy Enthusiast

              I have the same issue with the same kernel & same vmware version.


              I can add that previously I tested vmware player 4.0 on the same Fedora core it was OK. However that was the previous FC15 kernel.

              Now even vmware player 4.0 (VMware-Player-4.0.0-471780.x86_64.bundle) have problem with this new kernel - 2.6.41.1-1.fc15.x86_64

               

              At install stage no error msg for vmware workstaion 8.01, but when I run it tried to make vmware kernal modules and always failed.

               

              It seems to be a problem at the stage of making modules for vmnet.

               

              My error msg is not the same as yours - I got this (the rest looked OK but some error in this protion)

               

              make[1]: Entering directory `/usr/src/kernels/2.6.41.1-1.fc15.x86_64'
                CC [M]  /tmp/vmware-root/modules/vmnet-only/driver.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/hub.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/userif.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/netif.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/bridge.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/filter.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/procfs.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/smac_compat.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/smac.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetEvent.o
                CC [M]  /tmp/vmware-root/modules/vmnet-only/vnetUserListener.o
              /tmp/vmware-root/modules/vmnet-only/netif.c: In function ‘VNetNetIfSetup’:
              /tmp/vmware-root/modules/vmnet-only/netif.c:149:7: error: ‘struct net_device’ has no member named ‘init’
              /tmp/vmware-root/modules/vmnet-only/netif.c:150:7: error: ‘struct net_device’ has no member named ‘open’
              /tmp/vmware-root/modules/vmnet-only/netif.c:151:7: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
              /tmp/vmware-root/modules/vmnet-only/netif.c:152:7: error: ‘struct net_device’ has no member named ‘stop’
              /tmp/vmware-root/modules/vmnet-only/netif.c:153:7: error: ‘struct net_device’ has no member named ‘get_stats’
              /tmp/vmware-root/modules/vmnet-only/netif.c:154:7: error: ‘struct net_device’ has no member named ‘set_mac_address’
              /tmp/vmware-root/modules/vmnet-only/netif.c:155:7: error: ‘struct net_device’ has no member named ‘set_multicast_list’
              make[2]: *** [/tmp/vmware-root/modules/vmnet-only/netif.o] Error 1
              make[2]: *** Waiting for unfinished jobs....
              make[1]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2
              make[1]: Leaving directory `/usr/src/kernels/2.6.41.1-1.fc15.x86_64'
              make: *** [vmnet.ko] Error 2
              make: Leaving directory `/tmp/vmware-root/modules/vmnet-only'
              Using 2.6.x kernel build system.
              make: Entering directory `/tmp/vmware-root/modules/vmblock-only'
              make -C /lib/modules/2.6.41.1-1.fc15.x86_64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \

               

              my kernel & vmware version are as follows:

              # sha1sum VMware-Workstation-Full-8.0.1-528992.x86_64.bundle
              14a4f66c881a6a163bda0dfcaa3fa1240c061679  /home/uy/vmware/VM/VMware-Workstation-Full-8.0.1-528992.x86_64.bundle
              # uname -a
              Linux uy 2.6.41.1-1.fc15.x86_64 #1 SMP Fri Nov 11 21:36:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
              • 4. Re: Workstation 8.01 and kernel issues
                ltodd2 Novice

                Has anyone else seen this or know a fix or when it will be fixed?

                 

                Thanks

                • 5. Re: Workstation 8.01 and kernel issues
                  uy Enthusiast

                  A tiny good news about this. I created a seperated Fedora 16 and Workstation 8.01 modules complied OK with that. My FC 15 is still not able to have any VM. However I am not able to get pass irritating SELINUX which prevented me from entering my serial number. It kept asking me for root password. Must be permission & SELINUX policy issue which I am not familiar.

                  • 6. Re: Workstation 8.01 and kernel issues
                    ltodd2 Novice

                    uy

                     

                    Are you saying that F16 with the 2.6.41.1 kernel and vmware 8.0.1 works ok but the same kernel on F15 does not for you?

                    • 7. Re: Workstation 8.01 and kernel issues
                      awillerding Lurker

                      I running on Mint Debian with kernel 3.1.0-1-amd64 and getting the following trying to run Workstation 8.01

                       

                      Logging to /tmp/vmware-root/modconfig-13764.log
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      Stopping VMware services:
                         VMware Authentication Daemon                                        done
                         VM communication interface socket family                            done
                         Virtual machine communication interface                             done
                         Virtual machine monitor                                             done
                         Blocking file system                                               failed
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmmon.ko: No such file or directory
                      ERROR: modinfo: could not find module vmnet
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmblock.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vmci.ko: No such file or directory
                      ERROR: modinfo: could not open /lib/modules/3.1.0-1-amd64/misc/vsock.ko: No such file or directory
                      Stopping VMware services:
                         VMware Authentication Daemon                                        done
                         VM communication interface socket family                            done
                         Virtual machine communication interface                             done
                         Virtual machine monitor                                             done
                         Blocking file system                                               failed

                       

                       

                       

                      The log file contains:

                       

                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: Log for VMware Workstation pid=13764 version=8.0.1 build=build-528992 option=Release
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: The process is 64-bit.
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: Host is Linux 3.1.0-1-amd64 Linux Mint Debian Edition
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: Msg_Reset:
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: ----------------------------------------
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: Msg_Reset:
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: ----------------------------------------
                      2011-11-25T09:26:27.676-05:00| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
                      2011-11-25T09:26:27.676-05:00| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-13764.log
                      2011-11-25T09:26:27.711-05:00| vthread-3| I120: modconf query interface initialized
                      2011-11-25T09:26:27.711-05:00| vthread-3| I120: modconf library initialized
                      2011-11-25T09:26:27.746-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.751-05:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.751-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                      2011-11-25T09:26:27.751-05:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
                      2011-11-25T09:26:27.751-05:00| vthread-3| I120: Validating path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.753-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.766-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.791-05:00| vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64 is valid.
                      2011-11-25T09:26:27.791-05:00| vthread-3| I120: Validating path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.793-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.802-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.817-05:00| vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64 is valid.
                      2011-11-25T09:26:27.835-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.838-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.841-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.844-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.846-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.863-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.867-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.871-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.875-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.878-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.881-05:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.881-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                      2011-11-25T09:26:27.881-05:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
                      2011-11-25T09:26:27.881-05:00| vthread-3| I120: Validating path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.884-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.895-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.922-05:00| vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64 is valid.
                      2011-11-25T09:26:27.945-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.949-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.953-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.955-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.956-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:27.958-05:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.958-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                      2011-11-25T09:26:27.958-05:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
                      2011-11-25T09:26:27.958-05:00| vthread-3| I120: Validating path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:27.959-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.968-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:27.985-05:00| vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64 is valid.
                      2011-11-25T09:26:28.027-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:28.031-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:28.035-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:28.038-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:28.039-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.559-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.563-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.566-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.568-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.569-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.571-05:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:31.571-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                      2011-11-25T09:26:31.571-05:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
                      2011-11-25T09:26:31.571-05:00| vthread-3| I120: Validating path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64
                      2011-11-25T09:26:31.574-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:31.585-05:00| vthread-3| I120: Your GCC version: 4.6
                      2011-11-25T09:26:31.606-05:00| vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include for kernel release 3.1.0-1-amd64 is valid.
                      2011-11-25T09:26:31.650-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.654-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.658-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.661-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                      2011-11-25T09:26:31.663-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.

                      • 8. Re: Workstation 8.01 and kernel issues
                        srnhpp Enthusiast

                        Using debain 5...

                         

                        -->

                        vthread-3| I120: Log for VMware  Workstation pid=13764 version=8.0.1 build=build-528992 option=Release
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: The process is 64-bit.
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: Host is Linux 3.1.0-1-amd64 Linux Mint Debian Edition
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: Msg_Reset:
                        2011-11-25T09:26:27.676-05:00|  vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file  "/usr/lib/vmware/settings": No such file or directory.
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: ----------------------------------------
                        2011-11-25T09:26:27.676-05:00|  vthread-3| I120: PREF Optional preferences file not found at  /usr/lib/vmware/settings. Using default values.
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: Msg_Reset:
                        2011-11-25T09:26:27.676-05:00|  vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file  "/root/.vmware/config": No such file or directory.
                        2011-11-25T09:26:27.676-05:00| vthread-3| I120: ----------------------------------------
                        2011-11-25T09:26:27.676-05:00|  vthread-3| I120: PREF Optional preferences file not found at  /root/.vmware/config. Using default values.
                        2011-11-25T09:26:27.676-05:00| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-13764.log
                        2011-11-25T09:26:27.711-05:00| vthread-3| I120: modconf query interface initialized
                        2011-11-25T09:26:27.711-05:00| vthread-3| I120: modconf library initialized
                        2011-11-25T09:26:27.746-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.751-05:00|  vthread-3| I120: Validating path /lib/modules/preferred/build/include  for kernel release 3.1.0-1-amd64
                        2011-11-25T09:26:27.751-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                        2011-11-25T09:26:27.751-05:00|  vthread-3| I120: Failed version test:  /lib/modules/preferred/build/include/linux/version.h not found.
                        2011-11-25T09:26:27.751-05:00|  vthread-3| I120: Validating path  /lib/modules/3.1.0-1-amd64/build/include for kernel release  3.1.0-1-amd64
                        2011-11-25T09:26:27.753-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.766-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.791-05:00|  vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include  for kernel release 3.1.0-1-amd64 is valid.
                        2011-11-25T09:26:27.791-05:00|  vthread-3| I120: Validating path  /lib/modules/3.1.0-1-amd64/build/include for kernel release  3.1.0-1-amd64
                        2011-11-25T09:26:27.793-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.802-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.817-05:00|  vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include  for kernel release 3.1.0-1-amd64 is valid.
                        2011-11-25T09:26:27.835-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.838-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.841-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.844-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.846-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.863-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.867-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.871-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.875-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.878-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.881-05:00|  vthread-3| I120: Validating path /lib/modules/preferred/build/include  for kernel release 3.1.0-1-amd64
                        2011-11-25T09:26:27.881-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                        2011-11-25T09:26:27.881-05:00|  vthread-3| I120: Failed version test:  /lib/modules/preferred/build/include/linux/version.h not found.
                        2011-11-25T09:26:27.881-05:00|  vthread-3| I120: Validating path  /lib/modules/3.1.0-1-amd64/build/include for kernel release  3.1.0-1-amd64
                        2011-11-25T09:26:27.884-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.895-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.922-05:00|  vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include  for kernel release 3.1.0-1-amd64 is valid.
                        2011-11-25T09:26:27.945-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.949-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.953-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.955-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.956-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:27.958-05:00|  vthread-3| I120: Validating path /lib/modules/preferred/build/include  for kernel release 3.1.0-1-amd64
                        2011-11-25T09:26:27.958-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                        2011-11-25T09:26:27.958-05:00|  vthread-3| I120: Failed version test:  /lib/modules/preferred/build/include/linux/version.h not found.
                        2011-11-25T09:26:27.958-05:00|  vthread-3| I120: Validating path  /lib/modules/3.1.0-1-amd64/build/include for kernel release  3.1.0-1-amd64
                        2011-11-25T09:26:27.959-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.968-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:27.985-05:00|  vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include  for kernel release 3.1.0-1-amd64 is valid.
                        2011-11-25T09:26:28.027-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:28.031-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:28.035-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:28.038-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:28.039-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.559-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.563-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.566-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.568-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.569-05:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.1.0-1-amd64.
                        2011-11-25T09:26:31.571-05:00|  vthread-3| I120: Validating path /lib/modules/preferred/build/include  for kernel release 3.1.0-1-amd64
                        2011-11-25T09:26:31.571-05:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
                        2011-11-25T09:26:31.571-05:00|  vthread-3| I120: Failed version test:  /lib/modules/preferred/build/include/linux/version.h not found.
                        2011-11-25T09:26:31.571-05:00|  vthread-3| I120: Validating path  /lib/modules/3.1.0-1-amd64/build/include for kernel release  3.1.0-1-amd64
                        2011-11-25T09:26:31.574-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:31.585-05:00| vthread-3| I120: Your GCC version: 4.6
                        2011-11-25T09:26:31.606-05:00|  vthread-3| I120: Header path /lib/modules/3.1.0-1-amd64/build/include  for kernel release 3.1.0-1-amd64 is valid.that http://imagicon.info/cat/5-59/1.gif

                        • 9. Re: Workstation 8.01 and kernel issues
                          montpelier Lurker

                          I'm seeing exactly this as well ... same Fedora/kernel/VMware workstation version.

                          • 10. Re: Workstation 8.01 and kernel issues
                            uy Enthusiast

                            hi  ltodd2

                             

                             

                            FC16 different kernel. 3.1.2-1.fc16.x86_64

                             

                            But works for the vmware workstaion 8.0.1

                             

                            • 11. Re: Workstation 8.01 and kernel issues
                              uy Enthusiast

                              http://weltall.heliohost.org/wordpress/2011/11/09/vmware-workstation-8-x-player-4-x-virtualbox-fix-for-linux-3-2/


                              http://forums.fedoraforum.org/showpost.php?p=1531955&postcount=6

                               

                              I had read these URLs above and patches seemed to have helped some users. I am not able to get it worked myself, since there wasn't any instructions at the later.

                               

                              For me it did not changed anything, I tried again and it say patch found.

                               

                              But still failed to compile vmnet modules.

                              • 12. Re: Workstation 8.01 and kernel issues
                                ltodd2 Novice

                                uy

                                thanks for the info.  does that mean if i upgrade to f16 i should be ok.  Were the patches for a different fedora / kernel version you were using?

                                • 13. Re: Workstation 8.01 and kernel issues
                                  uy Enthusiast

                                  Yes I meant you will get pass this issue of vmware ws 8.0.1 won't complie vmnet.

                                   

                                  I have some FC16 issues myself.

                                   

                                  It is giving crazy unreliable keystrokes in the KDE konsole program which is my shell. It will stop accepting keystrokes after some time. Or get sluggish responds to keystrokes after few hundred keystrokes. Very annoying! I also had to recompile my ATI video driver quite a bit to see my graphics.

                                  • 14. Re: Workstation 8.01 and kernel issues
                                    uy Enthusiast

                                     

                                    2.6.41.4-1.fc15.x86_64

                                     

                                    I updated to the above (new) kernel today

                                     

                                    VMware Worikstation  (VMware-Workstation-Full-8.0.1-528992.x86_64.bundle) already compliled itself and worked.