2 Replies Latest reply on Nov 19, 2011 11:41 PM by jaymelo2wist

    IP information not propogated to VM?

    jblaaa Lurker

      First I'll start off by saying I just started using VMWare Studio so I'm very new to this. I am using the latest version, 2.5. I have successfully created a build of windows 2008 R2 exported it to an OVA file. 

       

      I went into Vsphere and went to deploy OVF template. The OVF deployment template wizard pops up and begins to wallk me through the setup proccess. It prompts me with the following

       

      1. Location of the OVA file

      2. Verify the OVA file's properties

      3. Which Datacenter I would like to deploy the appliance

      4. Which Host Cluster to deploy to

      5. Which Datastore to deploy to

      6. Thin or Thick Provisioning

      7. Which network vswitch I want to use

      8. Enter my network properties

           Default Gateway

           DNS

           Network IP Address

           Network Mask   

      9. finish and begin deployment

       

      My problem is that I the screen values on #8 are never propogated to the VM? I see a couple threads regarding this and I'm not sure if I'm doing something wrong or if this by design. Why would it prompt you for values it doesn't plan on using? If they're not used, is there a way to get VMStudio to not even prompt the user?

        • 1. Re: IP information not propogated to VM?
          chorgeas Hot Shot

          Since your VM is windows base, you need to write script to retrieve the the ovf property values. i.e. you can retreive the values using vmtoolsd.exe --cmd “info-get guestinfo.ovfEnv” command.

           

          After getting values you can set those values through command line using netsh command.

          http://mattiasgeniar.be/2008/06/24/changing-network-settings-through-the-windows-command-line/

           

          Keep all your batch (.bat) scripts in Windows startup area. So that in first boot it will get executed. But make sure to delete this scripts after everythig gets done.

          Startup area = C:\Documents and Settings\All Users\Start Menu\Programs\Startup [Path may change depending upon Operating System]

          • 2. Re: IP information not propogated to VM?
            jaymelo2wist Novice

            Hi,

            I am also facing the same issue.

             

            But my OS is Debian(Ubuntu) and I am using VSphere 4.1, vServer4.1 and ESX4.1.

             

            Even If I provide network proeperties(/IP/gateway/mask/dns), the values are not getting propogated to my linux vm from the values which I enter

            during network wizard.

             

            Is there a need to get these values from ovf and manually configure IPs using scripts in first boot(even for linux vm) ?

             

            Please provide me inputs on this.