5 Replies Latest reply on May 27, 2012 3:28 PM by WoodyZ

    Default for Serial Port?

    blackpuma Hot Shot

      I have a VM for a project that's gone through several versions of Workstation and (now) Fusion. The project requires a serial port, and when I converted the VM to the latest virtual hardware, the serial port setting was lost in the conversion. I added a new serial device and it works fine.


      The annoyance is that very time the VM starts it asks if I want to append or replace the file. Is there a way to set a default for this? It's not a huge deal right now, but it is irksome.

        • 1. Re: Default for Serial Port?
          Tonyw23 Expert
          VMware Employees

          It's really annoying, I always turn off the serial port when I do not need it to avoid that popup during booting.

          • 2. Re: Default for Serial Port?
            blackpuma Hot Shot

            The serial port is required for the software to run, so disabling it is not an option.

            • 3. Re: Default for Serial Port?
              jessepool Enthusiast
              VMware Employees

              Just noticed this old post. Not sure what version of WS or Fusion you're using, but try setting the following in your .vmx file,


              answer.msg.serial.file.open = "Append"


              Hope that helps.

              • 4. Re: Default for Serial Port?
                abirhasan Hot Shot

                Try to doing that...


                .vmx  file.


                serial1.present = "TRUE"

                serial1.fileType = "pipe"

                serial1.yieldOnMsrRead = "TRUE"

                serial1.startConnected = "TRUE"

                serial1.fileName = "/tmp/dev_com"

                serial1.pipe.endPoint = "client"


                On the target machine I added the following lines to the .vmx file.


                serial0.present = "TRUE"

                serial0.fileType = "pipe"

                serial0.yieldOnMsrRead = "TRUE"

                serial0.startConnected = "TRUE"

                serial0.fileName = "/tmp/dev_com"


                Then started up the target vm, edited the boot.ini file to add "/debugport=COM1 /baudrate=115200".

                Now start up the windbg vm, launch WinDbg, then File | Kernel Debug. Selection serial, COM2, check the box for reconnect.



                abirhasan  http://imagicon.info/cat/5-59/text-smiley.png
                • 5. Re: Default for Serial Port?
                  WoodyZ Guru

                  @abirhasan If you read blackpuma's OP it explicitly states "I added a  new serial device and it works fine." so presenting the configuration information you have has absolutely nothing whatsoever to do with the issue, which is having to answer a message box that appears when  starting/restarting the Virtual Machine to which jessepool had already  provided the correct answer to!