1 2 Previous Next 20 Replies Latest reply on Oct 4, 2011 5:22 AM by MichaelW007 Go to original post
      • 15. Re: KB Article: 1016106 and vSphere ESXi 5
        gopinathan Enthusiast

        I see the KB is updated now. It's a pain to go thru all of te ESX hosts and run the command against each RDM LUN.

        The following link has the PowerCLI script to find the RDM LUN. Hope the same can be extended to run the recommendation in the KB article.

        http://www.virtu-al.net/2008/12/23/list-vms-with-rdm/

        • 16. Re: KB Article: 1016106 and vSphere ESXi 5
          AARCO Lurker

          Hello,

           

          We have QNAP too.  We try de  command:

           

          esxcli nmp satp rule add -d "<naa.deviceid>" -s "VMW_SATP_DEFAULT_AA" -o "disable_ssd"

           

          but this error arises:

          ~ # esxcli nmp satp rule add -d naa.6001405a0f1cc60ddafed4daedbc09df  -s VMW_SATP_DEFAULT_AA -o disable_ssd
          Error: Unknown command or namespace nmp satp rule add

          We have ESXi 5.0 ....

          • 17. Re: KB Article: 1016106 and vSphere ESXi 5
            ileidi Novice

            I have the same problem too. ESXi 5.0 on an HP DL380 G7 with iSCSI Lun on a QNAP 809 U PRO. I have a slow boot time..8 minutes to boot the ESXi:

            2011-09-29T07:01:00.482Z cpu0:4120)ScsiDeviceIO: 2305: Cmd(0x4124003ed900) 0x12, CmdSN 0x43 to dev "naa.600140550c978cedf241d4b5fda8eedb" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x24 0x0.
            2011-09-29T07:01:00.494Z cpu0:4120)ScsiDeviceIO: 2305: Cmd(0x4124003ed900) 0x12, CmdSN 0x43 to dev "naa.600140550c978cedf241d4b5fda8eedb" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x24 0x0.
            2011-09-29T07:01:00.531Z cpu0:4120)NMP: nmp_ThrottleLogForDevice:2318: Cmd 0x12 (0x4124003ed900) to dev "naa.600140550c978cedf241d4b5fda8eedb" on path "vmhba32:C0:T0:L0" Failed: H:0x0 D:0x2 P:0x0 Valid sense data: 0xb 0x24 0x0.Act:NONE

            If i use the command indicated i have this output:

            # esxcli nmp satp rule add -d "naa.600140550c978cedf241d4b5fda8eedb" -s "VMW_SATP_DEFAULT_AA" -o "disable_ssd"

            Error: Unknown command or namespace nmp satp rule add

            Anyone have this problem?
            Best Regards
            Andrea

            • 18. Re: KB Article: 1016106 and vSphere ESXi 5
              MichaelW007 Enthusiast

              Hi Guys,

               

              My fault, sorry, in ESXi 5.0 the esxcli commands changed slightly. Now you need to specify which top level namespace, i.e. esxcli storage, or esxcli network.

               

              So the command you'd run would be:

               

              esxcli storage nmp satp rule add -d "naa.600140550c978cedf241d4b5fda8eedb" -s "VMW_SATP_DEFAULT_AA" -o "disable_ssd"

               

              Sorry that my earlier post was incorrect and neglected to include the "storage" part of the command.

              • 19. Re: KB Article: 1016106 and vSphere ESXi 5
                ileidi Novice

                Hi Micheal,

                 

                I tried to reconnect my QNAP with ESX. I create a Kernel Port (Binding only on vnic0 because i use a nic teaming) i connect the iSCSI Lun and after some minutes (the scan of new storage is very slow) i launch the command from CLI:

                 

                esxcli storage nmp satp rule add -d "naa.600140550c978cedf241d4b5fda8eedb" -s "VMW_SATP_DEFAULT_AA" -o "disable_ssd"

                 

                However nothing change. In the storage adpter section i see the QNAP Lun flapping up and down to death or error operational state

                 

                In the Log file vmkernel.log i have this error now:

                 

                2011-10-04T07:53:21.907Z cpu14:4110)ScsiDeviceIO: 2316: Cmd(0x412441852f40) 0x9e, CmdSN 0x291d to dev "naa.600140550c978cedf241d4b5fda8eedb" failed H:0x5 D:0x0 P:0x0 Possible sense data: 0x0 0x0 0x0.
                2011-10-04T07:53:31.907Z cpu16:4112)ScsiDeviceIO: 2316: Cmd(0x412441852f40) 0x25, CmdSN 0x291e to dev "naa.600140550c978cedf241d4b5fda8eedb" failed H:0x3 D:0x0 P:0x0 Possible sense data: 0x0 0x0 0x0.

                 

                Error code change from 0xb 0x24 0x0 to 0x0 0x0 0x0

                • 20. Re: KB Article: 1016106 and vSphere ESXi 5
                  MichaelW007 Enthusiast

                  Firstly the port group you are binding to can you confirm there is only one active uplink and also no stand by uplinks? All other uplinks must be set to not used. Secondly after applying the SATP rule you should rescan the datastore again. That rule will only help with rescan times, it will not help with boot times. I'm working with VMware on a fix for the slow boot time issue. But the workaround right now is to ensure that all iSCSI initiators and all bound ports have access to log in successfully to the iSCSI targets and to reduce the number or targets used in the environment to as few as possible to ensure faster boot times. If you're seeing the datastore flap something else maybe wrong.

                  1 2 Previous Next