1 2 Previous Next 25 Replies Latest reply on Feb 26, 2015 3:26 AM by MartinGrxx

    installation stops with "can't detect last level cache"

    sysfried Novice

      During installation ESXi 5.0 proccess stops with "can't detect last level cache" message

       

      VMware ESXi 5.0.0 [Releasebuild-469512 x86_64]
      Can't detect the last level cache
      cr0=80010039 cr2=0x0 cr3=0x3e7000 cr4=0x2038
      PCPU0:2048/bootstrap
      PCPU 0: S
      Code start: 0x418013200000 VMK uptime: 0:00:00:00.890
      6 lines of <no symbols> errors
      base fs=0x0 gs=0x418040000000 Kgs=0x0
      No place on disk to dump data.
      Debugger waiting....

       

      switching from LSI based SAS controller to onboard sata3 port didn't change a thing

       

      Oh, here the specs:
      Intel i5 2500
      16 GB RAM
      ASUS P8H67-M board

       

      any ideas?

        • 1. Re: installation stops with "can't detect last level cache"
          Attie Novice

          I had the same problem yesterday! Searching then gave me absolutly nothing useful. Funny you should have the same issue so soon after...

           

          I have attached a photo of the error message (in reality the screen is pink!)

           

          I have tried enabling memory mirroring, and disabling hyperthreading to no avail. My BIOS doesn't appear to have any advanced cache related options.

          Im just about to update the BIOS to latest with my fingers crossed!

           

          Hardware:

          2x Intel Xeon E5530

          Tyan S7025

          16GB RAM (8x 2GB)

          OCZ SSD

           

          Any help would be very much appreciated!

           

          Attie

           

          edit: updating the BIOS had no effect. I'm now going to try ESXi v4

           

          edit 2: whilst installing ESXi v4.1.0 (release build 260247) the server freezes at the "Initiating IOV..." screen.

           

          edit 3: disabling SR-IOV doesn't make a difference

          • 2. Re: installation stops with "can't detect last level cache"
            Attie Novice

            Bump!

             

            Does anyone know of any boot options that we might try, perhaps to disable the use of the "last level cache" whatever it may be!

             

            I have ESXi 5 running on an old AMD Athlon 6000+ machine without any problems (other than the sever lack of any hardware virtualisation support!

            • 3. Re: installation stops with "can't detect last level cache"
              Attie Novice

              After a little digging, the evasive "last level cache" appears to be the L3 in mine and sysfried's CPUs.

              I have run Prime95 in the cache intensive mode without issues, and am currently running Memtest86+ v4.20, again without issues so far... If anyone can suggest an app that will specifically test the L3 cache it would be greatly appreciated!

               

              Memtest reports 8MB of L3 cache (correct), so how come ESXi can't detect it!?

              • 4. Re: installation stops with "can't detect last level cache"
                sysfried Novice

                I've had the CPU run BOINC under full load for weeks. I had Windows7 on it, Ubuntu and I got ESXi 4 working (although I never got the storage to work).

                 

                It definately is not a CPU issue.

                 

                I can try to change the BIOS to use "full power" settings, so the CPU won't throttle down, but that shouldn't be the problem. Anyone from VMware with more insight on this issue?

                 

                Sincerely,

                 

                Sysfried

                • 5. Re: installation stops with "can't detect last level cache"
                  Sascha5000 Lurker

                  Hallo everybody,

                   

                  i have exactly the same problem with my ESXi 5 installation. do you have found any solution yet?

                   

                  thanks and regards

                  • 6. Re: installation stops with "can't detect last level cache"
                    sysfried Novice

                    Hi Sascha.

                     

                    Please post your hardware specs, so we might be able to trace the issue down.

                     

                    Sincerely,

                     

                    Sysfried

                    • 7. Re: installation stops with "can't detect last level cache"
                      Attie Novice

                      @sysfried: I am also fairly content that it is not a hardware issue... This has been my workstation for nearly 2 years now, with zero problems.

                       

                      @Sascha: Im glad it isn't just us! Hopefully if enough people are having this problem, VMWare will do something about it! As sysfried said, hardware specs and any attempts at resolution please!

                      • 8. Re: installation stops with "can't detect last level cache"
                        Attie Novice

                        I have done some more investigation, including disabling all power save modes from within the BIOS, along with hardware prefetcher etc. Nothing has allowed me past the "Can't detect last level cache" error.

                         

                        I decided to investigate ESXi's boot log (press [Esc] at the error message, and then press [L] , [Return] ).

                        Scrolling up a page or two ( [PgUp] / [PgDn] ) I found the following lines:

                         

                        TSC: 3093061528 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0x5a

                        TSC: 3093066456 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0x55

                        TSC: 3093071188 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0xe4

                        TSC: 3093076612 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0x21

                        TSC: 3093081480 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0xca

                        TSC: 3093086196 cpu0:0)CPUIntel: 928: unknown cache size encoding: 0x9

                        <---SNIP--->

                        TSC: 3096000364 cpu0:0)Cpu: 228: numCores 1, numHT 16

                        TSC: 3096005056 cpu0:0)Cpu: 230: L2 cache : size -1, assoc. -1

                        TSC: 3096009796 cpu0:0)Cpu: 232: L3 cache : size -1, assoc. -1

                         

                        Firstly, I would say that the numCores value for my system should be 8 (2x e5530 Xeons), or if it is referring to packages, then 2.

                        Later in the log are entries for cpu1:2049 with the same 'unknown cache size encoding' messages.

                         

                         

                        Can either of you confirm that you are observing the same behavior?

                        • 9. Re: installation stops with "can't detect last level cache"
                          sysfried Novice

                          I've given it another try today. Still the same error.

                           

                          I've ruled out onboard graphics (went for ATI discrete just for the heck), onboard SATA (plugged in only my USB ESXi4 stick), add-on SAS (removed), powersave settings (all set in BIOS to max)

                          Since the LOG is too large to type off, here are the pics:

                          20110913_002.jpg

                          20110913_003.jpg20110913_004.jpg20110913_005.jpg20110913_006.jpg20110913_007.jpg20110913_008.jpg20110913_009.jpg

                           

                          Hopefully someone from VMware will take a look at this.....

                           

                          Sysfried

                          • 10. Re: installation stops with "can't detect last level cache"
                            Attie Novice

                            This is "good" news... as expected we both have the following lines:

                             

                            TSC: 3096005056 cpu0:0)Cpu: 230: L2 cache : size -1, assoc. -1

                            TSC: 3096009796 cpu0:0)Cpu: 232: L3 cache : size -1, assoc. -1

                             

                            Does anyone with a better understanding of the log output have anything to comment?

                            • 11. Re: installation stops with "can't detect last level cache"
                              sysfried Novice

                              Being a bit dissapointed that we haven't gotten an answer from VMware yet, I took the install media and tried another Sandy Bridge based system.

                               

                              To my surprise, the system I never thought would work, does:

                               

                              Intel i3 2300T (dual core low power with HT) with 8 GB S0-DIMM

                              ASUS P8H67-I DELUXE Rev 3.0, Intel Sockel 1155

                               

                              The system that doesn't work has:

                              ASUS P8H67-M Rev 3.0,Sockel 1155, mATX, DDR

                               

                              so, it can't be a Chipset issue. Also since Atti has a totally different system, I doubt the chipset to be the problem.

                               

                              Also, I used the same CD-ROM and drive to install it, so it can't be a media error either.

                               

                              Any thoughts?

                               

                              EDIT: Edited the Rev B3 on the Mainboard name after Atties comment.

                              • 12. Re: installation stops with "can't detect last level cache"
                                Attie Novice

                                I'm also dissapointed, especially as my motherboard is supposed to be "VMware Certified"!

                                 

                                I have also got ESXi installed on another system - my old AMD 6000+, Asus Crosshair system (with no virtualisation support at all) from the same media.

                                You say that it isn't the chipset, but you mentioned that the working system was a rev 3.0 board, whereas the not-working system was not... Could this be an issue, or did you forget to append the "rev 3.0"

                                See:  http://event.asus.com/2011/mb/Identify_B3_Motherboards/

                                 

                                I'm starting to wonder if we perhaps have faulty CPUs or something...

                                 

                                I'm going to try it again today with virtualisation disabled, just to see what happens.... Ill let you know!

                                 

                                Attie

                                • 13. Re: installation stops with "can't detect last level cache"
                                  Attie Novice

                                  I've had the last attempt for now.

                                  I'm really disappointed in the lack of communication/interest from anyone (other than sysfried) on this forum...

                                   

                                  Disabling all virtualisation abilities didnt help, I was presented with the same error message.

                                   

                                  Attie

                                  • 14. Re: installation stops with "can't detect last level cache"
                                    akrysan Novice

                                    Hi all,

                                     

                                    I had the same problem after switching on in BIOS option "Max CPUID Value Limit " to Enable.

                                    Disabling above option help me to install vmware esxi 5.0

                                     

                                    Anatoliy

                                    4 people found this helpful
                                    1 2 Previous Next