1 Reply Latest reply: Sep 25, 2011 7:51 AM by WoodyZ RSS

    Fusion 4 with 10.5.8?

    tsasala Lurker

      I've been searching the forums and tech support and can't find a direct answer.   Can I run Fusion 4 on OS X 10.5.8?