2 Replies Latest reply on Apr 9, 2011 2:26 PM by tomaddox

    Composer service cannot access Soap

    andga Lurker

      Hello,

       

      view composer reports this error when I try to start it.

       

      Failed to perform VMware View Composer module initialization.

      VMware.Sim.CommonLib.Exception.SimVcSubsystemException: Soap exception connecting to VirtualCenter, url = https://XXX:443/sdk ---> System.Web.Services.Protocols.SoapException: Cannot complete login due to an incorrect user name or password.

       

      Recent update is Netapp plugin installation.

      I tried to follow everything reported here: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1024376

      Service is configured to run as localsystem, I tried even to configure a local user that is administrator, granting him rights as dbowner.

      I also reinstalled it using the existing database. Now I am struck at the point where setup tries to start it.

      It is not the database anyway, error message points to SOAP.

      Thank you for your help.

       

      Andrea

       

        • 1. Re: Composer service cannot access Soap
          sdm2841 Novice

          I know this is an old thread but i just ran across this searching for an answer to this exact issue, Failed to perform VMware View Composer module initialization.VMware.Sim.CommonLib.Exception.SimVcSubsystemException: Soap exception connecting to VirtualCenter, url = https://XXXXXXX.XXXX.com:443/sdk ---> System.Web.Services.Protocols.SoapException: Cannot complete login due to an incorrect user name or password.

           

          Prior to this failure, I had run into major problems with the Composer 2.6 upgrade that resulted in my having to create a new SQL database, installing Composer pointing to that DB, then copying over the info from the old database tables to the new one by copying all the rows from the old DB's tables to the new DB. It's important to note that the new DB's SVI_VC_CONFIG_ENTRY table had 2 entries at this point, one that I had copied over from the old DB and one apparently created by the Composer install, I left them both intact and copied the data from the new entry’s ID cell to the appropriate cells in the SVI_DEPLOYMENT_GROUP and SVI_REPLICA tables. The approach worked fine for a week until the servers ran their scheduled reboots at which time Composer failed with the above error. I too tried changing the service logon from Local System to a user with admin rights and got the same error. I then tried to reinstall using the same DB (the one I'd created and copied data to) but got the same message when trying to start services at the end of the installation. Although the problem appeared to point to a SOAP connection error having to do with permissions I looked to my DB knowing that my rights were ok. Finally, I deleted the old record in the SVI_VC_CONFIG_ENTRY table and Composer finished the install and all was well in View Admin returning all Composer functionality. Hope this helps someone avoid the 2 ½ days I burned.

          • 2. Re: Composer service cannot access Soap
            tomaddox Hot Shot

            I just ran afoul of this issue myself while performing an upgrade of vSphere 4.1 and migration to a new vCenter server, which involved migrating the RSA keys from the original server to the new one. The resolution was to perform the key import as the service account under which the vCenter Server service was running, and to do it without the quotation marks. For reference, the View upgrade manual indicates that this is the command:

             

            aspnet_regiis -pi “SviKeyContainer” “path\keys.xml”

             

            I don't know whether removing the quotation marks made a difference, but after everything I went through to upgrade, I'm not going back to find out!