12 Replies Latest reply on Jul 14, 2011 11:08 AM by VM0Sean

    esxi 4.1 freezing at loading module usb

    scmeis1 Novice

       

      Hi All.

       

       

         I am trying to install esxi 4.1. I keep freezing at the "Loading module usb".  I have an asus M4A89GTD PRO/USB3 motherboard, w/ 8 gig of Gskill DDR3 Ram.. i also have an AMD 1055T processor. I have researched as much as i could and thought I had all the issues identified for the install.

       

       

       

       

       

      I have disabled 4 of the 6 cores, turned off USB 3.0, then turned off all on the board services, IE: esata, sound, NIC. etc etc

       

       

       

       

       

      None of this has worked. I have read quite a few times where people have had these chipsets working IE: 890GTD and SB850

       

       

       

       

       

      I also have a Raid 1 set up with my VelociRaptors. I am not quite sure what is going on. I work on ESX all the time, and I have not enountered an issue I was not able to over come.

       

       

       

       

       

      Anyone have some suggestoins?

       

       

       

       

       

      Scott

       

       

        • 1. Re: esxi 4.1 freezing at loading module usb
          nonnac Lurker

          I have a M4A88TD-M/USB3 with a AMD 1055T and 10gigs mem. In order to get it to work i had to disable usb completely and enable ahci for hdds. Not having usb stinks but it works.

          • 2. Re: esxi 4.1 freezing at loading module usb
            henry16 Novice

            Same issue here on AMD Phenom II on Gigabyte GA 870A UD3 w/ 16 GB RAM.

             


            As it turned out, when you change to the console output using Alt-F12 the boot process continues. Use the page-down key to scroll the messages.

             

            If it hangs again just switch back to the yellow screen using Alt-F11 and back again to tty 12.

             


            HTH,

             

            henry

            • 3. Re: esxi 4.1 freezing at loading module usb
              richhenderson Lurker

              I Have the same issue,  I have a Asus M4A88TD -V Evo USB 3 Motherboard.

              I have disabled the usb headers as the above responses but there are still system hangs.   Any ideas

               

              Asus M4A88TD -V Evo Usb 3 MD

              AMD x6 1090T CPU

              8 GB Ram

              250 GB SATA Hard Drive

              • 4. Re: esxi 4.1 freezing at loading module usb
                henry16 Novice

                Did you try changing consoles via Ctl-F1 then Ctl-F8 or F9 or F10 ?

                 

                What do you see?

                 

                Did you disable E1C in the BIOS?

                 

                HTH,

                heinz

                • 5. Re: esxi 4.1 freezing at loading module usb
                  richhenderson Lurker

                  Hi Henry

                   

                  Thanks for your pointer but I tried all manor of settings within the BIOS but I have managed to over come and solve the problem in the last few hours.

                   

                  The MA488TD-V EVO board was shipped with the most recent BIOS and after thinking thinks through I found that if you down grade the BIOS to version 1106 and disable the onboard NIC and use a NIC from the HCL list it all works.  Even USB

                  • 6. Re: esxi 4.1 freezing at loading module usb
                    henry16 Novice

                    Glad it now works for you, Rich!

                     

                    And thanks for the solution, as others will stumble across it, too.

                    I also had to get a stock Intel GBit card to even install esxi 4.1.

                     

                    Cheers,

                    heinz

                    • 7. Re: esxi 4.1 freezing at loading module usb
                      dogcheese Lurker

                      What version is your BIOS .... I have the same board, and have been trying to get this thing going for a bit... Disableing USB etc

                      • 8. Re: esxi 4.1 freezing at loading module usb
                        richhenderson Lurker

                        Hi,  I downgraded my BIOS to version 1106 which is the version after intial release.

                        Did not have to disable anything after that.

                         

                        Hope this helps

                        • 9. Re: esxi 4.1 freezing at loading module usb
                          deanderso Lurker

                          After messing with the various suggestions on numerous threads, I have a working esxi 4.1 install on my m4a88td-m mother board (although I am afraid to reboot it now...)

                           

                          After 4-weeks of messing with this install, these are the things that I learned are:

                           

                          1. DISABLE THE ONBOARD NIC -- it is the root of all problems.  DO NOT THINK THAT THIS PART IS OPTIONAL!!!  I wasted 2-weeks before I gave up on the onboard NIC being involved in any way.
                          2. There are no issues with the USB -- just be patient.  It takes about 6-hours for the install to complete.  The USB "hang" will pass, and USB will work fine when you are done.
                          3. Install a HCL compatible NIC.  The cheap E1000 pci-e Intel card works great -- buy 2 for more joy (about $30 each).
                          4. Install windows xp, vista, or 7 -- don't bother to register it because esxi will destory it.  You just want a windows install connected to the network,
                          5. Run VMWare Go, point it at the Windows install, and go do something else for 4-6 hours.  (Even if it appears hung at usb, or hid, or e1000, or...  It isn't.  It will eventually complete.

                           

                          My whitebox hardware is:

                           

                          • Asus M4A88TD-M USB3
                          • 16 GB ram
                          • AMD Phenom II X6 1075T (All core enabled and accelerated)
                          • 1TB SATA HD

                           

                          I have the following OS's installed on my fully functional esxi:

                           

                          2 - Windows 2008 R2 64

                          Ubuntu Linux 10.1 64

                          Windows 7 64

                           

                          Also, don't worry when the Windows installs seem to get hung-up at the "Expanding Windows files (0%)" -- these installs take forever...  Just be patient, then %complete will eventually move...  Ubuntu installs in a more timely manner.  Even though Windows installs seem to proceed glacially, when they're done, the machines perform very nicely in Remote Desktop (the VMWare Client console always seems sluggish in Windows -- not Ubuntu, though).

                           

                          Hope this helps someone...

                          • 10. Re: esxi 4.1 freezing at loading module usb
                            henry16 Novice

                            My box is very similar to yours, Rich, just a different MB and 2 x 2 TB HD plus one SSD.

                             

                            Interesting idea to disable the onboard NIC!

                             

                            I added the same Intel GBit and card and made the other changes described above.

                            From there on, no delays anymore during install or boot time. Installation took long, maybe 1.5 h, not 4+.

                             

                            No need to install XP or such first. I got an almost pure Linux/BSD/Solaris-hosting ESXi here. 26 guests, half of them running. A separate group for templates, which I then copy via the datastore browser, boot them up and change hostname/IP.

                             

                            HTH,

                            heinz

                            • 11. Re: esxi 4.1 freezing at loading module usb
                              deanderso Lurker

                              Only reason I did the Windows install at the end was because I still couldn't get the dvd install working.  So, I tried the free VMWare Go product which requires windows on the target.  The first time I tried it, it picked up the Onboard NIC in addition to the Intel GBit.  After that, the config file was hosed for the install, and my previous windows install was toast.  So, I threw on an old XP install, and tried again with the internal card disabled.  Now I'm gold.

                               

                              During the installs, mine stops for 20-30 minutes on various things like USB, OHCI-USB, HID, E1000.  I think these are hardware discovery tests that eventually timeout or fail.

                               

                              I am a Windows guy.  I don't feel like sifting through Linux logs to find out what the real problems are.  I am just glad that things are moving forward again.

                              • 12. Re: esxi 4.1 freezing at loading module usb
                                VM0Sean Enthusiast

                                Interesting - I too just setup a MA488TD-M computer but all I had to do was disable E1C.  Install completed very quickly, did not need to disable onboard NIC.  I did put in an e1000 and it was detected and ran very fast.  All in all I was 15 minutes from powering on the first time to running.