8 Replies Latest reply on Jan 29, 2011 3:25 AM by Prabhjot

    Cannot upgrade ESX 4.0 to update 4.1

    Prabhjot Novice

      Hello Everyone,

       

      I am trying to upgrade my ESX servers from 4.0 to 4.1 but I am running into an error.

       

      I have done the following:

      1) Downloaded the update1a package and copied it to the ESX host in the /upgrades folder

      2) Put the host into Maintenance Mode

      3) Logged in to the host via putty

      4) Navigated to the folder with the copied update

      5) Run the following commands: esxupdate --bundle ESX410-201010001.zip stage

      6) Rebooted ESX host, reran the command, still the same error.

       

      When I run the command, I am getting below error on the server.

       

      ESX410-201010001.zip                              #################################################################### [100%]
      The following problems were encountered trying to resolve dependencies:
         No VIB provides 'DriverAPI-9.1' (required by rpm_vmware-esx-drivers-scsi-
         fnic_400.1.1.0.113.2-4vmw.0.1.320092@x86_64)
         No VIB provides 'libipmi.so' (required by rpm_vmware-esx-
         apps_4.1.0-0.1.320092@i386)
         Requested VIB rpm_vmware-esx-pam-config_4.1.0-0.1.320092@i386 conflicts with
         the host

       

      For reference I am using below link. I have additionally installed HP System management tools on the server.

       

      http://communities.vmware.com/people/vmroyale/blog/2009/10/12/single-use-esxupdate-how-to-for-esx-4

       

      Thanks,

      Prabhjot