4 Replies Latest reply on Oct 6, 2010 9:49 PM by deb85

    Secondary VM not starting in Fault-Tolerance

    deb85 Novice

      Hi,

       

      I am new to Vmware ESXi.  I am facing a problem in Fault-Tolerance.

       

       

       

      I have two ESXi 4.1 hosts:-

       

      Their hardware configuration are as follows:-

       

      ESXi 1 - Dell POwerEdge R300, 2CPUs x 2.999 GHz, Intel(R) Xeon(R) CPU E3113 @ 3.00Ghz

      ESXi 2 - Dell POwerEdge R300, 4CPUs x 2.833 GHz, Intel(R) Xeon(R) CPU X3363 @ 2.83Ghz.

       

      I am using Openfiler as iSCSI storage.

       

      vMotion of a VM from both the ESXi hosts worked fine for me.

       

      But the Fault-Tolerance is creating a problem for me.

       

      When my primary is on ESXi 1 and secondary is on ESXi 2. On Rebooting the ESXi 1 (without entering the maintainance mode) the secondary VM on ESXi 2 immediately becomes primary and when the ESXi 1 is up the secondary VM gets restart on it without any manual intervention.

       

      But When my primary is on ESXi 2 and secondary is on ESXi 1. On Rebooting the ESXi 2 (without entering the maintainance mode) the secondary VM on ESXi 1 immediately becomes primary. Now when the ESXi 2 is up the secondary VM does not start on it. ESXi 1 shows an error that "vCenter cannot start the secondary VM. Reason: Cannot complete login to secondary host." The Virtual machine tab on the ESXi 2 shows the status of the VM as normal. But disabling and then enabling the FT on the VM starts the secondary VM on the ESXi 2.

       

       

       

      Thanks in advance.