14 Replies Latest reply: Dec 30, 2009 10:39 PM by TechFan RSS

    Autofit Guest never works ?

    Garhal Novice

      Hi,

       

      No matter which Guest OS I have, Autofit Guest never works, I always have to manually Fit Guest Now ??????

       

       

      I DO have Vmware Tools installed on all guest OS's.

       

       

       

       

       

       

       

       

      Is this a known problem please, or is there some problem on my side ?

       

       

       

       

       

       

       

       

       

      Thanks.

        • 1. Re: Autofit Guest never works ?
          AWo Guru

          Does your guest OS list include Windows systems (W2K, W2K3, XP)?

           


          AWo
          VCP / VMware vEXPERT 2009

          \[:o]===\[o:]

          =Would you like to have this posting as a ringtone on your cell phone?=

          =Send "Posting" to 911 for only $999999,99!=

          • 2. Re: Autofit Guest never works ?
            cdc Hot Shot

            I've had this happen to me from time to time.  Sometimes, it works.  Other times, not so workie.

             

            Although, I have had some success in clicking on "View->Autofit Window" (to toggle it off, if it's on, or on, if it's off, then back off again).  Followed by clicking on "View->Autofit Guest" (to toggle it off, if it's on, then back on, or to toggle it on.)  Also, I've sometimes (after doing the previous 2 things) clicked on "View-Fit Guest Now" to kind of force it into action, and after that it seems to work ... for a time.  However, your mileage may vary.

             

            It's done that for me as far back as I can remember.  Just one of those minor annoyances that I just haven't been upset enough over to bother opening a ticket about it (since I'd have to spend money to do so, with no guarantee that it would be resolved to my satisfaction.)

            • 3. Re: Autofit Guest never works ?
              Joe1948 Enthusiast

               

              Mine is cranky too. What seems to work for me is to minimize VM to taskbar then bring it back up and it opens up to size. I know it sounds dumb.

               

               

              Joe

               

               

               

               

               

              • 4. Re: Autofit Guest never works ?
                JamesConrad Lurker

                Yep. Mine too, except it's even worse with VMWare Workstation 7 and the current VMWare Tools. I can't get it to work under any circumstance no matter what i do. 6.5 worked like magic.

                • 5. Re: Autofit Guest never works ?
                  Enthusiast

                   

                  Can you guys please post your guest operation systems? That will help alot to narrow down the problem.

                   

                   

                   

                   

                   

                  Thanks.

                   

                   

                  • 6. Re: Autofit Guest never works ?
                    Garhal Novice

                     

                    Guest OS's which don't autofit :

                     

                     

                     

                     

                     

                    - Windows XP (SP3)

                     

                     

                    - Windows 7 Pro

                     

                     

                    • 7. Re: Autofit Guest never works ?
                      Enthusiast

                       

                      Hmm...seems a bit strange since I haven't had any problems with Autofit with Windows 7 VM on WS 7. Anyway, can you please try these on a Win 7 VM...

                       

                       

                      a) Is  WS UI -> View -> AutoFit Guest option enabled?

                       

                       

                      b) Does the VM have VMware WDDM driver installed?

                       

                       

                      What exactly happens when you resize the VM window? If possible, can you please post the vmware.log file after you have an unsuccessful "AutoFit" attempt?

                       

                       

                      Thanks.

                       

                       

                      • 8. Re: Autofit Guest never works ?
                        Joe1948 Enthusiast

                         

                        I just was on mine Windows XP guest 32 bit created with WS 6.5 works. Windows 7 ultimate and Vista Ultimate both created in  WS 6.5 and both 64 bit do not resize automatically. If I minimise to taskbar then maximise they come to proper size. The same happens with windows 7 ultimate 7 64 bit created with WS 7. Does it have anything to do with a 64 bit guest ? The guest autofit is enabled. Where do I find the WDDM driver I don't see in device manager or looking around files and I don;t see log file either.

                         

                         

                        Joe

                         

                         

                        • 9. Re: Autofit Guest never works ?
                          Joe1948 Enthusiast

                           

                          I found the log files and am sending them for the 3 that don't autofit.

                           

                           

                          Joe

                           

                           

                          • 10. Re: Autofit Guest never works ?
                            Enthusiast

                             

                            I looked through the log files but nothing seems unusual there. Can you please do the following for the VMs where you are seeing the problem...

                             

                             

                            a) Uninstall tools in the VM.

                             

                             

                            b) Restart the guest.

                             

                             

                            c) Install the tools again.

                             

                             

                            Then do a resize to see if the problem persists. Also, you can check Device Manager ->  Display Adapters to see if the VM is using WDDM driver? Posting the string under Display Adapters here will also help.

                             

                             

                            Thanks.

                             

                             

                            • 11. Re: Autofit Guest never works ?
                              Joe1948 Enthusiast

                               

                              I looked in the display drivers and all that is there is Nvidia Geforce 0900 GT my system video card. I tried uninstalling tools and reinstalling in one of the VM's. When I installed tools I used Typical. It still doesn't autofit automatically.

                               

                               

                              Joe

                               

                               

                              • 12. Re: Autofit Guest never works ?
                                Enthusiast

                                 

                                Thanks.

                                 

                                 

                                By stating "Nvidia Geforce 0900 GT my system video card", I assume you're referring to host graphics card. Could you please check inside the VM and post us what you see under Device Manager -> Display Adapter? It should be something specific to VMware.

                                 

                                 

                                 

                                 

                                 

                                • 13. Re: Autofit Guest never works ?
                                  Joe1948 Enthusiast

                                   

                                  In the VM is shows Vmware SVGA 3D (Microsoft Corporation- WDDM)

                                   

                                   

                                  The host and VM"s with problem are all 64 bit. The 32 bit XP Pro VM is fine.

                                   

                                   

                                  Joe

                                   

                                   

                                  • 14. Re: Autofit Guest never works ?
                                    TechFan Enthusiast

                                    I seem to be having this same issue as well.  It used to work great with VM Server, but it seems like I have had this issue ever since we switched to ESXi 4.0 (I think it was working properly on 3.5).  It happens all the time.  Every time I ask for a console the window seems to start out at the same size.  I can uncheck and recheck fit to guest every time and then it works, but it never seems to open up correctly fitting.  Using newest vSphere Client 4.0 u1.