6 Replies Latest reply on Jun 10, 2010 4:32 PM by pchoi94

    Installing ESXi 4.0

    chimanbhai Novice

      Hello All:

       

      I have just started installing ESX i 4.0 on Dell SC1420,  this is not on HCL but trying anyways.

       

      I got rid of the error that said "Unsupported BIOS setting (CPUID is Limited).  I got rid of error by one of the psoting on this site that advised me on setting the boot options by hitting the TAB key.

       

      The adjusting boot option to  "mboot.c32 vmkernel.gz nocheckCPUIDLimit"

       

      Now I have another issue. It loads and then it hangs and gives following message at booting prompt. 

       

      booting: MBI = 0x00010120,   entry =  0x00100212

       

      I have seen a post on the vmware community when it is possible to load vmware 4.0 esxi.  Has any one run with this issue. ANy answer will be greatly appreciated.  thanks.

       

       

      Regards,

       

       

       

      Patrick

        • 1. Re: Installing ESXi 4.0
          AndreTheGiant Guru User Moderators vExpert

          Have you search for similar issue in whitebox configuration?

          http://www.vm-help.com

          http://ultimatewhitebox.com

           

          Andre

          • 2. Re: Installing ESXi 4.0
            chimanbhai Novice

            Yes, I have for about a week and have not got any further so i desided to put the post on the thread.

            • 3. Re: Installing ESXi 4.0
              chimanbhai Novice

              Hello All:

               

              Ok I was able to install esx i  4.0  on my dell sc1420 finaly. Following post helped me lot. I do not get any error and I was to manage via Vsphere Client.

               

              Thanks to all who have contributed to this coomunity, otherwise I would not have been able to do much. Thanks again.

               

              ****************************************************************************************************************************************************************************

               

               

              "I had to make a couple changes for ESXi 4.0

               

              To get ESX to install successfully on my Precision 370 I did the following;

               

               

              #1 To bypass the initial "CPUID" error as above;

               

               

              1. At the initial bootloader screen (when booting from the ISO), press TAB to edit the boot options

              2. Hold down the left-arrow key to move the cursor back to the

              beginning of the boot options, and add

               

               

              mboot.c32 vmkboot.gz nocheckCPUIDLimit --- vmkernel.gz nocheckCPUIDLimit ........

               

               

              3. Press ENTER.

               

              #2 To allow the installer to recognise/install onto the internal SATA disk

              In the BIOS (Drives | SATA Operation), changed config from Combination

              (SATA/PATA mode) to RAID Autodetect/ATA (RAID if signed drives,

              otherwise ATA)

               

               

               

              On Reboot

               

               

              Hold SHIFT+O at boot screen and enter nocheckCPUIDLimit as a kernel parameter

               

               

              Using vClient

               

               

              Enter Maintenance Mode

               

               

              Configuration > Software > Advanced Settings > VMKernel > Disable checkCPUIDLimit

               

               

              After that everything worked great ! "

               

               

              • 4. Re: Installing ESXi 4.0
                kcpaige Lurker

                UPDATE *******************

                 

                The solution described above does work with ESXi 4; I tried it and it works without a problem.  Still no luck with ESX 4 though

                 

                ******************************************

                 

                 

                I have an old Dell SC 1420 that I was hoping to use as a training platform for ESX 4.  I'm getting that same error as everyone else, "Unsupported BIOS setting (CPUID) is limited. Disable 'limit CPUID value' or 'Support legacy/NT4 OS in BIOS"

                 

                i have tried adding "nocheckCPUIDLimit"  at the beginning and the end of the options list ..with no success.

                 

                I get invalid options errors when adding mboot.c32 vmkboot.gz  vmkernel.gz to the options list.

                 

                **************************

                 

                On my version of ESX 4, I press F2 (not TAB) to view the list of boot options.  The default options look like this:

                 

                initrd=initrd.img vmkopts=debugLogToSerial:1 mem=512M quiet

                 

                If someone can clarify the above suggestion I would appreciate it.  Did the installation work when you literally added "mboot.c32 vmkboot.gz nocheckCPUIDLimit --- vmkernel.gz nocheckCPUIDLimit" to the front of the boot options list?

                 

                Any help or suggestions would be appreciated.

                • 5. Re: Installing ESXi 4.0
                  depping Champion User Moderators VMware Employees

                  I personally always take the easy route. just install linux + vmware workstation and run ESX virtually. works like a charm every time.



                  Duncan

                  VMware Communities User Moderator | VCP | VCDX

                  -


                  Now available: Paper - vSphere 4.0 Quick Start Guide (via amazon.com) | PDF (via lulu.com)

                  Blogging: http://www.yellow-bricks.com | Twitter: http://www.twitter.com/DuncanYB

                  • 6. Re: Installing ESXi 4.0
                    pchoi94 Novice

                    I see a lot of posts around the Internet saying that this solution (which supposedly works for ESXi 3.5) also works for ESXi 4.0.  Am I missing something here?  I'm getting the same issue you're having, i.e. my boot options look like:

                     

                    initrd=initrd.img vmkopts=debugLogToSerial:1 mem=512M quiet

                     

                    Is there a different built of ESXi 4.0 that people are using that still has the same boot options as 3.5?  Or are they just typos saying that they're using version 4.0?