1 2 3 4 Previous Next 48 Replies Latest reply on Jun 10, 2010 5:29 AM by crescendas

    cannot upgrade ESX4 to ESX 4 Update1

    vmwaredownload Enthusiast

      Hi,

       

      After upgrading Vcenter 4 to vCenter 4 Update1 and putting the ESX 4 Update 1  iso into the Update Manager repository

      i created a baseline..when trying to remdiate my ESX 4 hosts, im gettin the following error:

       

      Upgrade is not supported from host version 4.0.0 build 175625 to release version 4.0.0 update 1

      Build 208167

       

      and

        • 1. Re: cannot upgrade ESX4 to ESX 4 Update1
          davisjj Novice

          I am having the same problem.  I followed these steps in attempting the upgrade:

           

          1. Upgrade vCenter (VIM) server (all components) with VMware-VIMSetup-all-4.0.0-208156.iso

          2. Create host upgrade baseline with VMware-VIMSetup-all-4.0.0-208156.iso (did not upload ESXi .zip file, not using ESXi)

          3. Attached baseline to ESX hosts running v4.0.0-175625

          4. Scanned and attempted to remediate, received error: Upgrade is not supported from host version 4.0.0 Build 175625 to release version 4.0.0 Update 1 Build 208167.

           

          Also, can someone tell me where the upgrade files are stored/uploaded to when you create a baseline?  If I wanted to delete the baseline AND the uploaded content/files (to try again), how would I do that?

          • 2. Re: cannot upgrade ESX4 to ESX 4 Update1
            davver Enthusiast

            Hi,

             

            I have the same problem. Upgraded Vcenter to U1 and when i try to upgrade the host, i have the same message.

            The host is incompatible with the update.

             

            Any ideas on this issue?

             

            thx.

             

            Davy

            • 3. Re: cannot upgrade ESX4 to ESX 4 Update1
              chilow Enthusiast

              You need to use the offline-bundle to upgrade an ESX 4.0 host to 4.0U1.  Can your VUM server access the internet? If so, setup ESX 4.x patches to be automatically downloaded to the VUM server and create a new baseline.

               

              Source URL for ESX 4.x patches:  https://hostupdate.vmware.com/software/VUM/PRODUCTION/index.xml

              • 4. Re: cannot upgrade ESX4 to ESX 4 Update1
                chilow Enthusiast

                You need to use the offline-bundle to upgrade an ESX 4.0 host to 4.0U1.  Can your VUM server access the internet? If so, setup ESX 4.x patches to be automatically downloaded to the VUM server and create a new baseline.

                 

                Source URL for ESX 4.x patches:  https://hostupdate.vmware.com/software/VUM/PRODUCTION/index.xml

                • 5. Re: cannot upgrade ESX4 to ESX 4 Update1
                  davver Enthusiast

                  Hi,

                   

                  My VUM Server can reach the internet. The VUM downloaded the U1 rollup.

                  I made a new baseline to upgrade the host. After i attached the baseline, i scan the host and get the message 'host incompatible'.

                   

                  I noticed the download package on the vmware site. I will try the upgrade tomorrow with the package.

                  But it should work with the VUM also?! Or am i wrong?

                   

                  Regards,

                   

                  Davy

                  • 6. Re: cannot upgrade ESX4 to ESX 4 Update1
                    davisjj Novice

                    Thanks.  I have that URL setup (was included with the default configuration I guess). 

                     

                    I am being told by VMWare support that I will need to do the following (manual host-by-host upgrade, so it would seem):

                     

                    *********************************

                    In order to upgrade host download patch to /tmp

                     

                    Then run following commands

                    #cd /tmp

                    #esxupdate --bundle=ESX-4.0.0-update01.zip  update

                    *********************************

                     

                    I am getting ready to try this.

                    • 7. Re: cannot upgrade ESX4 to ESX 4 Update1
                      chilow Enthusiast

                      It should work with VUM, it worked in my test lab. 

                       

                      I...

                      -Updated vCenter4 to update1

                      -Updated VUM to update1

                      -downloaded new VUM client and installed

                      -created a ESX4.0 u1 baseline (fixed) using 'ESX4.0 complete update 1'

                      -attached baseline to test cluster

                      -scanned the two hosts for Patches and extensions

                      -upgraded hosts

                      • 8. Re: cannot upgrade ESX4 to ESX 4 Update1
                        davisjj Novice

                        That's the same path that I followed.  Could it have anything to do with customized partitions on the ESX hosts (mainly some larger than the default size)?  I thought I read somewhere that those could cause an issue during the update process.

                         

                        In any event, the semi-manual update process that support directed me to is working so far (one out of four hosts completed).

                         

                        *********************************

                        In order to upgrade host download patch to /tmp

                         

                        Then run following commands

                        #cd /tmp

                        #esxupdate --bundle=ESX-4.0.0-update01.zip update

                         

                        • 9. Re: cannot upgrade ESX4 to ESX 4 Update1
                          chilow Enthusiast

                          I also modified the partition sizes during the install of ESX 4.0.  Are you using the Cisco Nexus 1000v module?

                          • 10. Re: cannot upgrade ESX4 to ESX 4 Update1
                            davisjj Novice

                            No, we are not using the Nexus (our implementation is still relatively small), but one of our other sites is going to.

                             

                            Ok, I finished up all four hosts and they are happily running Update 1.  Not the ideal process and I would still like to have an explanation from VMWare as to why we had to do it this way, but at least we are current again.

                            • 11. Re: cannot upgrade ESX4 to ESX 4 Update1
                              joshp Hot Shot

                              If you have automatic downloads enabled for VUM you should have an entry in the available patches called "VMware ESX 4.0 Complete Update 1".  All you need is to add the patch to an existing "fixed" baseline or use the default "dynamic" baseline called "Non-Critical Host Patches".  You do not need to create a "Upgrade Baseline", use a "Patch Baseline".  After the patch is applied ESX will be running build 208167.

                              • 12. Re: cannot upgrade ESX4 to ESX 4 Update1
                                davisjj Novice

                                More on this from support:

                                 

                                Using one of two approaches esxupdate command is simple. Reason for VUM gives error message

                                 

                                The conflict is due to a dependency in ESX 4.0 Update 1. When applying this rollup it checks for the latest VEM module. The workaround is to create two baselines, one with Update 1 and the other with the Cisco update.

                                 

                                First remediate the VEM update and then in a second motion apply Update 1.

                                 

                                If these two updates are included in the same remediation process Update 1 seems to be the first attempt and will fail. Update Manager will continue after the Update 1 failure and install the VEM update however result will be an overall failure as some packages could not be installed. A second run of the same baselines will then have to be run to install Update 1.

                                • 13. Re: cannot upgrade ESX4 to ESX 4 Update1
                                  ITCORESYS Enthusiast
                                  chilow wrote:

                                  You need to use the offline-bundle to upgrade an ESX 4.0 host to 4.0U1.  Can your VUM server access the internet? If so, setup ESX 4.x patches to be automatically downloaded to the VUM server and create a new baseline.

                                   

                                  Source URL for ESX 4.x patches:  https://hostupdate.vmware.com/software/VUM/PRODUCTION/index.xml

                                   

                                   

                                  VUM is setup on mine to use that exact patch source, but the "offline-bundle" you speak of is not getting downloaded into my VUM repository and therefore is not visible to add to a baseline.

                                   

                                  Only the ESXi one is downloading.

                                  • 14. Re: cannot upgrade ESX4 to ESX 4 Update1
                                    ITCORESYS Enthusiast
                                    joshp wrote:

                                    If you have automatic downloads enabled for VUM you should have an entry in the available patches called "VMware ESX 4.0 Complete Update 1".  All you need is to add the patch to an existing "fixed" baseline or use the default "dynamic" baseline called "Non-Critical Host Patches".  You do not need to create a "Upgrade Baseline", use a "Patch Baseline".  After the patch is applied ESX will be running build 208167.

                                     

                                    I dont have the entry.

                                     

                                    I do have the "VMware ESXi 4.0 Complete Update 1" entry, not the ESX one though.

                                    1 2 3 4 Previous Next