5 Replies Latest reply on Oct 31, 2009 8:49 PM by imacomputa

    Can't run "vmrun.exe -T ws start ..." as Scheduled Task?

    imacomputa Novice

       

      Hi,

       

      I've been using VMWare Server for a while and would really like replace it with VMWare Workstation since WS has some features that I want / need that Server does not, and I don't have a problem paying for good software. Basically I'm ready to purchase WS, but need to sort out one thing before I lay the money down.

       

      Specifically, I need to be able to start VMs in the background during system startup in a fashion similar to Server - some will need to start before anyone logs on to the host. I am using VMWare Workstation 7 on Windows 7 Ultimate (x64), and one of the ways I have tried to make this work is to create a scheduled task. While I can successfully launch a VM with the vmrun.exe command in a variety of ways (from a runas cmd prompt for instance) the scheduled task method is giving me trouble. It will run fine as a scheduled task so long as the task option to "Run only when user is logged on" option is selected. However when I set it to "Run whether user is logged on or not" (what I actually need), and save it with credentials of the user that owns the VM, it always throws an error when I actually run the task.

       

      I used a .bat file with the exact same command in it to redirect the output to a temp file, and the only error message thrown is simply "Error: Unknown error". The vmrun.exe command is as follows:

       

      "C:\Program Files (x86)\VMware\VMware Workstation\vmrun.exe" -T ws "start" "C:\Users\<USER>\Documents\Virtual Machines\<VM>\<VM>.vmx" "nogui"

       

      Has this type of functionality been intentionally disabled? Any idea how I can work around this and get background VMs running at system startup with or without anyone logged on to the host? Suggestions for alternative methods to using a scheduled task are welcome.

       

       

       

       

       

      Thanks and best regards,

      Nate