1 2 3 4 5 Previous Next 67 Replies Latest reply on Oct 22, 2009 10:38 AM by hiteshhansalia Go to original post
      • 60. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
        abarmot Novice

         

        Pauldg,thanks for your reply!

         

         

        Guys, the problem is solved!! OpenManage is not supported in Windows XP SP2. I found it in documentation.

        Yesterday I installed it on Windows Server 2003 Enterprise SP2 and it worded great!

         

         

        So, before installation you should check your system for compability (http://support.dell.com/support/edocs/software/svradmin/6.1/en/COMPAT/HTML/4admnver.htm).

         

         

        Thanks for all for hep!!

         

         

         

         

         

        • 61. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
          hiteshhansalia Novice

           

          Installation of Dell OpenManage on ESXi 4.0

           

           

          Tools:

           

           

          VMware vSphere CLI     http://communities.vmware.com/community/vmtn/vsphere/automationtools/vsphere_cli

           

           

          ESXi 4.0 Patch:      https://www.vmware.com/mysupport/download/

           

           

          OEM-Dell OpenManage offline Bundle & VIB for ESXi 4.0: Get to local Drive

           

           

          Dell OpenManage Server Administrator Version 6.1 Installed on one windows Machine 

           

           

           

           

          • 1. Prior to completing this all VM Clients need to be shutdown.

          (Also a recommendation is to remove the clients from Auto restart until the installation/upgrade has been completed, then the Auto restart of clients can be configured again).

           

           

           

          • 2. Place ESXi 4.0 Host in "Maintenance Mode"

          • 3. Launch VMware vSphere CLI and change to the BIN directory (CD BIN)

          • 4. Copy the ESXi 4.0 patch downloaded from (https://www.vmware.com/mysupport/download/) to your local drive and run the following command:

           

          vihostupdate.pl --server <ESXi Host IP> --username root --password <root Password> -i -b C:\ESXi400-200906001.zip

           

           

           

          This may take some time for the installation of the patch, once it has returned to the command prompt reboot the Host.

           

           

           

          •5. Copy the OEM-Dell-OpenManage-ESXi_6.1-0000.zip file to your local drive and run the following command:

           

           

          vihostupdate.pl --server <ESXi Host IP> --username root --password <root Password> -i -b C:\oem-dell-openmanage-esxi_6.1-0000.zip

           

           

          This may take some time for the installation of the patch, once it has returned to the command prompt reboot the Host.

           

           

           

          --> ESXi Command to verify both esxi update and dellOm are installed run command 'esxupdate query'

           

           

           

           

          • 6. Open the ESXi Host, click on the Configuration Tab and select "Advance Settings", select "UserVars" and

          change the value of the CIMOEMProvidersEnabled to "1" once this is completed the Host requires a further reboot.

           

           

           

           

           

          •7. Exit Maintenance Mode and reconfigure clients that are required to have a Auto restart setting.

           

          • 8. Access Dell OpenManage Server Administrator Version 6.1 Installed on one windows Machine

            using URL https://<Dell OpenManage Server Administrator Version 6.1&gt;:1311

          once page launches click 'manage remote node' on right corner and tick the Ignore Certificate Warnings and Log in with ESXi Host details, Root  Username & Password

          if problem accessing above URL Verify dell open manage services are running on esxi host SSH:

           

           

          /usr/lib/ext/dell/dataeng status

           

           

          if command above returns services stopped: run command:

           

           

          /usr/lib/ext/dell/dataeng start

           

           

          • 62. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
            LucasAlbers Expert

             

            I found that upgraded systems sometimes had errors when managing in with openmanage.

             

             

            So fresh installs in my experience work better.

             

             

            You need a root password set to login with openmanage.

             

             

            I have never been able to get openmanage to work on the unpatched GA release, I always had to patch up before it started working.

             

             

            I had one system in which I had to uninstall it and reinstall openmanage to get it working.

             

             

            Make sure after you reboot when you are configuring the system that the uservars are set.

             

             

            On two instances I had to set one of the uservars again and reboot again to get it working.

             

             

            • 63. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
              Dano1 Lurker

              Ok, so I'm trying to install the OM as everyone else in this thread.  However, the patch that is mentioned here is older than the build I have installed (let alone the fact the website seems to be down for that particular patch).  I don't think I really need it anyhow; I have factory Dell ESXi v4.0.0 181792 (A01) 2009-08-11 ISO CD, installed to flash.

               

              Do I install this patch dated 7/9/2009 with filename of ESXi400-200906001?  I'm assuming 2009 06 001 is a date of some sort - why it doesn't match the release date I have no idea.

               

              At this point I have chosen not too, I think I'd be going backwards.

               

              This is a fresh install on PowerEdge 1950 with PERC5 (w/2 SATA drives) and no OS - period.

               

              Installed ESXi CD to USB flash drive (1GB Dell)

               

              So the real problem is:

               

              I install the VIB package (in maintenance mode) and I get this error:

               

              vihostupdate.pl --server 1.2.3.4 -i -b oem-dell-openmanage-esxi_6.1-0000.zip

              username: root

              password: blahblah

               

              Install operation failed: Insufficient space available on host (require 4MB and only 2 MB available).

               

               

              My goal:

               

              Remotely install and manage this Dell as if I was not here (although I am where the box is physically) to educate myself for remote management from the earliest point possible.  I want to configure the PERC5 RAID via the CLI/OpenManage and setup my raid settings (in this case RAID 1 since I only have 2 drives).  Once that's done then, create VMFS, then start building host vm's.

               

              What I'm trying to AVOID doing is; being at the physical box and configuring the PERC5 via BIOS.  I want to be able to do this all remotely from home or where-ever.  I can have a monkey plug a flash drive in and turn a server on.

               

              Am I running into an issue with the fact I'm booting from flash?  And / or because I have not setup any disk partitions or raid configuration? I can well imagine it having something to do with flash but I don't know enough to know where to look to see what partition it's trying to install to on the flash or if I can even expand that or not. I know it's not using 1GB worth.

               

              Thanks in advance.

              • 64. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
                s1xth Expert
                VMware Employees

                I have been trying to get OM 6.1 installed for a while, to much work to actually get it working. Dell should be releasing a version with it slipstreamed in soon.

                • 65. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
                  Dano1 Lurker

                   

                  I was hoping that's what the Dell ISO was containing but it doesn't appear so.

                   

                   

                  I really hate waiting for technology to catch up to me. LOL

                   

                   

                  • 66. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
                    Sup3rFly Novice

                     

                    Got OpenManage to work on our ESXi 4 (free) host, thanks to everyone that posted.

                     

                     

                     

                     

                     

                    Does anyone have the free version working with IT Assistant?  Since SNMP can't be enabled, is there anyway for IT Assistant to query the server and report hardware issues?  I thought we could use CIM and scan the host every so many hours but I can't get CIM to work.  Is there a special username/password that must be used?

                     

                     

                     

                     

                     

                    Anyone have IT Assistant working with the free version of ESXi?

                     

                     

                    • 67. Re: installing dell openmanage 6.1 on esxi 4.0 (released.)
                      hiteshhansalia Novice

                       

                      I am not able to get SNMP or other methods to send alerta, only thing i can do is check status using URL /&lt;Dell OpenManage Server Administrator Version 6.1&gt;:1311

                      once page launches click 'manage remote node' on right corner and tick the Ignore Certificate Warnings and Log in with ESXi Host details, Root Username & Password

                       

                       

                      1 2 3 4 5 Previous Next