3 Replies Latest reply on Feb 17, 2011 3:37 AM by MKoenig

    Has anyone been able to create a virtual SCO Open Server 5.0.5

    hwitten Lurker

      I'm using a 5.0.5 iso and Other/Other for os and version. 1GB mem and IDE HD. Have tried a few variations of mem and hd.

       

      It starts to boot but then fails with:

       

      -


      normal boot------- to:

      Loading kernel fd(64)unix.bss

       

      Memory excessively fragmented (inuse map full)

      WARNING: can't allocate page table for pstart

      Loading ram disk image fd(64)rootFS

      Memory excessively fragmented (inuse map full)

      Cannot load ram disk : Unable to allocate memory

       

       

      Any ideas, work-arounds? I only need a basic SCO with Dev system. I'm trying tyo retire an old system, or at least be prepared for when it decides to call it a day so I was hoping I could run a virtual.

       

      Any help greatly appreciated.

       

      heinz

        • 1. Re: Has anyone been able to create a virtual SCO Open Server 5.0.5
          MKoenig Lurker

           

          Create a Virtual Machine with an IDE Harddrive of 2GB(Primary Master, CD-ROM should be Secondary Master), set the RAM to 128MB and add a network card to this machine.

           

           

          Now use the iso image from the install cd to boot from this media.

           

           

          If "Boot:" is displayed on the screen, enter mem 1m-16m there and press <RETURN>

           

           

          Now the virtual machine should boot normal.

           

           

          You need also a image from the install floppy disk to enter the install routine. This image is on the install media. just mount it and install your SCO-Unix.

           

           

          It works really fine.

           

           

          • 2. Re: Has anyone been able to create a virtual SCO Open Server 5.0.5
            hwitten Lurker

            Thanks to your post I was encouraged to try again.

             

            Using a 5.0.5.CD I got to the boot prompt. The mem 1m-16m did not work. Rather than taking it as a configuration it must've been looking for it as a file?

             

            My next tack was to try a boot floppy but had to find a usb floppy drive to create the flp image for Fusion. While waiting for the stores to open next day I did more searching and ran across a post that succeeded loading 5.0.5 using Fusion 1.1.1.

             

            I downloaded the older version and installed it on my MBPro and did an install using 2gb disk, etc, and no mouse. Installed straight off the CD. Copied the virtual file to Fusion 2.0.2 and no problem booting it.

             

            Then I did another install, using a 10gb expanding disk and 256mb of RAM and hi-res mouse. All went well and everything seems to work, sofar anyways. GUI works. Did not mess with trying to adjust screen resolution, etc. Just using the defaults. Dev system installed ok too from the CD. The GUI was a surprising bonus as most of our usage will be telnet and ftp, I.e. text based.

             

            Currently copying the new build to my MacPro. Hopefully it'll go like the last one, I.e. just work.

             

            Thanks again.

            • 3. Re: Has anyone been able to create a virtual SCO Open Server 5.0.5
              MKoenig Lurker

              I have to correct my erlier post.

               

              at the boot: prompt the following string has to be entered to fix the Memory excessively fragmented (inuse map full) bug.

               

              defbootstr mem=1m-16m,16m-128m

               

              I tested this with the VMWare Player 3 on WinXP. I hope it will work also with Fusion for Mac.

               

              Sorry for the late post (2 years later).