1 2 3 Previous Next 37 Replies Latest reply: Mar 13, 2010 5:38 PM by martyfelker RSS

    Windows 7 host, Workstation 6.51 Works fine!

    magic-man Expert

       

      Running Windows 7 as host, all things work fine and faster... Only one small problem that I can see so far with the VMWare install...

       

       

      The __VMWare_User__ account is not hidden from the welcome screen like it used to be and it does not appear in manage users.

       

       

      Other than that, I give it a thumbs up (at least the 32 bit version I am running)...

       

       

       

       

       

      Bill

       

       

        • 1. Re: Windows 7 host, Workstation 6.51 Works fine!
          nextech Hot Shot

           

          Sweet!  Good to know, I was running Windows 7 as a guest VM, but really didn't think Windows 7 would work as a host.  Good to know, thanks for the info!  Have you noticed any other problems at all?

           

           

          I might give it a shot this weekend, and install Windows 7 as a host, just to mess around and tinker with it.  Thanks for the post!

           

           

           

           

           

          • 2. Re: Windows 7 host, Workstation 6.51 Works fine!
            erenken Lurker

             

            I am unable to get USB to work.  I am running x64 for Windows 7.

             

             

            Eric

             

             

            • 3. Re: Windows 7 host, Workstation 6.51 Works fine!
              magic-man Expert
              nextech wrote:

              Sweet! Good to know, I was running Windows 7 as a guest VM, but really didn't think Windows 7 would work as a host.

              Good to know, thanks for the info! Have you noticed any other problems at all?

               

               

               

               

               

               

               

              No real major issues so far. Vista drivers work fine (BUT if Win 7 has a beta driver for a devicem it DOES work better like my NVidia displays on the laptop)...

              PAE works just fine so I have a ramdisk in the area above 3 gigs that 32 bit OSes don't see.

              UAC is much better but has one tiny bug: Set the UAC to the setting that is one up from off. If you turn it off, you lose sidebar.

              UAC is actually liveable now, and I am leaving it enabled. For programs (like autoruns) that make changes to the system, you need to check run as administrator in the shortcut.

              Definately in my opinion, this BETA is faster and more stable out of the box than my custom vista install with all the tweaks!

              I shrunk the C partition on my laptop and put Win 7 on the new partition, just in case. I will probably remove the Vista partition in a week or so as soon as I really stress test Win 7.

              • 4. Re: Windows 7 host, Workstation 6.51 Works fine!
                magic-man Expert

                 

                erenken wrote:

                I am unable to get USB to work. I am running x64 for Windows 7.

                 

                Eric

                You mean as a HOST? On some chipsets, the drivers are not in the beta yet. Download the vista 64 bit drivers for your system board and install in Win 7. Fixed it for me.

                 

                • 5. Re: Windows 7 host, Workstation 6.51 Works fine!
                  erenken Lurker

                  No, I mean USB connection to VMWare.  So VMWare could use the USB device.  Anyway just after I posted this I plugged in a couple other devices and it USB started working.  It installed the VMWare USB driver.  I have had not real problems with Windows 7 in general as a OS or a Host.

                  • 6. Re: Windows 7 host, Workstation 6.51 Works fine!
                    didierw Lurker

                     

                    I'm now running windows server 2008 R2 x64 as a host with vmware 6.51 .. but the network does not work !

                     

                     

                    I was running (on my laptop) windows server 2008 x64 and did an upgrade to windows server 2008 R2 x64 (which is the windows 7 equivalent).

                     

                     

                    Which windows 7 architecture are you running, x86 or x64 ?

                     

                     

                    • 7. Re: Windows 7 host, Workstation 6.51 Works fine!
                      birdie Master

                      Windows 7 is basically a refurbished Vista, or better say Vista SE (second edition). So I'm glad for you and for Microsoft who has gained for free a new beta tester.

                      • 8. Re: Windows 7 host, Workstation 6.51 Works fine!
                        didierw Lurker

                         

                        Un- and re-installing vmware fixed the problem for me now.

                         

                         

                        I can confirm that 6.51 works fine on windows server 2008r2 beta

                         

                         

                         

                         

                         

                        • 9. Re: Windows 7 host, Workstation 6.51 Works fine!
                          jimbo45 Hot Shot

                           

                          Workstation runs just fine on W7 X32. My XP guest runs almost at native speed - this is running a SAP (mini-sap single user test development environment) system with no probles (9GB database on the SAP system). It' s also running Photoshop CS4 acceptably fast and full versions of Microsoft Office

                           

                           

                           

                           

                           

                          W7 (host) any version runs total rings around VISTA.

                           

                           

                           

                           

                           

                          I'm also running a W7 X64 guest - can;t yet run this as a host as I can't get the wired LAN card to work -- the well known "Limited Connectivity" problem  - I've tried a zillion solutions to no avail. (Wireless works however but at work I have to connect to a wired LAN).  The X64 W7 guest also works fine even on a W7 X32 host.

                           

                           

                           

                           

                           

                          Cheers

                           

                           

                           

                           

                           

                          -J

                           

                           

                          • 10. Re: Windows 7 host, Workstation 6.51 Works fine!
                            brant.at.ut Novice

                            Workstation is running great on my Dell OptiPlex 755 desktop under Win7 x64 and a Vista x64 guest.  On my laptop, however (Dell Latitude D620, Win7 x64), I can't get networking to work with x64 guest OS.  Works fine with x32 guest, however.  Already tried reinstalling.  Anyone seeing this yet?

                            • 11. Re: Windows 7 host, Workstation 6.51 Works fine!
                              heikland Lurker

                              Here's how to hide the vmware user account in Windows 7.

                               

                               

                               

                               

                               

                               

                               

                              Regards

                              • 12. Re: Windows 7 host, Workstation 6.51 Works fine!
                                newbie93 Hot Shot

                                I am not surprised.. WIndows 7 is just Vista rebranded with a new UI. Go read the tech articles. That's why it's so stable. It's still not compatible with XP drivers and you can't upgrade from XP->Win7. You need to go XP->Vista->Win7. Since when has MS ever developed a "new" OS in less than a year?

                                • 13. Re: Windows 7 host, Workstation 6.51 Works fine!
                                  pjc007 Novice

                                  Is the issue I had with vmnet0 when running Workstation 6.51 on Windows 7 pre-beta 6801 resolved, or did it 'just work' on 7000 (which is what I'm assuming you're running)?

                                   

                                  My thread describing the issues I had is here, btw: http://communities.vmware.com/thread/179234

                                   

                                  -PJC

                                  • 14. Re: Windows 7 host, Workstation 6.51 Works fine!
                                    magic-man Expert

                                     

                                    pjc007 wrote:

                                    Is the issue I had with vmnet0 when running Workstation 6.51 on Windows 7 pre-beta 6801 resolved, or did it 'just work' on 7000 (which is what I'm assuming you're running)?

                                     

                                    My thread describing the issues I had is here, btw: http://communities.vmware.com/thread/179234

                                     

                                    -PJC

                                     

                                    Just installed it and it ran. Only once did I have issues with vmnet0... I think it was more related to my suspending the VM in Vista AND Win7 without shutting the VM down between sessions.

                                     

                                     

                                    By the way... If you really wanna crash Vista to the point of having to use restore previous settings that worked.... Run the vm in Win7. Suspend the VM. fire up Vista bring up the suspended VM in it... do some heavy web stuff... Crashola! (Yeah, I know... you are not supposed to suspend in one OS and unsuspend in another... But had to have a little fun!!!! Perhaps Workstation should look at the machine ID before restoring from suspend??? (GRIN)

                                     

                                     

                                    1 2 3 Previous Next