12 Replies Latest reply on Feb 17, 2009 9:25 PM by Agasfer

    Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10

    DavidKahn Novice

      Host: Ubuntu AMD64, 8.10

       

      Client: Windows XP Professional

       

       

       

      Ctrl-Alt-Del now shrinks the guest O/S's window and gives up keyboard focus, because Ctrl-Alt is the command to give up focus.  This is a minor inconvenience, though it does force me to use VMware Worstation rather than the VMware Player.

       

       

       

       

      The arrow keys no longer work within Windows.  The down-arrow key open's Window's "Start" menu.

       

       

       

      Shift-Ctrl-C and Shift-Ctrl-V no longer work in Linux Terminal windows (this was true under Hardy, but was ignorable)

       

       

       

       

      Probably more.

       

       

       

       

      There's an article on keyboard mapping, but it ends with Workstation 5.5, and most of the links to additional information do not seem to work.

        • 1. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
          Teejeaux Enthusiast

           

          I seem to be having the same problem with my keyboard. The arrow keys don't work, the delete/insert/home/end/pgup/pgdn keys don't work, and the same as the other guy, the down arrow opens the start menu.  Does anyone else seem to be having this issue?

           

           

           

           

           

          Host: Ubuntu 8.10

           

           

          VM Workstation: 6.5

           

           

          Guest: Windows XP

           

           

          • 2. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
            BassKozz Enthusiast

             

            Having the same problems...

             

             

            I recenlty upgraded from Ubuntu Hardy (8.04) to Intrepid (8.10), and I

            am noticing some wierd keyboard issues with my VMs after the upgrade.

             

             

             

            The main problem I am having is that my arrow keys (up,down,left,right) aren't working...

            When I press up: the VM thinks I am pressing "Print Screen"

            When I press down: the VM thinks I am pressing the windows key (start menu pops up)

            When I press right: nothing happens

            When I press left: the VM thinks I am pressing "Alt"

             

             

             

            When I press the actual windows key, nothing happens. http://communities.vmware.com/images/emoticons/confused.gif

             

             

             

            ---

            VMware Workstation v6.5.0 build-118166

            Host OS: Ubuntu 8.10 (64bit)

            Guest OS: WinXP Sp3 (32bit)

             

             

             

             

             

            1 person found this helpful
            • 3. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
              Teejeaux Enthusiast

              Try this.  Add the following code to your /etc/vmware/config file:

               

              xkeymap.keycode.108 = 0x138 # Alt_R

              xkeymap.keycode.106 = 0x135 # KP_Divide

              xkeymap.keycode.104 = 0x11c # KP_Enter

              xkeymap.keycode.111 = 0x148 # Up

              xkeymap.keycode.116 = 0x150 # Down

              xkeymap.keycode.113 = 0x14b # Left

              xkeymap.keycode.114 = 0x14d # Right

              xkeymap.keycode.105 = 0x11d # Control_R

              xkeymap.keycode.118 = 0x152 # Insert

              xkeymap.keycode.119 = 0x153 # Delete

              xkeymap.keycode.110 = 0x147 # Home

              xkeymap.keycode.115 = 0x14f # End

              xkeymap.keycode.112 = 0x149 # Prior

              xkeymap.keycode.117 = 0x151 # Next

              xkeymap.keycode.78 = 0x46 # Scroll_Lock

              xkeymap.keycode.127 = 0x100 # Pause

              xkeymap.keycode.133 = 0x15b # Meta_L

              xkeymap.keycode.134 = 0x15c # Meta_R

              xkeymap.keycode.135 = 0x15d # Menu

              • 4. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                DavidKahn Novice

                 

                I also noticed that there were some messages during the re-install of Workstation 6.5 after installing Ubuntu 8.10 Intrepid:

                 

                 

                Before it uninstalled:

                 

                Preparing to replace vmware-workstation 6.5.0-118167 (using vmware-workstation_6.5.0-118167_amd64.deb) ...
                [: 7: Illegal number: upgrade

                 

                  During installation:

                 

                Installing VMware Player 2.5.0
                Copying files...
                Configuring...
                Traceback (most recent call last):
                File "/tmp/vmis.T19578/install/vmware-installer/python/lib/logging/handlers.py", line 73, in emit
                if self.shouldRollover(record):
                File "/tmp/vmis.T19578/install/vmware-installer/python/lib/logging/handlers.py", line 146, in shouldRollover
                msg = "%s\n" % self.format(record)
                File "/tmp/vmis.T19578/install/vmware-installer/python/lib/logging/__init__.py", line 630, in format
                return fmt.format(record)
                File "/tmp/vmis.T19578/install/vmware-installer/python/lib/logging/__init__.py", line 421, in format
                s = self._fmt % record.__dict__
                UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 62: ordinal not in range(128)

                 

                My recollection is that the uninstall error message existed with Workstation 6.5 under Ubuntu Gutsy, but that the install error is new to Ubuntu Intrepid.

                 

                 

                Since the VMware Player doesn't have a command to send Ctrl-Alt-Del to the guest O/S, there's no way to log into Windows.  Having no arrow keys makes VMware Workstation unusable under Ubuntu Intrepid.

                 

                 

                I'd call this a critical bug, justifying a new release.

                 

                 

                • 5. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                  Teejeaux Enthusiast

                  Try this.  Add the following code to your /etc/vmware/config file:

                   

                  xkeymap.keycode.108 = 0x138 # Alt_R

                  xkeymap.keycode.106 = 0x135 # KP_Divide

                  xkeymap.keycode.104 = 0x11c # KP_Enter

                  xkeymap.keycode.111 = 0x148 # Up

                  xkeymap.keycode.116 = 0x150 # Down

                  xkeymap.keycode.113 = 0x14b # Left

                  xkeymap.keycode.114 = 0x14d # Right

                  xkeymap.keycode.105 = 0x11d # Control_R

                  xkeymap.keycode.118 = 0x152 # Insert

                  xkeymap.keycode.119 = 0x153 # Delete

                  xkeymap.keycode.110 = 0x147 # Home

                  xkeymap.keycode.115 = 0x14f # End

                  xkeymap.keycode.112 = 0x149 # Prior

                  xkeymap.keycode.117 = 0x151 # Next

                  xkeymap.keycode.78 = 0x46 # Scroll_Lock

                  xkeymap.keycode.127 = 0x100 # Pause

                  xkeymap.keycode.133 = 0x15b # Meta_L

                  xkeymap.keycode.134 = 0x15c # Meta_R

                  xkeymap.keycode.135 = 0x15d # Menu

                   

                  On Tue, Nov 4, 2008 at 11:33 AM, BassKozz

                  • 6. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                    BassKozz Enthusiast

                     

                    Solution Found, type the following into terminal:

                    echo 'xkeymap.nokeycodeMap = true' > ~/.vmware/config

                     

                     

                    Thanks to: https://bugs.launchpad.net/ubuntu/+bug/289098

                    Specifically: https://bugs.launchpad.net/ubuntu/+bug/289098/comments/8

                     

                    You will see the following "Hint" everytime you boot your VM:

                     

                     

                     

                     

                     

                    , but no biggie

                     

                     

                     

                     

                     

                    • 7. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                      DavidKahn Novice

                      BassKoz,

                       

                      Thanks for the information.  You are correct that  adding: xkeymap.nokeycodeMap = true'

                       

                      to VMware's config file splces the problem.  However, I added it to /etc/vmware/config to make it system-wide, rather than to ~/.vmware/config which is personal to my login.

                       

                      I never got the"Hint" popup you displayed, which may mean that I had gotten it before and checked"Never show..." previously, or perhaps because I added the configuration line to the system-wide config file.

                       

                      This feels a lot cleaner than manually setting the keyboard map, as you first suggested.

                       

                      In my searching, I came across the following, useful page: www.vmware.com/support/ws55/doc/ws_devices_keymap_linux_longer.html

                       

                      Now if I can just get VMware to not interfer with using Shift-Ctrl-C and Shift-Ctrl-V to copy and paste into Linux terminal windows, I'll be a totally happy camper.

                       

                      David

                      • 8. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                        johnswb Hot Shot

                         

                        echo 'xkeymap.nokeycodeMap = true' > ~/.vmware/confi

                         

                         

                        This worked for me as well until I use the "Unity" option.  If I arrow up and down in the program menu it works fine in "Unity", but once I open an application the up and down arrow keys do not work.  

                         

                         

                        • 9. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                          aaron552 Novice

                           

                          johnswb wrote:

                          |echo 'xkeymap.nokeycodeMap = true' > ~/.vmware/confi|

                           

                           

                           

                          This worked for me as well until I use the "Unity" option.  If I arrow up and down in the program menu it works fine in "Unity", but once I open an application the up and down arrow keys do not work.  

                           

                          Exact same problem for me. Works in console view, reverts to broken in Unity.

                          This is definitely a critical bug. Needs fixing ASAP.

                          • 10. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                            dath Lurker

                            Another "me too".  Also running 8.10 and now using the individual mappings workaround and it allows me to start Unity, but the mappings don't seem to work in Unity mode.

                            • 11. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                              OrlandoR Lurker

                              Same here,

                               

                              Adding the no keycode hack gives me a second problem.

                              Some special characters don't work (alt gr).

                              • 12. Re: Keyboard in bad shape with Workstation 6.5 running under Ubuntu Intrepid 8.10
                                Agasfer Lurker

                                 

                                David,

                                 

                                 

                                 

                                 

                                 

                                so, were you able to use VmWare after this installation snafu? I am experiencing the same issue...

                                 

                                 

                                 

                                 

                                 

                                TIA