1 2 Previous Next 27 Replies Latest reply on Oct 22, 2009 12:28 PM by csabo

    ICH8 full support (AHCI non-RAID and non-AHCI non-RAID) under ESXi

    Scottish Captain Enthusiast

      Greetings to all.

       

      I've recently managed to "fix" the ata_piix driver included with ESXi so that it recognizes the Intel 965 (and others?)/82801x ICH8 chipset. The included ata_piix.o module will recognize the 8086:2820 and 8086:2825 device ID's of the ICH8 in non-AHCI mode (aka "native" mode) and allow you to use attached SATA drives as vmhba devices. The included simple.map and pci.ids files are setup to recognize the ICH8 in either non-AHCI mode (using ata_piix.o) or AHCI mode (using the stock ahci.o module). This is NOT a patch to simple.map and pci.ids (though those had to be modified anyways), the included ata_piix.o is different from the ata_piix.o included by VMware (so don't bother adding the ICH8 devices to simple.map/pci.ids yourself and wondering why it's not working- the stock ata_piix.o does not support ICH8 properly).

       

      I've wrapped everything up in a custom oem.tgz file that should handle most ICH8 cases regardless. If you are running a ICH7, or ICH9 chipset- DO NOT USE THIS FILE. If you fall under either of /those/ categories, you'll have to manually modify simple.map and pci.ids yourself to get things rolling. Once again, the attached oem.tgz file is for ICH8 chipsets ONLY.

       

      My test rig for this little project is a SFF IBM box running a Core 2 Duo 1.86ghz processor, 4GB of RAM, Q965/GMA3000 graphics, ICH8 (non-AHCI) SATA controller, one 80GB Seagate drive, two Pro/1000 Intel NIC's and an onboard Broadcom BCM5755 NIC. Thusfar, everything in the machine is now supported (including of course the SATA). I've had this particular box sitting here for about 4 hours now installing various VM's and compiling software/benchmarking the OS's under each VM with no ill results. For all intensive purposes, this is a hack and is completely unsupported by anyone including myself- but it works, so hey... I know there's a few other people out there with ICH8 boxes, so this should help you get things rolling if you can't enable AHCI mode.

       

      If you can't figure this stuff out for yourself (what oem.tgz, simple.map, or pci.ids is/are), then I will try to help, but you should be able to figure this stuff out via Google. Yes, it is possible to use this file to actually install ESXi to disk drive (which is what I did) and run off a ICH8 directly (rather then USB boot), but again, this is beyond my willingness to explain here and is documented sufficiently on Google.

       

      Cheers.

      -SC

        1 2 Previous Next